4.4 prerelease pkg rebuild warnings

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

4.4 prerelease pkg rebuild warnings

nrjank
Not sure where this is coming from, but with the 4.3.90, windows zipfile, running a pkg rebuild to get the package list on a fresh install produces:

>> pkg rebuild
warning: pkg: skipping invalid line in DESCRIPTION file
warning: called from
    get_description at line 48 column 9
    rebuild at line 52 column 12
    pkg at line 539 column 25
warning: pkg: skipping invalid line in DESCRIPTION file
warning: called from
    get_description at line 48 column 9
    rebuild at line 52 column 12
    pkg at line 539 column 25
warning: pkg: skipping invalid line in DESCRIPTION file
warning: called from
    get_description at line 48 column 9
    rebuild at line 52 column 12
    pkg at line 539 column 25
warning: pkg: skipping invalid line in DESCRIPTION file
warning: called from
    get_description at line 48 column 9
    rebuild at line 52 column 12
    pkg at line 539 column 25
warning: pkg: duplicate keyword "buildrequires" in DESCRIPTION, ignoring
warning: called from
    get_description at line 59 column 11
    rebuild at line 52 column 12
    pkg at line 539 column 25


afterward the package list does seem correctly populated.
Reply | Threaded
Open this post in threaded view
|

Re: 4.4 prerelease pkg rebuild warnings

John W. Eaton
Administrator
On 04/24/2018 12:47 PM, Nicholas Jankowski wrote:

> Not sure where this is coming from, but with the 4.3.90, windows
> zipfile, running a pkg rebuild to get the package list on a fresh
> install produces:
>
>  >> pkg rebuild
> warning: pkg: skipping invalid line in DESCRIPTION file
> warning: called from
>      get_description at line 48 column 9
>      rebuild at line 52 column 12
>      pkg at line 539 column 25
> warning: pkg: skipping invalid line in DESCRIPTION file
> warning: called from
>      get_description at line 48 column 9
>      rebuild at line 52 column 12
>      pkg at line 539 column 25
> warning: pkg: skipping invalid line in DESCRIPTION file
> warning: called from
>      get_description at line 48 column 9
>      rebuild at line 52 column 12
>      pkg at line 539 column 25
> warning: pkg: skipping invalid line in DESCRIPTION file
> warning: called from
>      get_description at line 48 column 9
>      rebuild at line 52 column 12
>      pkg at line 539 column 25
> warning: pkg: duplicate keyword "buildrequires" in DESCRIPTION, ignoring
> warning: called from
>      get_description at line 59 column 11
>      rebuild at line 52 column 12
>      pkg at line 539 column 25
>
>
> afterward the package list does seem correctly populated.


Thanks, I used the pkg -verbose rebuild and it looks like all of these
are coming from the geometry package.  Can you confirm?  I'll take a
look at patching this in mxe-octave.

jwe
-

Reply | Threaded
Open this post in threaded view
|

Re: 4.4 prerelease pkg rebuild warnings

nrjank
On Tue, Apr 24, 2018 at 1:07 PM, John W. Eaton <[hidden email]> wrote:
Thanks, I used the pkg -verbose rebuild and it looks like all of these are coming from the geometry package.  Can you confirm?  I'll take a look at patching this in mxe-octave.

jwe
-

Yes, all under geometry-3.0.0