Can't install Octave

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install Octave

Filip Mirković
Hello firends form Octave,
I recenty tried to install Octave on my Ubuntu 16.04 via the usual commant 'sudo apt-get install octave'.
Once I did that I encountered an error message stating:
'Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 octave : Depends: libcholmod3.0.6 but it is not going to be installed
          Depends: liboctave4 (= 4.2.1-2~octave~xenial1) but it is not going to be installed
          Depends: libosmesa6 (>= 10.2~) but it is not going to be installed
          Recommends: libopenblas-base but it is not going to be installed or
                      libatlas3-base but it is not going to be installed
E: Unable to correct problems, you have held broken packages.'

I'm eager to hear if there is a solution to this problem and what is it.

You have my thanks in advance!
I look forward to hearing from you.
Sincerely Filip Mirković.


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Can't install Octave

Mike Miller-4
On Mon, Sep 11, 2017 at 16:28:56 +0200, Filip Mirković wrote:

> Hello firends form Octave,
> I recenty tried to install Octave on my Ubuntu 16.04 via the usual commant
> 'sudo apt-get install octave'.
> Once I did that I encountered an error message stating:
> 'Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  octave : Depends: libcholmod3.0.6 but it is not going to be installed
>           Depends: liboctave4 (= 4.2.1-2~octave~xenial1) but it is not
> going to be installed
>           Depends: libosmesa6 (>= 10.2~) but it is not going to be installed
>           Recommends: libopenblas-base but it is not going to be installed
> or
>                       libatlas3-base but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.'
>
> I'm eager to hear if there is a solution to this problem and what is it.
Your Ubuntu 16.04 system has some combination of packages that are
conflicting with each other. This is not an Octave installation problem
but a general package management issue. There are a lot of resources out
there for troubleshooting this kind of problem, please try pursuing some
of them to clean up your system before installing Octave.

Here is an example to get you started:

https://askubuntu.com/q/866667/70254

Installing Octave on a clean Ubuntu 16.04 system works without error.

Good luck,

--
mike

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave

signature.asc (849 bytes) Download Attachment