Can't install packages

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install packages

Dildar Sk
When I am trying install packages by,
>>pkg install -forge package-name
I am getting following errors,

error: get_forge_pkg: package not found: "signal-1.3.2.tar.gz"(tar package
name).  Maybe you meant "fuzzy-logic-toolkit?"
error: called from
    get_forge_pkg at line 84 column 5
    get_forge_download at line 26 column 12
    pkg at line 382 column 29



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-Maintainers-f1638794.html


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: Can't install packages

tmacchant
----- Original Message -----

> From: Dildar Sk
> To: octave-maintainers
> Cc:
> Date: 2018/3/13, Tue 11:50
> Subject: Can't install packages
>
> When I am trying install packages by,
>>> pkg install -forge package-name
> I am getting following errors,
>
> error: get_forge_pkg: package not found: "signal-1.3.2.tar.gz"(tar
> package
> name).  Maybe you meant "fuzzy-logic-toolkit?"
> error: called from
>     get_forge_pkg at line 84 column 5
>     get_forge_download at line 26 column 12
>     pkg at line 382 column 29

Works for me octave-4.2.1 on Ubunutu 16.04.
I can install control and signal packages by

>> pkg install -forge (package-name)

Source Forge site sometimes become unstable state.
Perhaps you met such situation.

Try again

Tatsuro


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: Can't install packages

tmacchant
In reply to this post by Dildar Sk




----- Original Message -----

> From: Tatsuro MATSUOKA
> To: Dildar Sk ; "octave-maintainers
> Date: 2018/3/13, Tue 12:14
> Subject: Re: Can't install packages
>
> ----- Original Message -----
>
>>  From: Dildar Sk
>>  To: octave-maintainers
>>  Cc:
>>  Date: 2018/3/13, Tue 11:50
>>  Subject: Can't install packages
>>
>>  When I am trying install packages by,
>>>>  pkg install -forge package-name
>>  I am getting following errors,
>>
>>  error: get_forge_pkg: package not found:
> "signal-1.3.2.tar.gz"(tar
>>  package
>>  name).  Maybe you meant "fuzzy-logic-toolkit?"
>>  error: called from
>>      get_forge_pkg at line 84 column 5
>>      get_forge_download at line 26 column 12
>>      pkg at line 382 column 29
>
> Works for me octave-4.2.1 on Ubunutu 16.04.
> I can install control and signal packages by
>
>>>  pkg install -forge (package-name)
>
> Source Forge site sometimes become unstable state.
> Perhaps you met such situation.
>
> Try again
>
> Tatsuro

If you cannot install -forge option your re-try,
(sometimes happens due to network situation)
workaround is to download package tar.gz files via
https://sourceforge.net/projects/octave/files/Octave%20Forge%20Packages/Individual%20Package%20Releases/

and execute

>> pkg install (package name)-(version).tar.gz

HTH

Tatsuro



-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------