Quantcast

Can't use pkg on Octave 4.2.1 MacOS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can't use pkg on Octave 4.2.1 MacOS

franck
Hi everybody ,

I have a problem to use PKG with octave… 
Octave have been installed with MacPort and the pkg too. 

For example : pkg io 
- Pkg loading is ok 
- Pkg Using doesn’t work : 
- just trying to make a simple xls file with the fonction xlswrite, it prompts me this : 

error :’col2num’ undefined near line 49 column 10 
error: called from
parse_sp_range at line 49 column8
xlswrite at line 185 column 34

But I have previously install octave 4.0.3, and it worked with the bundle version … I can’t use the bundle version because I have to launch Octave without the GUI… 


Thank you for your Help 

Franck 

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't use pkg on Octave 4.2.1 MacOS

Marius Schamschula-5
Frank,

This works for me. e.g.

A=rand(5)

xlswrite ("fooA.xlsx", A)

What version of MacPorts octave and octave-io do you have installed?

I’ve got

octave @4.2.1_1+app+atlas+docs+fltk+gfortran+graphicsmagick+qt4+sound (active)

and

octave-io @2.4.7_0 (active)

Marius
--
Marius Schamschula



On May 12, 2017, at 2:40 AM, franck Desaize <[hidden email]> wrote:

Hi everybody ,

I have a problem to use PKG with octave… 
Octave have been installed with MacPort and the pkg too. 

For example : pkg io 
- Pkg loading is ok 
- Pkg Using doesn’t work : 
- just trying to make a simple xls file with the fonction xlswrite, it prompts me this : 

error :’col2num’ undefined near line 49 column 10 
error: called from
parse_sp_range at line 49 column8
xlswrite at line 185 column 34

But I have previously install octave 4.0.3, and it worked with the bundle version … I can’t use the bundle version because I have to launch Octave without the GUI… 


Thank you for your Help 

Franck 
_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't use pkg on Octave 4.2.1 MacOS

franck
Hello Marius,

I have installed Octave @4.2.1 The standard installation with macport.
About Io pkg, It's the 2.4.7, installed with MacPort...


I don't know why it's doesn't run ....


Franck
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't use pkg on Octave 4.2.1 MacOS

Marius Schamschula-5
Frank,

Did you run

pkg load io ?

Under MacPorts octave packages are installed but not loaded automatically.

On May 15, 2017, at 6:16 AM, franck <[hidden email]> wrote:

Hello Marius,

I have installed Octave @4.2.1 The standard installation with macport.
About Io pkg, It's the 2.4.7, installed with MacPort...


I don't know why it's doesn't run ....


Franck




--
View this message in context: http://octave.1599824.n4.nabble.com/Can-t-use-pkg-on-Octave-4-2-1-MacOS-tp4683302p4683329.html
Sent from the Octave - General mailing list archive at Nabble.com.

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave

Marius
--
Marius Schamschula





_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't use pkg on Octave 4.2.1 MacOS

franck
Yes Marius, I run it ... :(

I have installed Java JRE 8, is it the problem ?  



Franck
Loading...