Editor "floats" after 4.4 install

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Editor "floats" after 4.4 install

Fritz Sonnichsen
I installed version 4.4 Octave on Windows today.

When I double click on a "*.m" file , Octave comes up along with a
separate notepad++ session. I cannot run the program from octave. I need
to resume running octave as I did in the past, connecting the *.m
program directly with the internal editor. Further I want the editor
docked in the Octave frame. How does one accomplish this?

Thanks
Fritz



Reply | Threaded
Open this post in threaded view
|

Re: Editor "floats" after 4.4 install

EliAaron
Fritz Sonnichsen wrote
> I installed version 4.4 Octave on Windows today.
> When I double click on a "*.m" file , Octave comes up along with a
> separate notepad++ session.

I have the same problem, the file does not open in the Octave GUI built in
editor.
I tried checking\unchecking "Settings->Editor: Use custom file editor" but
it doesn’t make a difference
I can still open a file from Octave GUI.

Another related problem: the notepad++ throws error messages:
"Load Library is failed.
Make "Runtime Library" setting of this project as "Multi-threaded(/MT)" may
cure this problem.
This plugin is not compatible with current version of Notepad++.
Do you want to remove this plugin from plugins directory to prevent this
message from the next launch time?"


I started having these problems after installing Octave 4.4.0 64bit on
windows 10



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Editor "floats" after 4.4 install

yamane
Em ter, 19 de jun de 2018 às 19:33, EliAaron <[hidden email]> escreveu:
> Fritz Sonnichsen wrote
> > I installed version 4.4 Octave on Windows today.
> > When I double click on a "*.m" file , Octave comes up along with a
> > separate notepad++ session.
>
> I have the same problem, the file does not open in the Octave GUI built in
> editor.

Fixed, according the bug report below:
https://savannah.gnu.org/bugs/?53854

Best regards,
Renato


Reply | Threaded
Open this post in threaded view
|

Re: Editor "floats" after 4.4 install

EliAaron
yamane wrote
> Fixed, according the bug report below:
> https://savannah.gnu.org/bugs/?53854

Thanks, this solution worked for me
https://savannah.gnu.org/bugs/?53854#comment3
<https://savannah.gnu.org/bugs/?53854#comment3>  
It is a workaround that uses a 1sec pause but it works






--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html