Help installing packages

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Help installing packages

Kive
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Help installing packages

Dmitri A. Sergatskov
On Sat, Mar 24, 2018 at 4:59 PM, Kive <[hidden email]> wrote:
Hi everyone, I'm a new user of octave and fedora and at the moment I've been
trying to install the signal package but I get an error:

pkg install -forge signal
error: the following dependencies were unsatisfied:
   signal needs control >= 2.4.5

So, I looked online and found that I should type:

pkg install -forge control signal

but I get the following error:

pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 40 column 7
    install at line 192 colum

Can anyone please help? :(

I use Fedora27 and Octave, version 4.2.2
I installed via terminal.


​On Fedora you can do (in a terminal, not on octave's prompt):

dnf install ​octave-signal

​Dmitri.
​--




Reply | Threaded
Open this post in threaded view
|

Re: Help installing packages

Colin Macdonald-2
On 2018-03-24 07:04 PM, Dmitri A. Sergatskov wrote:
> On Sat, Mar 24, 2018 at 4:59 PM, Kive <[hidden email]
> <mailto:[hidden email]>> wrote:
>     I use Fedora27 and Octave, version 4.2.2
>     I installed via terminal.
>
>
> ​On Fedora you can do (in a terminal, not on octave's prompt):
>
> dnf install ​octave-signal

Or if you want to install packages using `pkg install -forge <foo>`, I
think you need to `dnf install octave-devel`.

Colin