How install package

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

How install package

Leloup
Hello,

       I am doing upgraded Ubuntu from V16 to *V18*. I am discovering the
release 4.2.0 of Octave. However, when typing *"pkg list"*, list is empty.
In the Web, I found the Octage-Forge site with interesting packages like
*signal*, algebra, image...I downloaded them. I don't know what do now. Must
I use the Ubuntu terminal? the Octave command window?  What command?  

    I should like using Linux Mint but the release of Octave is 4.0.0 and
the signal package does not have the corrcoef.m including.
signal *|   1.3.2 | /usr/share/octave/packages/signal-1.3.2
I don't know if Octave 4.0.0 is working with signal 1.4.0 from Octave-Forge?

   Sorry for the beginner questions.

Regards,

Le Loup



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: How install package

yamane
2018-06-03 10:53 GMT+02:00 Leloup <[hidden email]>:

>        I am doing upgraded Ubuntu from V16 to *V18*. I am discovering the
> release 4.2.0 of Octave. However, when typing *"pkg list"*, list is empty.
> In the Web, I found the Octage-Forge site with interesting packages like
> *signal*, algebra, image...I downloaded them. I don't know what do now. Must
> I use the Ubuntu terminal? the Octave command window?  What command?

Hi, to install a package, just type (example to install "signal"):
pkg install -forge signal

Take a look on the yellow box (Installing a package) on the link bellow:
https://octave.sourceforge.io/

Best regards,
Renato


Reply | Threaded
Open this post in threaded view
|

Re: How install package

Leloup
Hello Renato,

   I type: >> *pkg install -forge signal*
   *error*: the following dependencies were unsatisfied:
   signal needs control >= 2.4
   >> pkg list
  *no package installed *
  >> *pkg install -forge control*  __gripe_missing_component....
  *no package installed *

Regards,

Le Loup



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: How install package

nrjank
 >> pkg list
  *no package installed *


What operating system and version of Octave are you using? His did you install it?

If it is the Windows version try:

>> pkg rebuild

Then 

>> pkg list