Impossible to install Parallel Package

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Impossible to install Parallel Package

neutron des forets
Dear all,

 I am using Linux Mint 18.2 Sonya, and I try to install parallel package. I
have this kind of response:

>> pkg install -forge parallel
configure: WARNING: TLS disabled since gnutls/gnutls.h not found or not
compilable
In file included from config.h:255:0,
                 from <stdin>:26:
oct-alt-includes.h:11:31: fatal error: octave/call-stack.h: Aucun fichier ou
dossier de ce type
compilation terminated.
In file included from config.h:255:0,
                 from parallel-gnutls.h:27,
                 from <stdin>:39:

Can you help me ?




--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Impossible to install Parallel Package

Olaf Till-2
On Mon, May 21, 2018 at 01:04:44AM -0700, neutron des forets wrote:

> Dear all,
>
>  I am using Linux Mint 18.2 Sonya, and I try to install parallel package. I
> have this kind of response:
>
> >> pkg install -forge parallel
> configure: WARNING: TLS disabled since gnutls/gnutls.h not found or not
> compilable
> In file included from config.h:255:0,
>                  from <stdin>:26:
> oct-alt-includes.h:11:31: fatal error: octave/call-stack.h: Aucun fichier ou
> dossier de ce type
Could you translate this into English?

Olaf

> compilation terminated.
> In file included from config.h:255:0,
>                  from parallel-gnutls.h:27,
>                  from <stdin>:39:
>
> Can you help me ?
>
>
>
>
> --
> Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html
>
>
--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Impossible to install Parallel Package

Ian McCallion


On Mon, 21 May 2018, 22:05 Olaf Till, <[hidden email]> wrote:
On Mon, May 21, 2018 at 01:04:44AM -0700, neutron des forets wrote:

>                  from <stdin>:26:
> oct-alt-includes.h:11:31: fatal error: octave/call-stack.h: Aucun fichier ou
> dossier de ce type

Could you translate this into English?

Olaf

No file or folder of this type.

Ian


Reply | Threaded
Open this post in threaded view
|

Re: Impossible to install Parallel Package

CdeMills
In reply to this post by neutron des forets
neutron des forets wrote

> Dear all,
>
>  I am using Linux Mint 18.2 Sonya, and I try to install parallel package.
> I
> have this kind of response:
>
>>> pkg install -forge parallel
> configure: WARNING: TLS disabled since gnutls/gnutls.h not found or not
> compilable
> In file included from config.h:255:0,
>                  from
> <stdin>
> :26:
> oct-alt-includes.h:11:31: fatal error: octave/call-stack.h: Aucun fichier
> ou
> dossier de ce type
> compilation terminated.
> In file included from config.h:255:0,
>                  from parallel-gnutls.h:27,
>                  from
> <stdin>
> :39:
>
> Can you help me ?
>
>
>
>
> --
> Sent from:
> http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html

Hello neutron des bois,
did you install an octave-dev or octave-devel package ? Do you have
somewhere an include dir containing "octave.h" ? If not, then you can't
install packages requiring to compile source files.

OTOH, you should also install a tls-dev package.

Regards

Pascal



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html