Installing Octave on CentOS 6.5

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing Octave on CentOS 6.5

Prasad K
I was trying to install octave on CentOS 6.5 since few weeks.
I have tried so many options from internet including this tutorial
"http://www.discretizer.se/?p=198" and every attempt failed with some type
of error in the ./configure step (dependencies etc..).
Is there any clear tutorial or link about how to install octave on CentOS
6.5. Please help.
Thanks
Prasad



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Installing Octave on CentOS 6.5

Sahil
Prasad K wrote
> I was trying to install octave on CentOS 6.5 since few weeks.
> I have tried so many options from internet including this tutorial
> "http://www.discretizer.se/?p=198" and every attempt failed with some type
> of error in the ./configure step (dependencies etc..).
> Is there any clear tutorial or link about how to install octave on CentOS
> 6.5. Please help.
> Thanks
> Prasad

Hi
Did you try following the steps given here [1] ? And if still there's no
outcome, kindly share the error details.

Sahil

[1] https://wiki.octave.org/Octave_for_GNU/Linux#Red_Hat_Enterprise.2FCentOS



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Installing Octave on CentOS 6.5

Dmitri A. Sergatskov
On Wed, May 2, 2018 at 12:08 PM, Sahil <[hidden email]> wrote:
Prasad K wrote
> I was trying to install octave on CentOS 6.5 since few weeks.
> I have tried so many options from internet including this tutorial
> "http://www.discretizer.se/?p=198" and every attempt failed with some type
> of error in the ./configure step (dependencies etc..).

​I seriously doubt you can compile a recent octave on a stock RHEL 6.x and
related distros. Those are just too old and octave wants newer version of development
tools.
To compile octave on RHEL7 I  had to install a newer version of sed and libtool
(and probably something else which I have forgotten).

Dmitri.
--
  ​




Reply | Threaded
Open this post in threaded view
|

Re: Re: Installing Octave on CentOS 6.5

John W. Eaton
Administrator
On 05/02/2018 01:33 PM, Dmitri A. Sergatskov wrote:

> On Wed, May 2, 2018 at 12:08 PM, Sahil <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Prasad K wrote
>     > I was trying to install octave on CentOS 6.5 since few weeks.
>     > I have tried so many options from internet including this tutorial
>     > "http://www.discretizer.se/?p=198 <http://www.discretizer.se/?p=198>"
>     and every attempt failed with some type
>     > of error in the ./configure step (dependencies etc..).
>
>
> ​I seriously doubt you can compile a recent octave on a stock RHEL 6.x and
> related distros. Those are just too old and octave wants newer version
> of development
> tools.
> To compile octave on RHEL7 I  had to install a newer version of sed and
> libtool
> (and probably something else which I have forgotten).

mxe-octave can build modern versions of Octave and all dependencies for
these old systems.  You can check it out here:

   http://hg.octave.org/mxe-octave

It's still not trivial and the complete build will take several hours
because it builds about 125 dependencies and most Octave Forge packages.

I'd be glad to discuss commercial support options if you are interested.

jwe


Reply | Threaded
Open this post in threaded view
|

Re: Installing Octave on CentOS 6.5

Prasad K
In reply to this post by Sahil
Hi Sahil,

Thanks for your post. Now i am able to install octave 3.4.3 with the
suggested steps in the link that you gave. But it is very old version and
doesn't supports tool boxes that i need. So i downloaded octave 4.0.0.tar.gz
installed manually and i am able to open and run some simple commands. When
i try to install toolboxes it gives the below error.

online method:
/pkg install -forge struct
error: support for url transfers was disabled when Octave was built
error: called from
    get_forge_pkg at line 40 column 14
    get_forge_download at line 26 column 12
    pkg at line 393 column 29/

Then i searched Octave forum for possible cause and some threads suggested
to install /libcurl/ library that i already had and uptodate. In another
thread download and install toolboxes locally so i tried install struct
toolbox got the below error.

offline method:
/pkg install struct-1.0.14.tar.gz
unable to open /usr/local/share/octave/4.0.0/etc/macros.texi for reading
error: called from '__makeinfo__' in file
/usr/local/share/octave/4.0.0/m/help/__makeinfo__.m near line 103, column 5/

Please help thank you



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html