Quantcast

OF web site: problem with "Home" link

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OF web site: problem with "Home" link

Julien Bect-2
Hi Olaf,

There is a problem with the "Home" links on the OF web site (see error message below) which appears to be related to the changes that you made lately (I might be wrong about that).

These links point to:

https://octave.sourceforge.io/index.html.

The correct URL appears to be (if I look at https://octave.sourceforge.io):

https://octave.sourceforge.io/index.php

How do we fix this?  Is this a SourceForge problem?

Should we sed all the html files on OF to fix the links?

Should we make the change in the OP options in generate_html?

@++
Julien



Here is the error message that I get:

An error has been encountered in accessing this page.

1. Server: octave.sourceforge.io
2. URL path: /home/project-web/octave/htdocs/index.php
3. Error notes: NONE
4. Error type: 404
5. Request method: GET
6. Request query string: NONE
7. Time: 2017-02-26 10:25:26 UTC (1488104726)

Reporting this problem: The problem you have encountered is with a project web site hosted by SourceForge.net. This issue should be reported to the SourceForge.net-hosted project (not to SourceForge.net).

If this is a severe or recurring/persistent problem, please do one of the following, and provide the error text (numbered 1 through 7, above):

  1. Contact the project via their designated support resources.
  2. Contact the project administrators of this project via email (see the upper right-hand corner of the Project Summary page for their usernames) at user-name@users.sourceforge.net

If you are a maintainer of this web content, please refer to the Site Documentation regarding web services for further assistance.

NOTE: As of 2008-10-23 directory index display has been disabled by default. This option may be re-enabled by the project by placing a file with the name ".htaccess" with this line:

Options +Indexes

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OF web site: problem with "Home" link

Olaf Till-2
On Sun, Feb 26, 2017 at 11:37:48AM +0100, Julien Bect wrote:

> ...
> These links point to:
>
> https://octave.sourceforge.io/index.html.
>
> The correct URL appears to be (if I look at https://octave.sourceforge.io):
>
> https://octave.sourceforge.io/index.php
> ...
> Here is the error message that I get:
> ...
This is already fixed by rewrite rules in the .htaccess file, and it
did work when I tested it before. That it ceased to work now must be a
problem with the sourceforge servers. I'll file a ticket.

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OF web site: problem with "Home" link

Julien Bect-2
Le 26/02/2017 à 12:02, Olaf Till a écrit :

> On Sun, Feb 26, 2017 at 11:37:48AM +0100, Julien Bect wrote:
>> ...
>> These links point to:
>>
>> https://octave.sourceforge.io/index.html.
>>
>> The correct URL appears to be (if I look at https://octave.sourceforge.io):
>>
>> https://octave.sourceforge.io/index.php
>> ...
>> Here is the error message that I get:
>> ...
> This is already fixed by rewrite rules in the .htaccess file, and it
> did work when I tested it before. That it ceased to work now must be a
> problem with the sourceforge servers. I'll file a ticket.

Ok, it seems to work again.

Loading...