Octave 4.0.0_signal package_ellipord.m_xubuntu

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo




ellipordex.m (382 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Doug Stewart-4


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS



Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio
I think this is  newest linux version?



Lähetetty Samsung Galaxy -älypuhelimesta.

-------- Alkuperäinen viesti --------
Lähettäjä: Doug Stewart <[hidden email]>
Päivämäärä: 31.10.2018 19.22 (GMT+02:00)
Saaja: Tarmo Tapio <[hidden email]>
Kopio: Help-Octave List <[hidden email]>
Aihe: Re: Octave 4.0.0_signal package_ellipord.m_xubuntu



On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS



Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Mike Miller-4
In reply to this post by Tarmo Tapio
On Wed, Oct 31, 2018 at 19:09:29 +0200, Tarmo Tapio wrote:
> I have problem to use Octave 4.0.0 version's function ellipord.m (signal
> package version 1.4.0?). File included. I get error "validate_filter_bands".
> My operation system is Linux Xubuntu 16.04. What is my fault?

The function 'validate_filter_bands' is part of the signal package, so
this looks like a partial or faulty install of the package.

How did you install the signal package for Octave 4.0.0? Are you using
'pkg load signal'? What directories are in Octave's path after the
package is loaded?

--
mike



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio
In reply to this post by Doug Stewart-4

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.


Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS




Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Doug Stewart-4


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS




Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);
.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio
In reply to this post by Doug Stewart-4

Here is also error txt:

error: 'validate_filter_bands' undefined near line 69 column 5
error: called from
    ellipord at line 69 column 5
    elliptinensuodin at line 3 column 7


Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Doug Stewart-4
In reply to this post by Tarmo Tapio


On Thu, Nov 1, 2018 at 8:08 AM Tarmo Tapio <[hidden email]> wrote:

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);


This code works OK for me!
I get the results shown in the attached file


 

.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





--
DAS




magHdb1.ofig (40K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio

Ok.

I can not open this kind of file format. Are you using Linux or windows pc? What octave version?

Tarmo


Doug Stewart kirjoitti 1.11.2018 klo 14.40:


On Thu, Nov 1, 2018 at 8:08 AM Tarmo Tapio <[hidden email]> wrote:

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);


This code works OK for me!
I get the results shown in the attached file


 

.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





--
DAS




Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Doug Stewart-4


On Thu, Nov 1, 2018 at 10:42 AM Tarmo Tapio <[hidden email]> wrote:

Ok.

I can not open this kind of file format. Are you using Linux or windows pc? What octave version?

Tarmo


I am on ubuntu 18.04 octave 4.4.1

Try this file



 
Doug Stewart kirjoitti 1.11.2018 klo 14.40:


On Thu, Nov 1, 2018 at 8:08 AM Tarmo Tapio <[hidden email]> wrote:

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);


This code works OK for me!
I get the results shown in the attached file


 

.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





--
DAS




--
DASCertificate for 206392




1magHdb11.jpg (60K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio

Thank you Doug.

I tested this ellipord at win10 and octave 4.4.1. It works. However plotting do not work correctly at win10 laptop(Acer). Axis and curves moves different direction and overlap. My ubuntu pc is acer 10" (old). I try to update xubuntu to version 18.04, but how I can find octave 4.4.1 for linux. Newest version I found was 4.2.2.

BR Tarmo



Doug Stewart kirjoitti 1.11.2018 klo 18.02:


On Thu, Nov 1, 2018 at 10:42 AM Tarmo Tapio <[hidden email]> wrote:

Ok.

I can not open this kind of file format. Are you using Linux or windows pc? What octave version?

Tarmo


I am on ubuntu 18.04 octave 4.4.1

Try this file



 
Doug Stewart kirjoitti 1.11.2018 klo 14.40:


On Thu, Nov 1, 2018 at 8:08 AM Tarmo Tapio <[hidden email]> wrote:

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);


This code works OK for me!
I get the results shown in the attached file


 

.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





--
DAS




--
DASCertificate for 206392




Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0.0_signal package_ellipord.m_xubuntu

Tarmo Tapio
In reply to this post by Doug Stewart-4

I have now xubuntu 16.04 and octave 4.4.1 but I can not install signal package. What is correct command? To install octave 4.4.1 I had to use flatpak...flathub...etc. Command sudo apt-get install octave-signal do not work anymore.

Tarmo


Doug Stewart kirjoitti 1.11.2018 klo 18.02:


On Thu, Nov 1, 2018 at 10:42 AM Tarmo Tapio <[hidden email]> wrote:

Ok.

I can not open this kind of file format. Are you using Linux or windows pc? What octave version?

Tarmo


I am on ubuntu 18.04 octave 4.4.1

Try this file



 
Doug Stewart kirjoitti 1.11.2018 klo 14.40:


On Thu, Nov 1, 2018 at 8:08 AM Tarmo Tapio <[hidden email]> wrote:

I included it last time, but here is txt-file.

% The following 3 lines produce filter coefficients shown in Table 6.1.
wp = [0.35,0.65]; ws = [0.25,0.75]; Rp = 1; As = 50;
[N, wn] = ellipord(wp, ws, Rp, As);
[b,a] = ellip(N,Rp,As,wn);
w = [0:500]*pi/500; H = freqz(b,a,w); magH = abs(H);
magHdb = 20*log10(magH);


This code works OK for me!
I get the results shown in the attached file


 

.....

Tarmo

Doug Stewart kirjoitti 1.11.2018 klo 12.50:


On Thu, Nov 1, 2018, 12:25 AM Tarmo Tapio <[hidden email] wrote:

I have upgraded now to version 4.2.2 (sudo add-apt-repository ppa:octave/stable) but I get same error.

Ok
Can you show me a small section of code  that will make the error?




Doug Stewart kirjoitti 31.10.2018 klo 19.22:


On Wed, Oct 31, 2018 at 1:08 PM Tarmo Tapio <[hidden email]> wrote:
Hi

I have problem to use Octave 4.0.0 version's function ellipord.m (signal
package version 1.4.0?). File included. I get error
"validate_filter_bands". My operation system is Linux Xubuntu 16.04.
What is my fault?

Tarmo



Thank you for starting a new thread.
Octave 4.0.0 is very old, and lots of thing have been fixed since then.
I think you should upgrade to the newest octvae.



--
DAS





--
DAS




--
DASCertificate for 206392