Octave 4.0 on Mac 10.10

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave 4.0 on Mac 10.10

Sebastian Schöps
Dear Mac-Octavers,

I am currently using an octave build compiled by clang from the gui-release-branch supplied by homebrew on Yosemite. This used to work nicely (besides some minor gui bugs). However, the default development branch does not compile for me at all. I guess this is rather a problem of the interplay of clang with octave than a Yosemite issue. It seems that a lot of people are struggling with Octave on the Mac. Thus, before I invest a lot of time (e.g. changing from brew to macports etc.), I wanted to ask what is your status?

What is the plan for 4.0? Offering a precompiled build or helping brew or Macports? Is somebody working on this, e.g., Carlo - I recall that you were stuck on 10.9?

Bye,
Sebastian
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

bpabbott
Administrator
> On Feb 27, 2015, at 3:45 AM, Sebastian Schöps <[hidden email]> wrote:
>
> Dear Mac-Octavers,
>
> I am currently using an octave build compiled by clang from the
> gui-release-branch supplied by homebrew on Yosemite. This used to work
> nicely (besides some minor gui bugs). However, the default development
> branch does not compile for me at all. I guess this is rather a problem of
> the interplay of clang with octave than a Yosemite issue. It seems that a
> lot of people are struggling with Octave on the Mac. Thus, before I invest a
> lot of time (e.g. changing from brew to macports etc.), I wanted to ask what
> is your status?
>
> What is the plan for 4.0? Offering a precompiled build or helping brew or
> Macports? Is somebody working on this, e.g., Carlo - I recall that you were
> stuck on 10.9?
>
> Bye,
> Sebastian

Hi Sabastian,

I'm also running Yosemite.

I'm able to build and run the stable branch using Fink for the dependencies. I'm also able to build and run on Macports. However using Macports, I experienced some crashes.

The default branch does not compile for me on Yosemite, but I am (was) able to build and run on Mavericks.

Regarding prebuild app, my recollection is that Carlo was planning to use Macports and build on Mavericks.

Ben
_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

Carlo de Falco-2

On 27 Feb 2015, at 15:38, Ben Abbott <[hidden email]> wrote:

> Regarding prebuild app, my recollection is that Carlo was planning to use Macports and build on Mavericks.

I can build on Mavericks, but I'm not sure whether the resulting binary would be working in Yosemite.
Actually, according to previous reports, I think the Octave binary itself would work but it would be unable to build and install forge packages.
I also do not have a system with Yosemite at hand, and I cannot upgrade my main system, so I am trying to set up a virtual machine with it.

c.
_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

vicnorton
Hi Carlo,

Please keep me informed of your progress on Octave 4.0. I absolutely depend on the Octave 3.8.2 you sent me. It works perfectly. BTW, I am still on Mavericks.

Regards,

Vic

On Feb 27, 2015, at 11:19 AM, Carlo De Falco <[hidden email]> wrote:

>
> On 27 Feb 2015, at 15:38, Ben Abbott <[hidden email]> wrote:
>
>> Regarding prebuild app, my recollection is that Carlo was planning to use Macports and build on Mavericks.
>
> I can build on Mavericks, but I'm not sure whether the resulting binary would be working in Yosemite.
> Actually, according to previous reports, I think the Octave binary itself would work but it would be unable to build and install forge packages.
> I also do not have a system with Yosemite at hand, and I cannot upgrade my main system, so I am trying to set up a virtual machine with it.
>
> c.
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/help-octave



_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

Julien Salort
In reply to this post by bpabbott
Ben Abbott <[hidden email]> wrote:

> I'm able to build and run the stable branch using Fink for the
> dependencies. I'm also able to build and run on Macports. However using
> Macports, I experienced some crashes.

I don't know of this is related to the crashes that your experienced,
but there have been some Clang-related fixes recently:

https://trac.macports.org/ticket/45210

Julien

--
http://www.juliensalort.org





_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

bpabbott
Administrator

> On Mar 1, 2015, at 5:43 AM, Julien Salort <[hidden email]> wrote:
>
> Ben Abbott <[hidden email]> wrote:
>
>> I'm able to build and run the stable branch using Fink for the
>> dependencies. I'm also able to build and run on Macports. However using
>> Macports, I experienced some crashes.
>
> I don't know of this is related to the crashes that your experienced,
> but there have been some Clang-related fixes recently:
>
> https://trac.macports.org/ticket/45210
>
> Julien

Thanks for the update. I still have my Macports install and can switch between it and Fink by modifying my ~/.profile shell script.  When I have time I'll switch back to Macports and try building/running the default branch.

Ben


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

rdzman
In reply to this post by vicnorton
Just wondering if anyone as been able to make any progress on this? Has anyone gotten 4.0.0rc2 to build on any version of OS X? On Yosemite?

I currently have 3.8.0 installed via MacPorts and would love to give 4.0 a try.
Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.0 on Mac 10.10

Marius Schamschula-5

On Apr 2, 2015, at 7:40 AM, rdzman <[hidden email]> wrote:

> Just wondering if anyone as been able to make any progress on this? Has
> anyone gotten 4.0.0rc2 to build on any version of OS X? On Yosemite?
>
> I currently have 3.8.0 installed via MacPorts and would love to give 4.0 a
> try.
>

Until we find someone who can clean up the C++ code to appease clang (any recent version), there will not be a usable version of octave 4.0.0 on the Mac. Unfortunately, I don’t speak C++.

I have built 4.0.0-rc1, 4.0.0-rc2 and current using gcc 4.9. This builds cleanly, however, links against the wrong libc++ (lisbstdc++ vs. libc++), and thus creates an unstable/unusable app.

Marius
--
Marius Schamschula





_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave