Octave 4.4 flatpak and loading the signal package / error in control...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
RT
Reply | Threaded
Open this post in threaded view
|

Octave 4.4 flatpak and loading the signal package / error in control...

RT
I launch the flatpak version of octave 4.4 using
flatpak run org.octave.Octave --gui

then I type the command in the Octave terminal window:
pkg install -forge signal

I get an error
>> pkg install -forge signal
error: the following dependencies were unsatisfied:
   signal needs control >= 2.4


So I add the control package by typing in
pkg install -forge control

And I get sever errors

In file included from __control_slicot_functions__.cc:26:0:
sl_tg01ad.cc: In function ‘octave_value_list F__sl_tg01ad__(const octave_value_list&, int)’:
sl_tg01ad.cc:108:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:26:0:
sl_tg01ad.cc:108:38: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
                                      ^
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:27:0:
sl_sb10id.cc: In function ‘octave_value_list F__sl_sb10id__(const octave_value_list&, int)’:
sl_sb10id.cc:130:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:27:0:
sl_sb10id.cc:130:38: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
                                      ^
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:28:0:
sl_sb10kd.cc: In function ‘octave_value_list F__sl_sb10kd__(const octave_value_list&, int)’:
sl_sb10kd.cc:126:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~

--
--
|


Reply | Threaded
Open this post in threaded view
|

Re: Octave 4.4 flatpak and loading the signal package / error in control...

Doug Stewart-4


On Mon, May 14, 2018 at 11:17 AM, RT <[hidden email]> wrote:
I launch the flatpak version of octave 4.4 using
flatpak run org.octave.Octave --gui

then I type the command in the Octave terminal window:
pkg install -forge signal

I get an error
>> pkg install -forge signal
error: the following dependencies were unsatisfied:
   signal needs control >= 2.4


So I add the control package by typing in
pkg install -forge control

And I get sever errors

In file included from __control_slicot_functions__.cc:26:0:
sl_tg01ad.cc: In function ‘octave_value_list F__sl_tg01ad__(const octave_value_list&, int)’:
sl_tg01ad.cc:108:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:26:0:
sl_tg01ad.cc:108:38: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
                                      ^
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:27:0:
sl_sb10id.cc: In function ‘octave_value_list F__sl_sb10id__(const octave_value_list&, int)’:
sl_sb10id.cc:130:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:27:0:
sl_sb10id.cc:130:38: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
                                      ^
In file included from common.h:31:0,
                 from sl_ab08nd.cc:31,
                 from __control_slicot_functions__.cc:1:
/app/include/octave-4.4.0/octave/../octave/f77-fcn.h:49:18: note: declared here
 static const int f77_exception_encountered = 0;
                  ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from __control_slicot_functions__.cc:28:0:
sl_sb10kd.cc: In function ‘octave_value_list F__sl_sb10kd__(const octave_value_list&, int)’:
sl_sb10kd.cc:126:13: warning: ‘f77_exception_encountered’ is deprecated: [4.4]: this variable is obsolete and should not be needed [-Wdeprecated-declarations]
         if (f77_exception_encountered)
             ^~~~~~~~~~~~~~~~~~~~~~~~~

--
--
|



These are just warnings you can safely ignorthem


--
DASCertificate for 206392