Octave doesn't lauch in Windows 10

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave doesn't lauch in Windows 10

Felipe Nicolau
Hello
My name is Felipe and I've installed Octave 4.4.1 and everything was working normal. Then I upgraded windows 10 and now when the GUI simply doesn't open, it doesn't even come up with error messages.
A little help would be much appreciated.
Kind regards,
Felipe


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

PhilipNienhuis
Felipe Nicolau wrote
> Hello
> My name is Felipe and I've installed Octave 4.4.1 and everything was
> working normal. Then I upgraded windows 10 and now when the GUI simply
> doesn't open, it doesn't even come up with error messages.
> A little help would be much appreciated.
> Kind regards,
> Felipe

It's hard to tell what exactly happened inside your box.
What is your Windows 10 version now? look in Settings -> System -> About.
E.g., on my Win10 box it says "Version 1803".

Have you tried if reinstalling Octave helps?

Philip



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

bpabbott
Administrator
> On Jan 20, 2019, at 2:56 AM, PhilipNienhuis <[hidden email]> wrote:
>
> Felipe Nicolau wrote
>> Hello
>> My name is Felipe and I've installed Octave 4.4.1 and everything was
>> working normal. Then I upgraded windows 10 and now when the GUI simply
>> doesn't open, it doesn't even come up with error messages.
>> A little help would be much appreciated.
>> Kind regards,
>> Felipe
>
> It's hard to tell what exactly happened inside your box.
> What is your Windows 10 version now? look in Settings -> System -> About.
> E.g., on my Win10 box it says "Version 1803".
>
> Have you tried if reinstalling Octave helps?
>
> Philip

Many of reported running Octave on Windows 10. However, it does not work for me either. I’m running Win10 Pro v 1709, build 16299.611

My IT disabled root access on Win10. This means there are location where I no longer have write access. I’ve been wondering if that is my problem.

Felipe, did you have to “run elevated” to install Octave?

Ben

Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

PhilipNienhuis
bpabbott wrote
>> On Jan 20, 2019, at 2:56 AM, PhilipNienhuis &lt;

> pr.nienhuis@

> &gt; wrote:
>>
>> Felipe Nicolau wrote
>>> Hello
>>> My name is Felipe and I've installed Octave 4.4.1 and everything was
>>> working normal. Then I upgraded windows 10 and now when the GUI simply
>>> doesn't open, it doesn't even come up with error messages.
>>> A little help would be much appreciated.
>>> Kind regards,
>>> Felipe
>>
>> It's hard to tell what exactly happened inside your box.
>> What is your Windows 10 version now? look in Settings -> System -> About.
>> E.g., on my Win10 box it says "Version 1803".
>>
>> Have you tried if reinstalling Octave helps?
>>
>> Philip
>
> Many of reported running Octave on Windows 10. However, it does not work
> for me either. I’m running Win10 Pro v 1709, build 16299.611
>
> My IT disabled root access on Win10. This means there are location where I
> no longer have write access. I’ve been wondering if that is my problem.

Your IT-colleagues may have made the registry hive where Octave writes its
uninstallation info read-only; that'll make installation of several SW
cumbersome at least.
But once installed Octave merely writes info in the user profile, that
should be no problem.

But there are creepier mechanisms.
In my company the IT security folks have installed so-called TRAPS and
Thinapp services ("daemons") that catch any .dlls and .exes that aren't
registered in some SW database and prevent them from running at all.  The
net effect was that we were tied down so severely we couldn't do our core
activities anymore, the rules had to be relaxed quite a bit for us.  For
Octave it meant whitelisting the entire Octave installation directory.
Maybe you're affected by a similar IT dept. move.


> Felipe, did you have to “run elevated” to install Octave?

felipe,

You can try to right-click the desktop shortcut and in Properties set
something like 'Turn on legacy <blahblah>'.

Can you try to install (expand) the zipdist archive rather than run the
binary installer and then create a desktop shortcut to
<octave_install_dir>\octave.vbs ?

BTW my local Win10 installations are both v. 1803 and Octave 4.4.1 to 6.0.0
run fine there.
Upgrading to a new Win10 version is known to be risky at times, but AFAIK
the most affected part is the Octave terminal. But it is the heart of it
all, and on Windows it is known to be fragile.

Philip




--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

h.r.30
In reply to this post by Felipe Nicolau
High Felipe and all posters of this thread,

I got the same problem, but  found out that running octave 4.4.1 in a
command shell (means starting octave-4.4.1 (CLI) starts the program without
error message, however without GUI. But this is not satisfactory. After
several un- and reinstalling, new start of PC etc., I couldn't start
octave-4.4.1 (GUI). Somethings wrong with the GUI.
I'm not sure, but after installations of older versions I got a message that
this version is not tested well with Win10. After checking the properties
(right click the icon at your desktop) I have the possibility of selecting
another Windows environment (i.e. Win 8). I didn't test the previous
installation 4.4.0, but will do that. I installed it, but didn't start it.
4.2.1 worked properly. I think I started under setting Win 7 or Win
8-environment in the properties (I'm not sure, because it's 1 1/2 year ago I
installed it). for 4.4.1 this option is'nt shown in the properties
Remarks: My system is Win 10 built 1803 too.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

tmacchant
> From: h.r.30 

> To: help-octave
> Cc:
> Date: 2019/1/28, Mon 06:27
> Subject: Re: Octave doesn't lauch in Windows 10
>
> High Felipe and all posters of this thread,
>
> I got the same problem, but  found out that running octave 4.4.1 in a
> command shell (means starting octave-4.4.1 (CLI) starts the program without
> error message, however without GUI. But this is not satisfactory. After
> several un- and reinstalling, new start of PC etc., I couldn't start
> octave-4.4.1 (GUI). Somethings wrong with the GUI.
> I'm not sure, but after installations of older versions I got a message that
> this version is not tested well with Win10. After checking the properties
> (right click the icon at your desktop) I have the possibility of selecting
> another Windows environment (i.e. Win 8). I didn't test the previous
> installation 4.4.0, but will do that. I installed it, but didn't start it.
> 4.2.1 worked properly. I think I started under setting Win 7 or Win
> 8-environment in the properties (I'm not sure, because it's 1 1/2 year
> ago I
> installed it). for 4.4.1 this option is'nt shown in the properties
> Remarks: My system is Win 10 built 1803 too.
>
I am now one of users octave for windows on widows 10.

For me, octave-4.4.1 works fine with GUI.
My windows 10 was upgraded to 1809 from 1803 about a week before.
For both situation, octave-4.4.1 with GUI works fine.

However, some reports that are similar to yours has been reported.
The problem seems to depend on environments.
Unfortunately origins has not been resolved yet.

Tatsuro   



Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

h.r.30
In reply to this post by Felipe Nicolau
It's strange. I tried to upgrade from 4.2.1 to 4.4.1 with result as written
afore, also with setting the compitibility mode down to Win8 and Win7 for
the setup file. 4.4.0 has the same result. I  removed it and reinstalled
4.2.1. Well, this works properly.

Does this help for any checking or improvements?
Honestly, I don't have any idea, which settings of environment variables
shal be set.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

nrjank
I've also been running Octave on Windows 10 with no issues. That said, I'm currently running Version 1709. What version are you using? (you can run 'winver' from the start menu to get the info)

A release candidate was recently made available for the soon-to-be-released next version of octave. While this version may still have a few other bugs, I'd be curious if you have the same problems with Octave 5.0.90 at http://alpha.gnu.org/gnu/octave/


On Mon, Jan 28, 2019 at 1:01 PM h.r.30 <[hidden email]> wrote:
It's strange. I tried to upgrade from 4.2.1 to 4.4.1 with result as written
afore, also with setting the compitibility mode down to Win8 and Win7 for
the setup file. 4.4.0 has the same result. I  removed it and reinstalled
4.2.1. Well, this works properly.

Does this help for any checking or improvements?
Honestly, I don't have any idea, which settings of environment variables
shal be set.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html




Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

h.r.30
Hi nrjank

I have Win10 built 1803 and octave 4.2.1 runs properly with that. Perhaps I
should update to1809.
Are there any differences between 4.2.1 and 4.4.1 concerning GUI, perhaps
updated libraries, which can cause conflicts?



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

h.r.30
In reply to this post by Felipe Nicolau
I installed now WIN10 built 1809 and started Octave-4.4.1 without any
success. I have no idea, what let the program immediately shut down. Anyhow,
I have the impression it shuts down faster now.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

sedroca
C  c

Em ter, 29 de jan de 2019 às 18:08, h.r.30 <[hidden email]> escreveu:
I installed now WIN10 built 1809 and started Octave-4.4.1 without any
success. I have no idea, what let the program immediately shut down. Anyhow,
I have the impression it shuts down faster now.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


--
Andrew Henry Cordes

Optoelectronics and Instrumentation Group
Centre for Telecommunication Studies
Pontifical Catholic University of Rio de Janeiro


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

tmacchant
In reply to this post by h.r.30
> Subject: Re: Octave doesn't lauch in Windows 10

>
> I installed now WIN10 built 1809 and started Octave-4.4.1 without any
> success. I have no idea, what let the program immediately shut down. Anyhow,
> I have the impression it shuts down faster now.
>

I misunderstand the situation. You wrote in the first post

> I've installed Octave 4.4.1 and everything was working normal. 
> Then I upgraded windows 10 and now when the GUI simply 
> doesn't open, it doesn't even come up with error messages.


I cannot remember correctly, but one of colleges report the similar.
However, in my case windows update does not affect octave-4.4.1 at all.
(My windows 10 is 1809 latest at Jan., 2019 .)

Perhaps there have been no solution for your case.

Can you try next version release candidate?
http://alpha.gnu.org/gnu/octave/

 octave-5.0.90-w64-installer.exe (installer)
 octave-5.0.90-w64.7z (7zip archived. require 7zip software to extract)
 octave-5.0.90-w64.zip (zio archived)

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: Octave doesn't lauch in Windows 10

apjanke-floss


On 1/29/19 6:05 PM, Tatsuro MATSUOKA wrote:

>> Subject: Re: Octave doesn't lauch in Windows 10
>
>>
>> I installed now WIN10 built 1809 and started Octave-4.4.1 without any
>> success. I have no idea, what let the program immediately shut down. Anyhow,
>> I have the impression it shuts down faster now.
>>
>
> I misunderstand the situation. You wrote in the first post
>
>> I've installed Octave 4.4.1 and everything was working normal.
>> Then I upgraded windows 10 and now when the GUI simply
>> doesn't open, it doesn't even come up with error messages.
>
>
> I cannot remember correctly, but one of colleges report the similar.
> However, in my case windows update does not affect octave-4.4.1 at all.
> (My windows 10 is 1809 latest at Jan., 2019 .)
>
> Perhaps there have been no solution for your case.
>
> Can you try next version release candidate?
> http://alpha.gnu.org/gnu/octave/
>
>   octave-5.0.90-w64-installer.exe (installer)
>   octave-5.0.90-w64.7z (7zip archived. require 7zip software to extract)
>   octave-5.0.90-w64.zip (zio archived)
>
> Tatsuro

One more data point:

I built a completely fresh Windows 10 1809 VM and installed the 5.0.90
RC on it. When launching, it complained about "msvcr100.dll was not
found". I installed the Microsoft Visual C++ 2010 Redistribtable x64 and
after that it ran fine.

Original poster: Maybe your Octave Qt GUI settings got borked sometime
between then and now. What happens if you delete
%USERPROFILE%\.config\octave (that is, .config\octave under your user
home directory) and then run Octave again?

Cheers,
Andrew