Problem Installing package io-2.4.10.tar.gz

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem Installing package io-2.4.10.tar.gz

Gary Dilay
I am having a problem installing the package io-2.4.10.tar.gz on my Windows 10 PC. I am using octave 4.2.1 configured for x86_64-w64-mingw32. When I try to install the package, I get the following error message:

pkg install -verbose io-2.4.10.tar.gz
mkdir (C:\Users\garyw\AppData\Local\Temp\oct-f6xVY6)
untar (io-2.4.10.tar.gz, C:\Users\garyw\AppData\Local\Temp\oct-f6xVY6)
checking for mkoctfile... D:/Octave-4.2.1/octave-4.2.1/bin/mkoctfile-4.2.1.exe --verbose
checking for octave-config... D:/Octave-4.2.1/octave-4.2.1/bin/octave-config-4.2.1.exe
checking whether the C++ compiler works... no
configure: error: in `/tmp/oct-f6xVY6/io-2.4.10/src':
configure: error: C++ compiler cannot create executables
See `config.log' for more details
pkg: error running the configure script for io.
error: called from
    configure_make at line 78 column 9
    install at line 192 column 7
    pkg at line 394 column 9
>>

Can you advise me how I can install package io-2.4.10.tar.gz?

Thank you.



-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------