Problem installing communications package

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem installing communications package

Lester Anderson
Hello,

I cannot get communications-1.2.1.tar.gz to install

pkg install communications-1.2.1.tar.gz

Error:

pkg: error running `make' for the communications package.
error: called from
    configure_make at line 95 column 9
    install at line 192 column 7
    pkg at line 394 column 9

Using Octave 4.2.1 on Windows 7  64-bit

Any ideas?

Cheers
Lester

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Problem installing communications package

Mike Miller-4
On Tue, Sep 05, 2017 at 17:10:41 +0100, Lester Anderson wrote:

> I cannot get communications-1.2.1.tar.gz to install
>
> pkg install communications-1.2.1.tar.gz
>
> Error:
>
> pkg: error running `make' for the communications package.
> error: called from
>     configure_make at line 95 column 9
>     install at line 192 column 7
>     pkg at line 394 column 9
>
> Using Octave 4.2.1 on Windows 7  64-bit
If you are installing on Windows, you should use the packages that are
prebuilt and ready to use with Octave. The official installer comes with
many Octave Forge packages already built and ready to use, including
communications.

There is a known compatibility problem with the latest release of
communications and Octave 4.2. If you use the packages provided with the
installer you don't have to worry about this.

--
mike

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problem installing communications package

Lester Anderson
Thanks Mike for the information.

Does it matter if one installs Octave from the zip file or .exe file?
Just tested on my home laptop with windows 8.1 and the executable
64bit installer thought that windows 10 was on (odd behaviour)!

Tested packages using: pkg load communications etc and that seems fine.
More economical to load packages in .m files - still learning!

Cheers
Lester

On 5 September 2017 at 17:15, Mike Miller <[hidden email]> wrote:

> On Tue, Sep 05, 2017 at 17:10:41 +0100, Lester Anderson wrote:
>> I cannot get communications-1.2.1.tar.gz to install
>>
>> pkg install communications-1.2.1.tar.gz
>>
>> Error:
>>
>> pkg: error running `make' for the communications package.
>> error: called from
>>     configure_make at line 95 column 9
>>     install at line 192 column 7
>>     pkg at line 394 column 9
>>
>> Using Octave 4.2.1 on Windows 7  64-bit
>
> If you are installing on Windows, you should use the packages that are
> prebuilt and ready to use with Octave. The official installer comes with
> many Octave Forge packages already built and ready to use, including
> communications.
>
> There is a known compatibility problem with the latest release of
> communications and Octave 4.2. If you use the packages provided with the
> installer you don't have to worry about this.
>
> --
> mike

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave