Problem regarding enabling gnutls with parallel package while installing in RHEL 7.5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem regarding enabling gnutls with parallel package while installing in RHEL 7.5

Andy03
Hi all,

I am using RHEL 7.5 and octave version 4.2.0 which i installed manually. The
following are the steps i followed:

yum-builddep -y octave
wget ftp://ftp.gnu.org/gnu/octave/octave-4.2.0.tar.gz
tar -xzvf octave-4.2.0.tzr.gz
cd octave-4.2.0
./configure
make -j4
sudo make install

After successful installation of octave i tried to install parallel package
and its dependent package struct I installed struct and parallel packages
with commands

pkg install -forge struct
pkg install -forge parallel

The parallel package gave a WARNING saying TLS disabled since
gnutls/gnutls.h not found or not compilable.

But i want to use cluster functions in parallel package so i uninstalled
parallel package and installed gnutls-devel using the command

sudo yum -y install gnutls-devel

After successful installation i again tried to install parallel package but
it returned a
WARNING saying TLS disabled since symbol gnutls_srp_2048_group_prime not
found in gnutls libarary -build with --disable-srp-authentication?

So kindly suggest what are the dependencies for TLS to be enabled and how to
install parallel package with TLS enable in RHEL 7.5?.

Thanks



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Problem regarding enabling gnutls with parallel package while installing in RHEL 7.5

Andy03
Kindly let me know if any further clarifications are required regarding the
issue.

Thanks



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html