Problems while installing Octave 4.2

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems while installing Octave 4.2

S. Swayamjyoti
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam



error.png (255K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

siko1056
On Thu, Oct 18, 2018 at 9:38 AM S. Swayamjyoti <[hidden email]> wrote:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam


Basically, the problem is defined precisely in the error messages: The development libraries for cURL, fontconfig and so on are not installed on your system.

If you are in a hurry, then you must be precise for getting help:
- Which Linux distribution and version runs in your virtual box?
- Why can't you run a Linux version that naively supports Octave 4.2 or newer?  https://packages.debian.org/stretch-backports/octave
- Do you really rely on version 4.2 or why not choosing 4.4.1 when compiling from source?
- Compiling from source requires you to install lots of development packages, see https://wiki.octave.org/Octave_for_Debian_systems#The_easy_way_.28but_likely_incorrect.29

HTH,
Kai


Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

karl
In reply to this post by S. Swayamjyoti
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

S. Swayamjyoti
Thanks a lot! 

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

S. Swayamjyoti
In reply to this post by karl
Hi,

Based on your suggestions, I installed Octave 4.4 in my system, I am able to install the dependancies, configure. But while building it with 'make', I get the following errors,

Unknown option 'qt4'.
Makefile:27463: recipe for target 'libgui/src/qrc-resource.cc' failed
make[2]: *** [libgui/src/qrc-resource.cc] Error 1
make[2]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:26387: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:10181: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please advise?

Best Regards,
Swayam

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

karl
Am 22.10.18 um 10:37 schrieb S. Swayamjyoti:
Hi,

Based on your suggestions, I installed Octave 4.4 in my system, I am able to install the dependancies, configure. But while building it with 'make', I get the following errors,

Unknown option 'qt4'.
Makefile:27463: recipe for target 'libgui/src/qrc-resource.cc' failed
make[2]: *** [libgui/src/qrc-resource.cc] Error 1
make[2]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:26387: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:10181: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please advise?

Best Regards,
Swayam

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy

Hi Swayan,

here again the advice of Andreas:

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

I think it is clear what he meant. Do not try to build Octave from source, but use a package from your distribution or Flatpack.

Why do you not follow his advice? You tried again to build it from source.

Karl



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

S. Swayamjyoti
Hi, I did try to install from Flatpack,


However, I am not able to install or fetch with that, the command prompt is getting hanged, on that command,
sudo add-apt-repository ppa:alexlarsson/flatpak
Without flatpak, I am unable run the following commands, for setting up Octave:

https://flathub.org/apps/details/org.octave.Octave

flatpak run org.octave.Octave

Will you suggest any workaround?

Best,
Swayam

On Mon, Oct 22, 2018 at 3:05 PM <[hidden email]> wrote:
Am 22.10.18 um 10:37 schrieb S. Swayamjyoti:
Hi,

Based on your suggestions, I installed Octave 4.4 in my system, I am able to install the dependancies, configure. But while building it with 'make', I get the following errors,

Unknown option 'qt4'.
Makefile:27463: recipe for target 'libgui/src/qrc-resource.cc' failed
make[2]: *** [libgui/src/qrc-resource.cc] Error 1
make[2]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:26387: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:10181: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please advise?

Best Regards,
Swayam

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy

Hi Swayan,

here again the advice of Andreas:

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

I think it is clear what he meant. Do not try to build Octave from source, but use a package from your distribution or Flatpack.

Why do you not follow his advice? You tried again to build it from source.

Karl



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

karl
Am 22.10.18 um 11:11 schrieb S. Swayamjyoti:
Hi, I did try to install from Flatpack,


However, I am not able to install or fetch with that, the command prompt is getting hanged, on that command,
sudo add-apt-repository ppa:alexlarsson/flatpak
Without flatpak, I am unable run the following commands, for setting up Octave:

https://flathub.org/apps/details/org.octave.Octave

flatpak run org.octave.Octave

Will you suggest any workaround?

Best,
Swayam

On Mon, Oct 22, 2018 at 3:05 PM <[hidden email]> wrote:
Am 22.10.18 um 10:37 schrieb S. Swayamjyoti:
Hi,

Based on your suggestions, I installed Octave 4.4 in my system, I am able to install the dependancies, configure. But while building it with 'make', I get the following errors,

Unknown option 'qt4'.
Makefile:27463: recipe for target 'libgui/src/qrc-resource.cc' failed
make[2]: *** [libgui/src/qrc-resource.cc] Error 1
make[2]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:26387: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:10181: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please advise?

Best Regards,
Swayam

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy

Hi Swayan,

here again the advice of Andreas:

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

I think it is clear what he meant. Do not try to build Octave from source, but use a package from your distribution or Flatpack.

Why do you not follow his advice? You tried again to build it from source.

Karl

Sorry,

I cannot guess what is wrong with your system when it hangs trying to add the ppa.

This is not an Octave problem.

Karl



Reply | Threaded
Open this post in threaded view
|

Re: Problems while installing Octave 4.2

S. Swayamjyoti
In reply to this post by karl
Hi, I am able to install the latest version of octave 4.4, in my system.

However, some of the packages are probably still not there in Octave 4.4. For example, when I call the function trainAutoEncoder, I get the following error. In MATLAB, this could be due to an older version. However, what can I do in Octave for that?

error: 'trainAutoencoder' undefined near line 25 column 7
error: called from
    ae at line 25 column 5  

On Mon, Oct 22, 2018 at 3:05 PM <[hidden email]> wrote:
Am 22.10.18 um 10:37 schrieb S. Swayamjyoti:
Hi,

Based on your suggestions, I installed Octave 4.4 in my system, I am able to install the dependancies, configure. But while building it with 'make', I get the following errors,

Unknown option 'qt4'.
Makefile:27463: recipe for target 'libgui/src/qrc-resource.cc' failed
make[2]: *** [libgui/src/qrc-resource.cc] Error 1
make[2]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:26387: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/swayam/Downloads/octave-4.4.1'
Makefile:10181: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please advise?

Best Regards,
Swayam

On Thu, Oct 18, 2018 at 2:01 PM <[hidden email]> wrote:
Am 18.10.18 um 10:22 schrieb S. Swayamjyoti:
Hi, I don't have the suggestions from Andreas Weber. Could you please send it to me? I have restricted access to the mailing list.

best,
swayam

On Thu, Oct 18, 2018 at 1:21 PM <[hidden email]> wrote:
Am 18.10.18 um 09:27 schrieb S. Swayamjyoti:
Hi,

I am trying to install an octave package for scientific computations. I could easily install Octave 4.0, but I am facing great difficulty, with Octave 4.2. After running the 'configure' command, successfully, I am still not able to find a make file to build Octave.

Can someone please help me with this? The issue is a bit urgent. Please find attached the error screenshot.

Best,
Swayam

You got an answer from Andreas Weber. Why you don't follow his advice?

Charly

Here it is:

Am 18.10.18 um 05:55 schrieb S. Swayamjyoti:

I have a problem installing or upgrading to Octave 4.2.0. Could you help me on it?

GNU Octave 4.4.1 is the current stable version.

Inside, the Octave 4.2 folder, I just can't do a 'make' after, 'configuration'.

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

Hope that helps, Andy

Hi Swayan,

here again the advice of Andreas:

I guess you are trying to build Octave 4.2 from source on a GNU/Linux system which you shouldn't do unless you have good reasons.

Instead use the packages of your used distribution:
https://www.gnu.org/software/octave/download.html

or even Flatpak if your distribution doesn't ship Octave >=4.2

I think it is clear what he meant. Do not try to build Octave from source, but use a package from your distribution or Flatpack.

Why do you not follow his advice? You tried again to build it from source.

Karl