Re: Help-octave Digest, Vol 137, Issue 32

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Help-octave Digest, Vol 137, Issue 32

Mphumzi Tshentu
Good day

I tried to write a time and date from 2002, I don't seem to get it right, the system is saying syntax error.

octave-3.2.4.exe:1> t0=(clock(09:27:35),17-Feb-02

parse error:

 

  syntax error

I tried different ways to write this and I don't get it right. Please can you help me?

Mphumzi


On Fri, Aug 18, 2017 at 6:00 PM, <[hidden email]> wrote:
Send Help-octave mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.gnu.org/mailman/listinfo/help-octave
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Help-octave digest..."


Today's Topics:

   1. Re: textable not working in octave 4.0.0 ubuntu 16.04
      (wienerschnitzel)
   2. Re: Grid-lines in "print" to png appear black always, not
      grey (Tatsuro MATSUOKA)
   3. Re: BUG: If I manually set xticks on figure, minor x-ticks
      and grid  miss out where major ticks 'would; have been (mmuetzel)
   4. Re: BUG: If I manually set xticks on figure, minor x-ticks
      and grid  miss out where major ticks 'would; have been (mmuetzel)
   5. Re: textable not working in octave 4.0.0 ubuntu 16.04
      (Juan Pablo Carbajal)


----------------------------------------------------------------------

Message: 1
Date: Thu, 17 Aug 2017 23:10:38 -0700 (PDT)
From: wienerschnitzel <[hidden email]>
To: [hidden email]
Subject: Re: textable not working in octave 4.0.0 ubuntu 16.04
Message-ID: <[hidden email]>
Content-Type: text/plain; charset=us-ascii

hello Mike,
thanks for confirming.
bug has been reported in savannah, bug#51781.

-andre



--
View this message in context: http://octave.1599824.n4.nabble.com/textable-not-working-in-octave-4-0-0-ubuntu-16-04-tp4684509p4684518.html
Sent from the Octave - General mailing list archive at Nabble.com.



------------------------------

Message: 2
Date: Fri, 18 Aug 2017 16:26:48 +0900 (JST)
From: Tatsuro MATSUOKA <[hidden email]>
To: Tim Pierce <[hidden email]>, Help GNU Octave
        <[hidden email]>
Subject: Re: Grid-lines in "print" to png appear black always, not
        grey
Message-ID: <[hidden email]>
Content-Type: text/plain; charset=iso-8859-1

>Octave 4.0.0
>>
>>code:
>>
>>? ? figure
>>? ? plot( 1:100 )
>>? ? grid on
>>? ? print( 'test.png', '-dpng ','-S500,500', '-color' )
>>
>>In?https://engineeringliberty. wordpress.com/2011/10/07/ making-great-plots-in-octave- and-matlab-too/?
>>
>>
>>I can see that the second graph down has an example of nice grey (as per the window)?
>>
>>
>>The figure looks like this in Octave
>>It prints to test.png like this
>>I have been through all the gca settings I can see, relevant. There's a LOT.
>>The printed plot respects none of them
>>
>>If anyone could help diagnose this it would be appreciated
>>
>>Tim


>Very sorry, correction -?
>Octave 4.2.1 (Win)
>


This is a limitation of openGL (qt and fltk) and -dpng printing devise.

For Octave 4.2.1 (Win), dpngcairo can be used on gnuplot graphics_toolkit.
Try?

graphics_toolkit gnuplot

figure
plot( 1:100 )
grid on
print( 'test.png', '-dpngcairo','-S500,500', '-color' )


Tatsuro



------------------------------

Message: 3
Date: Fri, 18 Aug 2017 01:10:17 -0700 (PDT)
From: mmuetzel <[hidden email]>
To: [hidden email]
Subject: Re: BUG: If I manually set xticks on figure, minor x-ticks
        and grid        miss out where major ticks 'would; have been
Message-ID: <[hidden email]>
Content-Type: text/plain; charset=us-ascii

Tim,

This has already been fixed in the current development version of Octave
which will eventually become Octave 4.4.
See: https://savannah.gnu.org/bugs/index.php?45850

In the meantime, you can work around the issue by manually setting the
hidden property "xminortickvalues". E.g.:
set (gca, "xminortickvalues", 1:30)

Regards
Markus



--
View this message in context: http://octave.1599824.n4.nabble.com/BUG-If-I-manually-set-xticks-on-figure-minor-x-ticks-and-grid-miss-out-where-major-ticks-would-have-n-tp4684516p4684520.html
Sent from the Octave - General mailing list archive at Nabble.com.



------------------------------

Message: 4
Date: Fri, 18 Aug 2017 01:15:02 -0700 (PDT)
From: mmuetzel <[hidden email]>
To: [hidden email]
Subject: Re: BUG: If I manually set xticks on figure, minor x-ticks
        and grid        miss out where major ticks 'would; have been
Message-ID: <[hidden email]>
Content-Type: text/plain; charset=us-ascii

Sorry. The name of the hidden axes property was "xmtick" in Octave 4.2. So it
should be:
set(gca, 'xmtick', 1:30)



--
View this message in context: http://octave.1599824.n4.nabble.com/BUG-If-I-manually-set-xticks-on-figure-minor-x-ticks-and-grid-miss-out-where-major-ticks-would-have-n-tp4684516p4684521.html
Sent from the Octave - General mailing list archive at Nabble.com.



------------------------------

Message: 5
Date: Fri, 18 Aug 2017 11:44:40 +0200
From: Juan Pablo Carbajal <[hidden email]>
To: Mike Miller <[hidden email]>
Cc: Help GNU Octave <[hidden email]>
Subject: Re: textable not working in octave 4.0.0 ubuntu 16.04
Message-ID:
        <CABDtPkQmN9w8c+0hRV=[hidden email]>
Content-Type: text/plain; charset="UTF-8"

On Fri, Aug 18, 2017 at 12:24 AM, Mike Miller <[hidden email]> wrote:
> On Thu, Aug 17, 2017 at 10:03:14 -0700, wienerschnitzel wrote:
>> hello,
>> I'm trying to use textable:
>>
>> >> A=[1 2 3; 4 5 6]
>> A =
>>
>>    1   2   3
>>    4   5   6
>>
>> >> textable(A)
>> error: value on right hand side of assignment is undefined
>> error: called from
>>     textable at line 111 column 5
>>
>>
>> This is after I installed and loaded miscellaneous package, which depends on
>> general package.
>>
>> Am I missing something else?
>
> Only that the miscellaneous package has not seen a release since 2014.
> It still uses the obsolete inputParser from the general package before
> Octave 4.0 was released in 2015.
>
> Please take the time to report a bug so that this will be fixed in a
> future release of the miscellaneous package
>
>   https://savannah.gnu.org/bugs/?func=additem&group=octave
>
> --
> mike
I think I fixed it in the dev version.

https://savannah.gnu.org/bugs/?51781



------------------------------

Subject: Digest Footer

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave


------------------------------

End of Help-octave Digest, Vol 137, Issue 32
********************************************


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave