Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Olaf Till-2
On Mon, Jun 12, 2017 at 11:45:00AM +0200, Julien Bect wrote:

> Le 12/06/2017 à 11:22, Sébastien Villemot a écrit :
> >Hi all,
> >
> >I just realized that for most if not all of our Forge packages, the URL
> >in the Homepage field of debian/control is no longer valid.
> >
> >Apparently it is because a trailing slash is now required. For example,
> >currently for octave-optim we have…
> >
> >Homepage: http://octave.sourceforge.net/optim
> >
> >…which no longer works (404 error).
> >
> >However, it works if one adds a trailing slash (http://octave.sourcefor
> >ge.io/optim/). By the way, one is automatically redirected to a secure
> >URL.
> >
> >I am not familiar enough with the Forge website, so I don't know if
> >this should be considered as a bug to be fixed on that side, or if we
> >should update all our packages. Any opinion by people more familiar
> >with the topic?
>
> Hello Sébastien,
>
> I have no idea, but I am CC'ing the OF admins.
I've put all package html directories from top level to a common
subdirectory "packages/" today, to cleanup the top level
directory. The internal redirections worked at my local machine, I
didn't realize this issue at the sourceforge machine.

It seems logical that apaches mod_dir can't add a trailing slash for
directories that don't exist before re-writing them. But on my local
machine adding the trailing slash worked anyway, I don't know how.

My first attempts to fix this in .htaccess had no success. I'll need a
bit time. Do you think I'll have to revert the change as long as I've
not fixed it? It would make testing inconvenient.

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Olaf Till-2
On Mon, Jun 12, 2017 at 01:29:47PM +0200, Olaf Till wrote:

> On Mon, Jun 12, 2017 at 11:45:00AM +0200, Julien Bect wrote:
> > Le 12/06/2017 à 11:22, Sébastien Villemot a écrit :
> > >Hi all,
> > >
> > >I just realized that for most if not all of our Forge packages, the URL
> > >in the Homepage field of debian/control is no longer valid.
> > >
> > >Apparently it is because a trailing slash is now required. For example,
> > >currently for octave-optim we have…
> > >
> > >Homepage: http://octave.sourceforge.net/optim
> > >
> > >…which no longer works (404 error).
> > >
> > >However, it works if one adds a trailing slash (http://octave.sourcefor
> > >ge.io/optim/). By the way, one is automatically redirected to a secure
> > >URL.
> > >
> > >I am not familiar enough with the Forge website, so I don't know if
> > >this should be considered as a bug to be fixed on that side, or if we
> > >should update all our packages. Any opinion by people more familiar
> > >with the topic?
> >
> > Hello Sébastien,
> >
> > I have no idea, but I am CC'ing the OF admins.
>
> I've put all package html directories from top level to a common
> subdirectory "packages/" today, to cleanup the top level
> directory. The internal redirections worked at my local machine, I
> didn't realize this issue at the sourceforge machine.
>
> It seems logical that apaches mod_dir can't add a trailing slash for
> directories that don't exist before re-writing them. But on my local
> machine adding the trailing slash worked anyway, I don't know how.
>
> My first attempts to fix this in .htaccess had no success. I'll need a
> bit time. Do you think I'll have to revert the change as long as I've
> not fixed it? It would make testing inconvenient.
Should be fixed now, though not in a nice way.

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Sébastien Villemot-2
Le lundi 12 juin 2017 à 13:56 +0200, Olaf Till a écrit :
> Le 12/06/2017 à 11:22, Sébastien Villemot a écrit :
> > > > I just realized that for most if not all of our Forge packages,

> > > > the URL
> > > > in the Homepage field of debian/control is no longer valid.
> > > >
> > > > Apparently it is because a trailing slash is now required. For
> > > > example,
> > > > currently for octave-optim we have…
> > > >
> > > > Homepage: http://octave.sourceforge.net/optim
> > > >
> > > > …which no longer works (404 error).
> > > > I've put all package html directories from top level to a
> > > > common

> Should be fixed now, though not in a nice way.

Thanks!

However it looks like some URLs without a trailing slash are still not
working, e.g.:
https://octave.sourceforge.io/econometrics

--
 .''`.    Sébastien Villemot
: :' :    Debian Developer
`. `'     http://sebastien.villemot.name
  `-      GPG Key: 4096R/381A7594

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Olaf Till-2
On Mon, Jun 12, 2017 at 02:38:44PM +0200, Sébastien Villemot wrote:
> However it looks like some URLs without a trailing slash are still not
> working, e.g.:
> https://octave.sourceforge.io/econometrics

This one works for me. I've still tested a bit yesterday to find a
cleaner fix, causing a time period of a few seconds length when these
URLs didn't work. Maybe you've hit just this period... Or maybe you
should try to reload the page? Browsers shouldn't cache faults, but
maybe some browsers do...

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Pkg-octave-devel] Homepage URL of Forge packages seems to have changed

Sébastien Villemot-2
Le mardi 13 juin 2017 à 11:19 +0200, Olaf Till a écrit :

> On Mon, Jun 12, 2017 at 02:38:44PM +0200, Sébastien Villemot wrote:
> > However it looks like some URLs without a trailing slash are still
> > not
> > working, e.g.:
> > https://octave.sourceforge.io/econometrics
>
> This one works for me. I've still tested a bit yesterday to find a
> cleaner fix, causing a time period of a few seconds length when these
> URLs didn't work. Maybe you've hit just this period... Or maybe you
> should try to reload the page? Browsers shouldn't cache faults, but
> maybe some browsers do...

I confirm that that one now works for me. Thanks again.

--
 .''`.    Sébastien Villemot
: :' :    Debian Developer
`. `'     http://sebastien.villemot.name
  `-      GPG Key: 4096R/381A7594

Loading...