Regarding package installation

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Regarding package installation

SANKET SHARMA
I downloaded the linear-algebra-2.2.2.tar.gz file. And tried to install in Octave prompt by using command pkg install linear-algebra-2.2.2.tar.gz in the current working directory. 

But it showed the following error message:

pkg: please install the Debian package "liboctave-dev" to get the mkoctfile command error: called from '__gripe_missing_component__' in file /usr/share/octave/4.0.0/m/help/__gripe_missing_component__.m near line 53, column 3

Kindly, reply ASAP

Regards,

Sanket Sharma
Research Scholar
GLA University, Mathura
India - 281406

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Regarding package installation

Oliver Heimlich
Am 17. Januar 2018 14:58:43 MEZ schrieb SANKET SHARMA <[hidden email]>:
I downloaded the linear-algebra-2.2.2.tar.gz file. And tried to install in Octave prompt by using command pkg install linear-algebra-2.2.2.tar.gz in the current working directory. 

But it showed the following error message:

pkg: please install the Debian package "liboctave-dev" to get the mkoctfile command error: called from '__gripe_missing_component__' in file /usr/share/octave/4.0.0/m/help/__gripe_missing_component__.m near line 53, column 3

Kindly, reply ASAP

Regards,

Sanket Sharma
Research Scholar
GLA University, Mathura
India - 281406

Hi,

did you try to install the Debian package "liboctave-dev"?

Best regards
Oliver
_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Regarding package installation

marco atzeri-2
In reply to this post by SANKET SHARMA
On 17/01/2018 14:58, SANKET SHARMA wrote:

> I downloaded the *linear-algebra-2.2.2.tar.gz *file. And tried to
> install in Octave prompt by using command *pkg
> install linear-algebra-2.2.2.tar.gz *in the current working directory.
>
> But it showed the following error message:
>
> *pkg: please install the Debian package "liboctave-dev" to get the
> mkoctfile command **error: called from '__gripe_missing_component__' in
> file /usr/share/octave/4.0.0/m/help/__gripe_missing_component__.m near
> line 53, column 3*
> *
> *
> Kindly, reply ASAP
>
> Regards,
>

Hi Sanket,

you are probably looking for the already compiled package for debian
https://packages.debian.org/jessie/octave-linear-algebra

The command
  pkg install linear-algebra-2.2.2.tar.gz

will build and install from source code.

Regards
Marco

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave