Renaming pseudo_inverse routine in liboctave?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Renaming pseudo_inverse routine in liboctave?

Rik-4
All,

The function which calculates the Moore-Penrose pseudoinverse in liboctave
is named pseudo_inverse.  The conventional spelling for this term is just
one word--without any underscore.  See for example, Wikipedia
https://en.wikipedia.org/wiki/Moore%E2%80%93Penrose_inverse.

I thought I might rename the function and put in an alias which prints a
warning about the new name change.  That warning would persist for two
releases of Octave and then would be retired.

--Rik