Strange error along with strange version numbers in octave

classic Classic list List threaded Threaded
3 messages Options
RT
Reply | Threaded
Open this post in threaded view
|

Strange error along with strange version numbers in octave

RT

I installed the Octave flatpack from the software center and I'm getting a stange error along
with strange Octave version numbers.  Any idea what's going on? I'm using ubuntu 18.04 64bit.

http://i.imgur.com/AanAsDM.png
Could not copy help collection to temporary
file. Search capabilities may be affected.
Cannot create index tables in file /app/share/octave/5.0.91/doc/octave_interpreter.qhc.


----------------------------------------------------------------------
GNU Octave Version: 5.0.91 (hg id: 8c50b03c2016)
GNU Octave License: GNU General Public License
Operating System: Linux 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 2916:28:13 UTC 2019 x86_64
-------------------------------



Reply | Threaded
Open this post in threaded view
|

Re: Strange error along with strange version numbers in octave

Mike Miller-4
On Thu, Feb 07, 2019 at 21:03:26 -0500, RT wrote:
> I installed the Octave flatpack from the software center and I'm
> getting a stange error along with strange Octave version numbers.  Any
> idea what's going on? I'm using ubuntu 18.04 64bit.

Sure, the flatpak repository has been updated to Qt 5.12 and the second
release candidate for Octave 5.1. The correct version number is 5.0.91.

The error about the help collection is due to what I think is a Qt 5.12
bug. See https://github.com/flathub/org.octave.Octave/issues/45.

In general it's best to report flatpak-specific problems to the GitHub
project at https://github.com/flathub/org.octave.Octave/issues. Most
people on this help mailing list aren't following or aware of the
details of the flatpak packaging effort.

HTH,

--
mike



signature.asc (849 bytes) Download Attachment
RT
Reply | Threaded
Open this post in threaded view
|

Re: Strange error along with strange version numbers in octave

RT
Thanks will do.

On Thu, Feb 7, 2019 at 9:13 PM Mike Miller <[hidden email]> wrote:
On Thu, Feb 07, 2019 at 21:03:26 -0500, RT wrote:
> I installed the Octave flatpack from the software center and I'm
> getting a stange error along with strange Octave version numbers.  Any
> idea what's going on? I'm using ubuntu 18.04 64bit.

Sure, the flatpak repository has been updated to Qt 5.12 and the second
release candidate for Octave 5.1. The correct version number is 5.0.91.

The error about the help collection is due to what I think is a Qt 5.12
bug. See https://github.com/flathub/org.octave.Octave/issues/45.

In general it's best to report flatpak-specific problems to the GitHub
project at https://github.com/flathub/org.octave.Octave/issues. Most
people on this help mailing list aren't following or aware of the
details of the flatpak packaging effort.

HTH,

--
mike


--