Unable to install image acquisition package on Mac OS

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install image acquisition package on Mac OS

Sudhabrata Majumder
Dear All

Please help me to install image acquisition package on my Mac. When I run the command on octave terminal (pkg install -forge image-acquisition) it shown following report on the terminal.

>>  pkg install -forge image-acquisition
configure: error: unable to find the v4l2_open() function
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether clang++ -std=gnu++11 accepts -g... yes
checking for mkoctfile... yes
checking for fltk-config... /usr/local/bin/fltk-config
checking for v4l2_open in -lv4l2... no

pkg: error running the configure script for image-acquisition.
error: called from
    configure_make at line 82 column 9
    install at line 184 column 7
    pkg at line 437 column 9

Please help to find out, what are the things I am still missing?

Regards

Sudha


Reply | Threaded
Open this post in threaded view
|

Re: Unable to install image acquisition package on Mac OS

Mike Miller-4
On Sun, Aug 26, 2018 at 22:00:46 +0530, Sudhabrata Majumder wrote:
> checking for v4l2_open in -lv4l2... no
>
> pkg: error running the configure script for image-acquisition.
> error: called from
>     configure_make at line 82 column 9
>     install at line 184 column 7
>     pkg at line 437 column 9
>
> Please help to find out, what are the things I am still missing?

The image-acquisition package needs the v4l (Video4Linux) library.

Is it possible to use Video4Linux on macOS?

--
mike



signature.asc (849 bytes) Download Attachment