Unable to update Octave version in Lubuntu 16?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to update Octave version in Lubuntu 16?

IMacaulay
I see that the most recent version is showing as 4.2.1, but when I
have tried to update using

> sudo apt-get install octave

I get

  octave is already the newest version (4.0.2-1ubuntu5~octave~xenial1).

Any suggestions for updating my Octave, please?  My system is Lubuntu
16.04.2 LTS (kernel is Linux 4.4.0-72-generic (x86_64)).

Thanks.

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to update Octave version in Lubuntu 16?

ratulloch
That's the most stable release for your version.  If you want a more recent version you will have to compile it on your own machine.   A snap version or Appimage would be nice but none have been create that I know of.

On Thu, Apr 6, 2017 at 8:18 AM, IMacaulay <[hidden email]> wrote:
I see that the most recent version is showing as 4.2.1, but when I
have tried to update using

> sudo apt-get install octave

I get

  octave is already the newest version (4.0.2-1ubuntu5~octave~xenial1).

Any suggestions for updating my Octave, please?  My system is Lubuntu
16.04.2 LTS (kernel is Linux 4.4.0-72-generic (x86_64)).

Thanks.

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to update Octave version in Lubuntu 16?

tmacchant
----- Original Message -----

>From: Rick T 
>To: IMacaulay  
>Cc: [hidden email]
>Date: 2017/4/6, Thu 23:46
>Subject: Re: Unable to update Octave version in Lubuntu 16?
>On Thu, Apr 6, 2017 at 8:18 AM, IMacaulay <[hidden email]> wrote:
>
>I see that the most recent version is showing as 4.2.1, but when I
>>have tried to update using
>>
>>> sudo apt-get install octave
>>
>>I get
>>
>>  octave is already the newest version (4.0.2-1ubuntu5~octave~ xenial1).
>>
>>Any suggestions for updating my Octave, please?  My system is Lubuntu
>>16.04.2 LTS (kernel is Linux 4.4.0-72-generic (x86_64)).
>>
>>Thanks.
>>

>
>That's the most stable release for your version.  If you want a more recent version you will have to compile it on your own machine.   A snap version or Appimage would be nice but none have been create that I know of.
>
>


As Rick suggested, you have to build from source.

https://www.scivision.co/compiling-octave-4-on-ubuntu/


may be helpful.

Tatsuro

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Loading...