Version 4.x.x not recognized when installing control package

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Version 4.x.x not recognized when installing control package

Mariana
I have Octave 4.4.0 installed using MacPorts installation (*sudo port install
octave @4.4.0*)

When I run octave everything seems to be ok, but I need to install the
control package.

I tried using
*pkg install -forge image*

and got the following error message
*error: the following dependencies were unsatisfied: control needs octave >=
4.0.0*

However, when I use command version on octave I get
*ans = 4.x.x*

What now?





--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Version 4.x.x not recognized when installing control package

Marius Schamschula-5
On Jun 5, 2018, at 9:55 PM, Mariana <[hidden email]> wrote:

I have Octave 4.4.0 installed using MacPorts installation (*sudo port install
octave @4.4.0*)

When I run octave everything seems to be ok, but I need to install the
control package.

I tried using
*pkg install -forge image*

and got the following error message
*error: the following dependencies were unsatisfied: control needs octave >=
4.0.0*

However, when I use command version on octave I get
*ans = 4.x.x*

What now?


Two things:

1) I’ve also noticed the strange version string

2) Why are you trying to manually install a package? Under MacPorts

sudo port install octave-image

will install not just the image package, but all other octave packages it depends on, and then load them into octave for you.

Marius
--
Marius Schamschula