Warnings related to sundials ida in octave configuration

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Warnings related to sundials ida in octave configuration

José Luis García Pallero
Hello:

I'm trying to compile Octave 4.4.1 in Debian Sid and the ./configure
script emits two warnings about the sundials library:

configure: WARNING: SUNDIALS IDA library does not include the IDADENSE
linear solver, ode15i and ode15s will be disabled
configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
ode15i and ode15s will not support the sparse Jacobian feature

I've installes all libraries related with Sundials present in the
Debian Sid repositories:

libsundials-cvodes3
libsundials-cvode3
libsundials-nvecparallel-hypre3
libsundials-idas2
libsundials-nvecparallel-openmp3
libsundials-nvecparallel-pthread3
libsundials-sunmatrix1
libsundials-sunlinsol1
libsundials-ida3
libsundials-nvecparallel-mpi3
libsundials-nvecparallel-petsc3
libsundials-kinsol3
libsundials-arkode2
libsundials-nvecserial3
libsundials-dev

Are these warnings a problem of the Sundials in Debian ?

--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************

Reply | Threaded
Open this post in threaded view
|

Re: Warnings related to sundials ida in octave configuration

marco atzeri-2
Am 08.11.2018 um 11:43 schrieb José Luis García Pallero:

> Hello:
>
> I'm trying to compile Octave 4.4.1 in Debian Sid and the ./configure
> script emits two warnings about the sundials library:
>
> configure: WARNING: SUNDIALS IDA library does not include the IDADENSE
> linear solver, ode15i and ode15s will be disabled
> configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
> ode15i and ode15s will not support the sparse Jacobian feature
>
> I've installes all libraries related with Sundials present in the
> Debian Sid repositories:
>
> libsundials-cvodes3
> libsundials-cvode3
> libsundials-nvecparallel-hypre3
> libsundials-idas2
> libsundials-nvecparallel-openmp3
> libsundials-nvecparallel-pthread3
> libsundials-sunmatrix1
> libsundials-sunlinsol1
> libsundials-ida3
> libsundials-nvecparallel-mpi3
> libsundials-nvecparallel-petsc3
> libsundials-kinsol3
> libsundials-arkode2
> libsundials-nvecserial3
> libsundials-dev
>
> Are these warnings a problem of the Sundials in Debian ?
>

I guess you need the version 2.7 not the 3.x



---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus


Reply | Threaded
Open this post in threaded view
|

Re: Warnings related to sundials ida in octave configuration

José Luis García Pallero
El jue., 8 nov. 2018 a las 12:14, Marco Atzeri
(<[hidden email]>) escribió:

>
> Am 08.11.2018 um 11:43 schrieb José Luis García Pallero:
> > Hello:
> >
> > I'm trying to compile Octave 4.4.1 in Debian Sid and the ./configure
> > script emits two warnings about the sundials library:
> >
> > configure: WARNING: SUNDIALS IDA library does not include the IDADENSE
> > linear solver, ode15i and ode15s will be disabled
> > configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
> > ode15i and ode15s will not support the sparse Jacobian feature
> >
> > I've installes all libraries related with Sundials present in the
> > Debian Sid repositories:
> >
> > libsundials-cvodes3
> > libsundials-cvode3
> > libsundials-nvecparallel-hypre3
> > libsundials-idas2
> > libsundials-nvecparallel-openmp3
> > libsundials-nvecparallel-pthread3
> > libsundials-sunmatrix1
> > libsundials-sunlinsol1
> > libsundials-ida3
> > libsundials-nvecparallel-mpi3
> > libsundials-nvecparallel-petsc3
> > libsundials-kinsol3
> > libsundials-arkode2
> > libsundials-nvecserial3
> > libsundials-dev
> >
> > Are these warnings a problem of the Sundials in Debian ?
> >
>
> I guess you need the version 2.7 not the 3.x

Thanks, you are right. Sundials 2.7 is now in Debian Testing. But
sooner or later Sundials 3 will be in Debian Sid and will be the
default in other Linux distros. What is the reason Octave needs 2.7?
Due to IDADENSE and IDAKLU functions?

>
>
>
> ---
> Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
> https://www.avast.com/antivirus
>
>


--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************

Reply | Threaded
Open this post in threaded view
|

Re: Warnings related to sundials ida in octave configuration

Carlo de Falco-2


> On 8 Nov 2018, at 12:30, José Luis García Pallero <[hidden email]> wrote:
>

> Thanks, you are right. Sundials 2.7 is now in Debian Testing. But
> sooner or later Sundials 3 will be in Debian Sid and will be the
> default in other Linux distros. What is the reason Octave needs 2.7?
> Due to IDADENSE and IDAKLU functions?

This is a known issue which is being discussed here:

https://savannah.gnu.org/bugs/?func=detailitem&item_id=52475

help is needed and welcome by an autotools expert.

c.