What is the oldest version of octave that we are supporting?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

What is the oldest version of octave that we are supporting?

Doug Stewart-4

In the control pkg we have statements like this:

#include "nfields2.cc"  // delete this if support for Octave 3.8 gets dropped



--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

Rik-4
On 01/02/2019 09:00 AM, [hidden email] wrote:
Subject:
What is the oldest version of octave that we are supporting?
From:
Doug Stewart [hidden email]
Date:
01/02/2019 07:42 AM
To:
octave-maintainers [hidden email]
List-Post:
[hidden email]
Precedence:
list
MIME-Version:
1.0
Message-ID:
[hidden email]
Content-Type:
multipart/alternative; boundary="000000000000a59c94057e7b7f7f"
Message:
6


In the control pkg we have statements like this:

#include "nfields2.cc"  // delete this if support for Octave 3.8 gets dropped

Octave 3.8 is 5 years old.  Since control is a package it is up to the package maintainer to set their own deprecation policies, but I would be fine with dropping support.

--Rik

hg log -r release-3-8-2

changeset:   18991:a66548dc07b0
branch:      stable
tag:         release-3-8-2
parent:      18987:082063dc2165
user:        John W. Eaton [hidden email]
date:        Thu Aug 07 11:41:28 2014 -0400
summary:     Version 3.8.2 released.

Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

Doug Stewart-4


On Wed, Jan 2, 2019 at 12:35 PM Rik <[hidden email]> wrote:
On 01/02/2019 09:00 AM, [hidden email] wrote:
Subject:
What is the oldest version of octave that we are supporting?
From:
Doug Stewart [hidden email]
Date:
01/02/2019 07:42 AM
To:
octave-maintainers [hidden email]
List-Post:
[hidden email]
Precedence:
list
MIME-Version:
1.0
Message-ID:
[hidden email]
Content-Type:
multipart/alternative; boundary="000000000000a59c94057e7b7f7f"
Message:
6


In the control pkg we have statements like this:

#include "nfields2.cc"  // delete this if support for Octave 3.8 gets dropped

Octave 3.8 is 5 years old.  Since control is a package it is up to the package maintainer to set their own deprecation policies, but I would be fine with dropping support.

--Rik


Thanks. I think that only Octave 4.x.x should be supported.


 
hg log -r release-3-8-2

changeset:   18991:a66548dc07b0
branch:      stable
tag:         release-3-8-2
parent:      18987:082063dc2165
user:        John W. Eaton [hidden email]
date:        Thu Aug 07 11:41:28 2014 -0400
summary:     Version 3.8.2 released.



--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

jbect
Le 02/01/2019 à 18:49, Doug Stewart a écrit :
Octave 3.8 is 5 years old.  Since control is a package it is up to the package maintainer to set their own deprecation policies, but I would be fine with dropping support.

--Rik


Thanks. I think that only Octave 4.x.x should be supported.


None of my business, really, but for the record : 3.8.x is still available in Debian Jessie and Unbuntu Trusty.

Both are rather old, of course, but still in their LTS period...


Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

Doug Stewart-4


On Wed, Jan 2, 2019 at 1:54 PM Julien Bect <[hidden email]> wrote:
Le 02/01/2019 à 18:49, Doug Stewart a écrit :
Octave 3.8 is 5 years old.  Since control is a package it is up to the package maintainer to set their own deprecation policies, but I would be fine with dropping support.

--Rik


Thanks. I think that only Octave 4.x.x should be supported.


None of my business, really, but for the record : 3.8.x is still available in Debian Jessie and Unbuntu Trusty.

Both are rather old, of course, but still in their LTS period...


they can still use control 3.1.0

--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

jbect
Le 02/01/2019 à 19:56, Doug Stewart a écrit :
On Wed, Jan 2, 2019 at 1:54 PM Julien Bect <[hidden email]> wrote:
Le 02/01/2019 à 18:49, Doug Stewart a écrit :
Octave 3.8 is 5 years old.  Since control is a package it is up to the package maintainer to set their own deprecation policies, but I would be fine with dropping support.

--Rik


Thanks. I think that only Octave 4.x.x should be supported.


None of my business, really, but for the record : 3.8.x is still available in Debian Jessie and Unbuntu Trusty.

Both are rather old, of course, but still in their LTS period...

they can still use control 3.1.0


Sure.  As I said, none of my business...

Reply | Threaded
Open this post in threaded view
|

Re: What is the oldest version of octave that we are supporting?

Mike Miller-4
In reply to this post by jbect
On Wed, Jan 02, 2019 at 19:54:20 +0100, Julien Bect wrote:
> None of my business, really, but for the record : 3.8.x is still available
> in Debian Jessie and Unbuntu Trusty.

If you want another data point, the signal package supports 3.8 and will
continue to until it's no longer reasonably easy to maintain.

But as others said, it's completely up to the package maintainer's
discretion, and may depend heavily on how much compiled code there is,
what parts of the Octave API it touches, and of course available time
and interest.

--
mike

signature.asc (849 bytes) Download Attachment