can anyone please help with Octave rpm installed on Redhat el6 workstation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

can anyone please help with Octave rpm installed on Redhat el6 workstation

cici
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: can anyone please help with Octave rpm installed on Redhat el6 workstation

Jordi Gutiérrez Hermoso-2
On 6 September 2011 12:47, Ruixia Xu <[hidden email]> wrote:

> /usr/bin/octave: error while loading shared libraries: libhdf5.so.6:
> cannot open shared object file: No such file or directory
>
>
> Can anyone help me to find out why Octave is not running when it
> didn't show any error message after the rpm installed?

Looks like a packaging bug, but I don't understand how it could
happen, since rpm-making tools should catch linking dependencies
automatically. Is there an HDF5 rpm you can install?

- Jordi G. H.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: can anyone please help with Octave rpm installed on Redhat el6 workstation

Sergei Steshenko
In reply to this post by cici





>________________________________
>From: Ruixia Xu <[hidden email]>
>To: "[hidden email]" <[hidden email]>
>Sent: Tuesday, September 6, 2011 8:47 PM
>Subject: can anyone please help with Octave rpm installed on Redhat el6 workstation
>
>
>Dear all,
>
>
>I am new to Octave. I have just install octave rpm on my redhat enterprise workstation 6.0 for x86_64 machine:
>
>
># rpm -ivh octave-3.2.4-3.el6.x86_64.rpm
>warning: octave-3.2.4-3.el6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
>Preparing...                ########################################### [100%]
>   1:octave                 ########################################### [100%]
>
>
>
>Then, I typed and saw this:
>
>
># which octave
>/usr/bin/octave
># /usr/bin/octave
>/usr/bin/octave: error while loading shared libraries:
libhdf5.so.6: cannot open shared object file: No such file or directory

>
>
>
>
>Can anyone help me to find out why Octave is not running when it didn't show any error message after the rpm installed?
>
>
>many thanks.
>
>
>Ruixia
>
>
>
>_______________________________________________
>Help-octave mailing list
>[hidden email]
>https://mailman.cae.wisc.edu/listinfo/help-octave
>
>

The answer to your question is in your Email:


"

/usr/bin/octave: error while loading shared libraries:
libhdf5.so.6: cannot open shared object file: No such file or directory
"

- you need to install an RPm with HDF5 library. And apparently
'octave' RPM packagers forgot to include the missing RPM as a
dependency.

Regards,
  Sergei.




>
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: can anyone please help with Octave rpm installed on Redhat el6 workstation

cici
CONTENTS DELETED
The author has deleted this message.