crashing octave with copy command in editor

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

crashing octave with copy command in editor

Doug Stewart-4
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Dmitri A. Sergatskov


On Tue, Jan 8, 2019 at 9:22 AM Doug Stewart <[hidden email]> wrote:
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

I cannot reproduce this problem with bc6237a189e1 (stable)


 

--
DASCertificate for 206392


Dmitri.
--
Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Dmitri A. Sergatskov


On Tue, Jan 8, 2019 at 9:28 AM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:22 AM Doug Stewart <[hidden email]> wrote:
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

I cannot reproduce this problem with bc6237a189e1 (stable)



Hmm.. I just tried it on a different computer (Xeon + nvidia gpu) and I cannot start the gui --
it crashes with signal 6.
I will re-clone and re-compile.

Dmitri.
--


Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Dmitri A. Sergatskov


On Tue, Jan 8, 2019 at 12:06 PM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:28 AM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:22 AM Doug Stewart <[hidden email]> wrote:
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

I cannot reproduce this problem with bc6237a189e1 (stable)



Hmm.. I just tried it on a different computer (Xeon + nvidia gpu) and I cannot start the gui --
it crashes with signal 6.
I will re-clone and re-compile.


And after that it is working fine again...
bc6237a189e1 (stable) tip
 

Dmitri.
--

Dmitri.
--
Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Doug Stewart-4


On Tue, Jan 8, 2019 at 1:25 PM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 12:06 PM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:28 AM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:22 AM Doug Stewart <[hidden email]> wrote:
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

I cannot reproduce this problem with bc6237a189e1 (stable)



Hmm.. I just tried it on a different computer (Xeon + nvidia gpu) and I cannot start the gui --
it crashes with signal 6.
I will re-clone and re-compile.


And after that it is working fine again...
bc6237a189e1 (stable) tip
 

Dmitri.
--

Dmitri.
--

I updated my regular computer to a recent ver of stable and now see the problem on 2 computers.
I am bisecting to find the change that did it, and will do a bug report. 
--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Doug Stewart-4


On Wed, Jan 9, 2019 at 8:27 AM Doug Stewart <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 1:25 PM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 12:06 PM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:28 AM Dmitri A. Sergatskov <[hidden email]> wrote:


On Tue, Jan 8, 2019 at 9:22 AM Doug Stewart <[hidden email]> wrote:
I set up a new laptop with ubuntu 18.10 and 
doug@X555QA:~/octavec1$ hg id
72e0a106d956 (stable) tip
using Qt5 and octave --force-gui

When using the editor I tried to copy and paste some code
from one line to the next. If i use the mouse right button or if I use cntr-C 
to copy the highlighted lines, both methods crash out of octave.
octave shuts down. It looks like I had done a contr-C at the command prompt
of octave.

Is this just my machine or can others see the same problem?

I cannot reproduce this problem with bc6237a189e1 (stable)



Hmm.. I just tried it on a different computer (Xeon + nvidia gpu) and I cannot start the gui --
it crashes with signal 6.
I will re-clone and re-compile.


And after that it is working fine again...
bc6237a189e1 (stable) tip
 

Dmitri.
--

Dmitri.
--

I updated my regular computer to a recent ver of stable and now see the problem on 2 computers.
I am bisecting to find the change that did it, and will do a bug report. 
--
DASCertificate for 206392


I tried bisecting and the problem disappeared! on both machines!
I think that if you start a completely fresh build on a fresh mach. then it will fail but when you recompile the problem disappears.

--
DASCertificate for 206392

Reply | Threaded
Open this post in threaded view
|

Re: crashing octave with copy command in editor

Dmitri A. Sergatskov


On Wed, Jan 9, 2019 at 10:54 AM Doug Stewart <[hidden email]> wrote:

I tried bisecting and the problem disappeared! on both machines!
I think that if you start a completely fresh build on a fresh mach. then it will fail but when you recompile the problem disappears.

--
DASCertificate for 206392


I just build
HG ID for this build is "4d6392c879d7"
and again observed that the very first run terminates with signal 6 after that it runs fine:

Octave successfully built.  Now choose from the following:
 
   ./run-octave    - to run in place to test before installing
   make check      - to run the tests
   make install    - to install (PREFIX=/usr/local)
 
   HG ID for this build is "4d6392c879d7"
 
make[2]: Leaving directory '/home/dima/src/octave/gcc_def'
make[1]: Leaving directory '/home/dima/src/octave/gcc_def'
$ ./run-octave --gui
octave exited with signal 6
$ ./run-octave --gui
(runs fine)

In logs I see:

abrt-notification[9721]: Process 9544 (lt-octave-gui) crashed in malloc()

Dmitri.
--