--enable-64 and --enable-fortran-int-64 must match for stable-octave.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

--enable-64 and --enable-fortran-int-64 must match for stable-octave.

tmacchant
Hello

I have tried to mxe-build stable octave.
./configure --enable-devel-tools --enable-windows-64 --enable-octave=stable --enable-binary-packages --disable-docs

make zip-dist

--enable-64 and --enable-fortran-int-64 must match for stable-octave.

stop

???

I do not want to 64bit indexing. What is wrong?

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: --enable-64 and --enable-fortran-int-64 must match for stable-octave.

siko1056
tmacchant wrote

> Hello
>
> I have tried to mxe-build stable octave.
> ./configure --enable-devel-tools --enable-windows-64
> --enable-octave=stable --enable-binary-packages --disable-docs
>
> make zip-dist
>
> --enable-64 and --enable-fortran-int-64 must match for stable-octave.
>
> stop
>
> ???
>
> I do not want to 64bit indexing. What is wrong?
>
> Tatsuro

Recently on OctConf, we have merged 4.3.0+ to stable for the upcoming 4.4.0
feature release.  One of the new features is that 64 bit indices are default
on 64 bit systems [1].  I do not build MXE myself, but maybe you can explain
the error for MXE in more detail to become ready for the next stable release
soon?

Best,
Kai


[1] https://hg.savannah.gnu.org/hgweb/octave/file/a73dedb0d9b5/NEWS#l10



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html