hg clone fail to get gnulib subrepo

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

hg clone fail to get gnulib subrepo

Cameron Taggart
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Cameron Taggart
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Dmitri A. Sergatskov
Worked for me ~ an hour ago:

ls -go octave/gnulib/
total 4776
drwxrwxr-x  4    4096 Aug  1 14:59 build-aux
-rw-rw-r--  1    3241 Aug  1 14:59 cfg.mk
-rw-rw-r--  1 4249372 Aug  1 14:59 ChangeLog
-rwxrwxr-x  1    2366 Aug  1 14:59 check-copyright
-rwxrwxr-x  1    7725 Aug  1 14:59 check-module
drwxrwxr-x  2    4096 Aug  1 14:59 config
-rw-rw-r--  1    1015 Aug  1 14:59 COPYING
-rw-rw-r--  1    4743 Aug  1 14:59 DEPENDENCIES
drwxrwxr-x  8    4096 Aug  1 14:59 doc
-rwxrwxr-x  1  256352 Aug  1 14:59 gnulib-tool
drwxrwxr-x 14   36864 Aug  1 14:59 lib
drwxrwxr-x  2   24576 Aug  1 14:59 m4
-rw-rw-r--  1    6014 Aug  1 14:59 Makefile
drwxrwxr-x 15   57344 Aug  1 14:59 modules
-rwxrwxr-x  1   80332 Aug  1 14:59 MODULES.html.sh
-rw-rw-r--  1   39982 Aug  1 14:59 NEWS
-rwxrwxr-x  1   10169 Aug  1 14:59 posix-modules
-rw-rw-r--  1     183 Aug  1 14:59 README
-rw-rw-r--  1    4566 Aug  1 14:59 STATUS-libposix
drwxrwxr-x 15   36864 Aug  1 14:59 tests
drwxrwxr-x  2    4096 Aug  1 14:59 top
-rw-rw-r--  1    6775 Aug  1 14:59 users.txt

Dmitri.
--


On Tue, Aug 1, 2017 at 3:58 PM, Cameron Taggart <[hidden email]> wrote:
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.





Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Cameron Taggart
It was for me as well (see first 3 builds). I'll check again in the morning.

On Tue, Aug 1, 2017 at 11:59 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
Worked for me ~ an hour ago:

ls -go octave/gnulib/
total 4776
drwxrwxr-x  4    4096 Aug  1 14:59 build-aux
-rw-rw-r--  1    3241 Aug  1 14:59 cfg.mk
-rw-rw-r--  1 4249372 Aug  1 14:59 ChangeLog
-rwxrwxr-x  1    2366 Aug  1 14:59 check-copyright
-rwxrwxr-x  1    7725 Aug  1 14:59 check-module
drwxrwxr-x  2    4096 Aug  1 14:59 config
-rw-rw-r--  1    1015 Aug  1 14:59 COPYING
-rw-rw-r--  1    4743 Aug  1 14:59 DEPENDENCIES
drwxrwxr-x  8    4096 Aug  1 14:59 doc
-rwxrwxr-x  1  256352 Aug  1 14:59 gnulib-tool
drwxrwxr-x 14   36864 Aug  1 14:59 lib
drwxrwxr-x  2   24576 Aug  1 14:59 m4
-rw-rw-r--  1    6014 Aug  1 14:59 Makefile
drwxrwxr-x 15   57344 Aug  1 14:59 modules
-rwxrwxr-x  1   80332 Aug  1 14:59 MODULES.html.sh
-rw-rw-r--  1   39982 Aug  1 14:59 NEWS
-rwxrwxr-x  1   10169 Aug  1 14:59 posix-modules
-rw-rw-r--  1     183 Aug  1 14:59 README
-rw-rw-r--  1    4566 Aug  1 14:59 STATUS-libposix
drwxrwxr-x 15   36864 Aug  1 14:59 tests
drwxrwxr-x  2    4096 Aug  1 14:59 top
-rw-rw-r--  1    6775 Aug  1 14:59 users.txt

Dmitri.
--


On Tue, Aug 1, 2017 at 3:58 PM, Cameron Taggart <[hidden email]> wrote:
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.






Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Cameron Taggart
It worked for about an hour this morning. It is been broken all afternoon so far. I've been trying to setup a mirror on github, but can't even get it imported there.

On Wed, Aug 2, 2017 at 12:06 AM, Cameron Taggart <[hidden email]> wrote:
It was for me as well (see first 3 builds). I'll check again in the morning.

On Tue, Aug 1, 2017 at 11:59 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
Worked for me ~ an hour ago:

ls -go octave/gnulib/
total 4776
drwxrwxr-x  4    4096 Aug  1 14:59 build-aux
-rw-rw-r--  1    3241 Aug  1 14:59 cfg.mk
-rw-rw-r--  1 4249372 Aug  1 14:59 ChangeLog
-rwxrwxr-x  1    2366 Aug  1 14:59 check-copyright
-rwxrwxr-x  1    7725 Aug  1 14:59 check-module
drwxrwxr-x  2    4096 Aug  1 14:59 config
-rw-rw-r--  1    1015 Aug  1 14:59 COPYING
-rw-rw-r--  1    4743 Aug  1 14:59 DEPENDENCIES
drwxrwxr-x  8    4096 Aug  1 14:59 doc
-rwxrwxr-x  1  256352 Aug  1 14:59 gnulib-tool
drwxrwxr-x 14   36864 Aug  1 14:59 lib
drwxrwxr-x  2   24576 Aug  1 14:59 m4
-rw-rw-r--  1    6014 Aug  1 14:59 Makefile
drwxrwxr-x 15   57344 Aug  1 14:59 modules
-rwxrwxr-x  1   80332 Aug  1 14:59 MODULES.html.sh
-rw-rw-r--  1   39982 Aug  1 14:59 NEWS
-rwxrwxr-x  1   10169 Aug  1 14:59 posix-modules
-rw-rw-r--  1     183 Aug  1 14:59 README
-rw-rw-r--  1    4566 Aug  1 14:59 STATUS-libposix
drwxrwxr-x 15   36864 Aug  1 14:59 tests
drwxrwxr-x  2    4096 Aug  1 14:59 top
-rw-rw-r--  1    6775 Aug  1 14:59 users.txt

Dmitri.
--


On Tue, Aug 1, 2017 at 3:58 PM, Cameron Taggart <[hidden email]> wrote:
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.







Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Dmitri A. Sergatskov
I see the same problem now (using client computers on different networks).
It must be some problem with the server (or its provider).

Dmitri.
--

On Wed, Aug 2, 2017 at 5:07 AM, Cameron Taggart <[hidden email]> wrote:
It worked for about an hour this morning. It is been broken all afternoon so far. I've been trying to setup a mirror on github, but can't even get it imported there.

On Wed, Aug 2, 2017 at 12:06 AM, Cameron Taggart <[hidden email]> wrote:
It was for me as well (see first 3 builds). I'll check again in the morning.

On Tue, Aug 1, 2017 at 11:59 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
Worked for me ~ an hour ago:

ls -go octave/gnulib/
total 4776
drwxrwxr-x  4    4096 Aug  1 14:59 build-aux
-rw-rw-r--  1    3241 Aug  1 14:59 cfg.mk
-rw-rw-r--  1 4249372 Aug  1 14:59 ChangeLog
-rwxrwxr-x  1    2366 Aug  1 14:59 check-copyright
-rwxrwxr-x  1    7725 Aug  1 14:59 check-module
drwxrwxr-x  2    4096 Aug  1 14:59 config
-rw-rw-r--  1    1015 Aug  1 14:59 COPYING
-rw-rw-r--  1    4743 Aug  1 14:59 DEPENDENCIES
drwxrwxr-x  8    4096 Aug  1 14:59 doc
-rwxrwxr-x  1  256352 Aug  1 14:59 gnulib-tool
drwxrwxr-x 14   36864 Aug  1 14:59 lib
drwxrwxr-x  2   24576 Aug  1 14:59 m4
-rw-rw-r--  1    6014 Aug  1 14:59 Makefile
drwxrwxr-x 15   57344 Aug  1 14:59 modules
-rwxrwxr-x  1   80332 Aug  1 14:59 MODULES.html.sh
-rw-rw-r--  1   39982 Aug  1 14:59 NEWS
-rwxrwxr-x  1   10169 Aug  1 14:59 posix-modules
-rw-rw-r--  1     183 Aug  1 14:59 README
-rw-rw-r--  1    4566 Aug  1 14:59 STATUS-libposix
drwxrwxr-x 15   36864 Aug  1 14:59 tests
drwxrwxr-x  2    4096 Aug  1 14:59 top
-rw-rw-r--  1    6775 Aug  1 14:59 users.txt

Dmitri.
--


On Tue, Aug 1, 2017 at 3:58 PM, Cameron Taggart <[hidden email]> wrote:
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.








Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: hg clone fail to get gnulib subrepo

Dmitri A. Sergatskov
may be it is coincidental, but it worked when i did:

hg clone --uncompressed  http://hg.octave.org/gnulib

Dmitri.
--


On Wed, Aug 2, 2017 at 1:26 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
I see the same problem now (using client computers on different networks).
It must be some problem with the server (or its provider).

Dmitri.
--

On Wed, Aug 2, 2017 at 5:07 AM, Cameron Taggart <[hidden email]> wrote:
It worked for about an hour this morning. It is been broken all afternoon so far. I've been trying to setup a mirror on github, but can't even get it imported there.

On Wed, Aug 2, 2017 at 12:06 AM, Cameron Taggart <[hidden email]> wrote:
It was for me as well (see first 3 builds). I'll check again in the morning.

On Tue, Aug 1, 2017 at 11:59 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
Worked for me ~ an hour ago:

ls -go octave/gnulib/
total 4776
drwxrwxr-x  4    4096 Aug  1 14:59 build-aux
-rw-rw-r--  1    3241 Aug  1 14:59 cfg.mk
-rw-rw-r--  1 4249372 Aug  1 14:59 ChangeLog
-rwxrwxr-x  1    2366 Aug  1 14:59 check-copyright
-rwxrwxr-x  1    7725 Aug  1 14:59 check-module
drwxrwxr-x  2    4096 Aug  1 14:59 config
-rw-rw-r--  1    1015 Aug  1 14:59 COPYING
-rw-rw-r--  1    4743 Aug  1 14:59 DEPENDENCIES
drwxrwxr-x  8    4096 Aug  1 14:59 doc
-rwxrwxr-x  1  256352 Aug  1 14:59 gnulib-tool
drwxrwxr-x 14   36864 Aug  1 14:59 lib
drwxrwxr-x  2   24576 Aug  1 14:59 m4
-rw-rw-r--  1    6014 Aug  1 14:59 Makefile
drwxrwxr-x 15   57344 Aug  1 14:59 modules
-rwxrwxr-x  1   80332 Aug  1 14:59 MODULES.html.sh
-rw-rw-r--  1   39982 Aug  1 14:59 NEWS
-rwxrwxr-x  1   10169 Aug  1 14:59 posix-modules
-rw-rw-r--  1     183 Aug  1 14:59 README
-rw-rw-r--  1    4566 Aug  1 14:59 STATUS-libposix
drwxrwxr-x 15   36864 Aug  1 14:59 tests
drwxrwxr-x  2    4096 Aug  1 14:59 top
-rw-rw-r--  1    6775 Aug  1 14:59 users.txt

Dmitri.
--


On Tue, Aug 1, 2017 at 3:58 PM, Cameron Taggart <[hidden email]> wrote:
Same error when I try to clone it directly. :(

C:\Users\camer\tmp> hg clone http://hg.octave.org/gnulib
destination directory: gnulib
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 0 bytes, expected 4)

On Tue, Aug 1, 2017 at 11:50 PM, Cameron Taggart <[hidden email]> wrote:
Anyone else seeing a failure about the ability to clone because it is unable to clone the subrepo gnulib? I am able to reproduce locally on Windows too.









Loading...