install gsl package fails

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

install gsl package fails

karl

Hi all,

I have problems with installing the gsl package. Running Xubuntu 18.04, octave 4.4.1.

Using -forge the installation process stalls with the message:

pkg install -forge gsl
configure: error: gslcblas library not found

I have installed via synaptic:

libgslcblas0, libgsl-dev, libgsl23

Can anybody give me instructions what to do now?

Thanks :-)).

Karl



Reply | Threaded
Open this post in threaded view
|

RE: install gsl package fails

John Donoghue-3


> Message: 2
> Date: Tue, 27 Nov 2018 16:06:12 +0100
> From: [hidden email]
> To: [hidden email]
> Subject: install gsl package fails
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset="utf-8"; Format="flowed"
>
> Hi all,
>
> I have problems with installing the gsl package. Running Xubuntu 18.04,
octave

> 4.4.1.
>
> Using -forge the installation process stalls with the message:
>
>     /pkg install -forge gsl//
>     //configure: error: gslcblas library not found/
>
> I have installed via synaptic:
>
> libgslcblas0, libgsl-dev, libgsl23
>
> Can anybody give me instructions what to do now?
>
> Thanks :-)).
>
> Karl
> //


In Ubuntu 18.04, installing just libgsl-dev, (which then installs as
dependencies libgsl23 libgslcblas0 ),
It successfully installs ok for me.

Running with verbose, what does it display?

pkg install -forge -verbose gsl




Reply | Threaded
Open this post in threaded view
|

Re: install gsl package fails

karl
Am 27.11.18 um 18:50 schrieb JohnD:

Message: 2
Date: Tue, 27 Nov 2018 16:06:12 +0100
From: [hidden email]
To: [hidden email]
Subject: install gsl package fails
Message-ID: [hidden email]
Content-Type: text/plain; charset="utf-8"; Format="flowed"

Hi all,

I have problems with installing the gsl package. Running Xubuntu 18.04,
octave
4.4.1.

Using -forge the installation process stalls with the message:

    /pkg install -forge gsl//
    //configure: error: gslcblas library not found/

I have installed via synaptic:

libgslcblas0, libgsl-dev, libgsl23

Can anybody give me instructions what to do now?

Thanks :-)).

Karl
//

In Ubuntu 18.04, installing just libgsl-dev, (which then installs as
dependencies libgsl23 libgslcblas0 ),
It successfully installs ok for me.

Running with verbose, what does it display?

pkg install -forge -verbose gsl

Hi John,

did you read my mail? It says:

"I have installed via synaptic:

libgslcblas0, libgsl-dev, libgsl23"

So why do you advise me then to install libgsl-dev?

Thanks

Ciao
Karl 





Reply | Threaded
Open this post in threaded view
|

Re: install gsl package fails

mmuetzel
karl wrote
> Hi John,
>
> did you read my mail?

Maybe it is you who is having problems reading mails?


JohnD wrote
>> Running with verbose, what does it display?
>>
>> pkg install -forge -verbose gsl

You didn't answer his question.

In general, please try to be polite when people are offering their help.

Markus



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: install gsl package fails

John Donoghue-3
In reply to this post by karl
On 11/28/18 12:01 AM, [hidden email] wrote:
Am 27.11.18 um 18:50 schrieb JohnD:
Message: 2
Date: Tue, 27 Nov 2018 16:06:12 +0100
From: [hidden email]
To: [hidden email]
Subject: install gsl package fails
Message-ID: [hidden email]
Content-Type: text/plain; charset="utf-8"; Format="flowed"

Hi all,

I have problems with installing the gsl package. Running Xubuntu 18.04,
octave
4.4.1.

Using -forge the installation process stalls with the message:

    /pkg install -forge gsl//
    //configure: error: gslcblas library not found/

I have installed via synaptic:

libgslcblas0, libgsl-dev, libgsl23

Can anybody give me instructions what to do now?

Thanks :-)).

Karl
//
In Ubuntu 18.04, installing just libgsl-dev, (which then installs as
dependencies libgsl23 libgslcblas0 ),
It successfully installs ok for me.

Running with verbose, what does it display?

pkg install -forge -verbose gsl

Hi John,

did you read my mail? It says:

"I have installed via synaptic:

libgslcblas0, libgsl-dev, libgsl23"

So why do you advise me then to install libgsl-dev?

Thanks

Ciao
Karl 

      


I didnt - I said that was all I had to install. And then asked what does it display in verbose mode.