installing io (and other) packages

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

installing io (and other) packages

noel hughes
I will be very grateful if someone can guide me to successfully install Octave packages.

I am running under ubuntu linux, I have Octave 4.0 installed.  When I execute, from the terminal window,
 java -version,    I get:
openjdk version "1.8.0_171"
OpenJDK Runtime Environment (build 1.8.0_171-8u171-b11-0ubuntu0.16.04.1-b11)
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)

in Octave, this command
pkg list           replies with this (no mention of java):
Package Name  | Version | Installation directory
--------------+---------+-----------------------
          io  |  2.4.11 | /home/nhughes/octave/io-2.4.11

I am a mechanical engineer with rudimentary computer skills.  I am at a loss as to what to try next.  Any reply/help to [hidden email] will be greatly appreciated.
Noel Hughes


Reply | Threaded
Open this post in threaded view
|

Re: installing io (and other) packages

PhilipNienhuis
noel hughes wrote

> I will be very grateful if someone can guide me to successfully install
> Octave packages.
>
> I am running under ubuntu linux, I have Octave 4.0 installed.  When I
> execute, from the terminal window,
>  java -version,    I get:
> openjdk version "1.8.0_171"
> OpenJDK Runtime Environment (build
> 1.8.0_171-8u171-b11-0ubuntu0.16.04.1-b11)
> OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)
>
> in Octave, this command
> pkg list           replies with this (no mention of java):
> Package Name  | Version | Installation directory
> --------------+---------+-----------------------
>           io  |  2.4.11 | /home/nhughes/octave/io-2.4.11

Installation seems to be OK.
However to use the functions in the io package you'd also have to load the
package by issuing the command:

pkg load io

After that, the output of pkg list should mention something long the lines
of:

                io *|  2.4.11 |
...\dist\octave\share\octave\packages\io-2.4.11

(note the asterisk which means that the package has been loaded).

HTH
Philip



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html