java in octave 4.2.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

java in octave 4.2.1

John
Hi members,
I have  installed octave 4.2.1 ans package symbolic-win-py-bundle 2.60.zip.
works perfect.
Now I saw  you have to install java.Otherwie in wiki-octave they say don't
install java in octave 3.8
or later.
Now my question is you have to install java????for what is it needed??
and if it is yes what version....

Thank you





--
Sent from: http://octave.1599824.n4.nabble.com/Octave-Maintainers-f1638794.html


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: java in octave 4.2.1

Mike Miller-4
On Tue, Mar 13, 2018 at 12:28:49 -0700, John wrote:
> Hi members,
> I have  installed octave 4.2.1 ans package symbolic-win-py-bundle 2.60.zip.
> works perfect.
> Now I saw  you have to install java.Otherwie in wiki-octave they say don't
> install java in octave 3.8
> or later.
> Now my question is you have to install java????for what is it needed??
> and if it is yes what version....

This looks like a question for the general help list, not the
maintainers list.

Please post your question there, and include more information about what
prompted you to think that you have to install Java.

--
mike


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: java in octave 4.2.1

tmacchant
In reply to this post by John
--- gil.decraemer

> Hi members,
> I have  installed octave 4.2.1 ans package symbolic-win-py-bundle 2.60.zip.
> works perfect.
> Now I saw  you have to install java.Otherwie in wiki-octave they say don't
> install java in octave 3.8
> or later.
> Now my question is you have to install java????for what is it needed??
> and if it is yes what version....
>
> Thank you
>
To enble Java features in octave core,  JRE is required. Some features in io package use Java interface.

You need not intall JRE if you do not use Java features.

I use oracle JRE. openjdk for windows is available. But I have never tested.

Tatsuro



-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------