make check hangs in recent dev

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

make check hangs in recent dev

Dmitri A. Sergatskov
make check hangs at the end (after all checks has passed)
with octave process running with 100% CPU utilization.

(I verified it also on other machines).

I took buildbot client off-line until this gets resolved.

Dmitri.
--


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
Also running

./run-octave --no-gui
"quit"
would just hangs OK with 100% CPU.

(default, gui version seems to be working fine).

Dmitri.


On Sun, Apr 9, 2017 at 2:00 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
make check hangs at the end (after all checks has passed)
with octave process running with 100% CPU utilization.

(I verified it also on other machines).

I took buildbot client off-line until this gets resolved.

Dmitri.
--



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Torsten-3
In reply to this post by Dmitri A. Sergatskov
On 09.04.2017 21:00, Dmitri A. Sergatskov wrote:

> I noticed that after
> http://buildbot.octave.org:8010/changes/2871
>
> make check hangs at the end (after all checks has passed)
> with octave process running with 100% CPU utilization.
> E.g.:
> http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>
> (I verified it also on other machines).
>
> I took buildbot client off-line until this gets resolved.
>
> Dmitri.
> --
>
>

After the mentioned changeset, the cli version still works on my system.
It seems that my last changeset
http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
broke the cli version.

Torsten


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov


On Sun, Apr 9, 2017 at 3:13 PM, Torsten <[hidden email]> wrote:
On 09.04.2017 21:00, Dmitri A. Sergatskov wrote:
> I noticed that after
> http://buildbot.octave.org:8010/changes/2871
>
> make check hangs at the end (after all checks has passed)
> with octave process running with 100% CPU utilization.
> E.g.:
> http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>
> (I verified it also on other machines).
>
> I took buildbot client off-line until this gets resolved.
>
> Dmitri.
> --
>
>

After the mentioned changeset, the cli version still works on my system.
It seems that my last changeset
http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
broke the cli version.



​Perhaps the issue was intermittent. You can see on buildbot ​logs multiple
The default gcc compile seems to finished OK, but llvm and lto both hanged
(I noticed 2 octaves running on my machine.)

 
Torsten


​Dmitri.
--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Torsten-3
On 09.04.2017 22:22, Dmitri A. Sergatskov wrote:

>
>
> On Sun, Apr 9, 2017 at 3:13 PM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 09.04.2017 21:00, Dmitri A. Sergatskov wrote:
>     > I noticed that after
>     > http://buildbot.octave.org:8010/changes/2871
>     <http://buildbot.octave.org:8010/changes/2871>
>     >
>     > make check hangs at the end (after all checks has passed)
>     > with octave process running with 100% CPU utilization.
>     > E.g.:
>     >
>     http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>     <http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio>
>     >
>     > (I verified it also on other machines).
>     >
>     > I took buildbot client off-line until this gets resolved.
>     >
>     > Dmitri.
>     > --
>     >
>     >
>
>     After the mentioned changeset, the cli version still works on my system.
>     It seems that my last changeset
>     http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
>     <http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f>
>     broke the cli version.
>
>
>
> ​Perhaps the issue was intermittent. You can see on buildbot ​logs multiple
> failures during make check.
>
> http://buildbot.octave.org:8010/waterfall
>
> The default gcc compile seems to finished OK, but llvm and lto both hanged
> (I noticed 2 octaves running on my machine.)
>
>

Since I really don't know at the moment, where to look for the erroneous
side effect, I have backed out the last changeset. The cli version now
exits normally again on my system.

Torsten


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
On Sun, Apr 9, 2017 at 3:29 PM, Torsten <[hidden email]> wrote:
On 09.04.2017 22:22, Dmitri A. Sergatskov wrote:
>
>
> On Sun, Apr 9, 2017 at 3:13 PM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 09.04.2017 21:00, Dmitri A. Sergatskov wrote:
>     > I noticed that after
>     > http://buildbot.octave.org:8010/changes/2871
>     <http://buildbot.octave.org:8010/changes/2871>
>     >
>     > make check hangs at the end (after all checks has passed)
>     > with octave process running with 100% CPU utilization.
>     > E.g.:
>     >
>     http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>     <http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio>
>     >
>     > (I verified it also on other machines).
>     >
>     > I took buildbot client off-line until this gets resolved.
>     >
>     > Dmitri.
>     > --
>     >
>     >
>
>     After the mentioned changeset, the cli version still works on my system.
>     It seems that my last changeset
>     http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
>     <http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f>
>     broke the cli version.
>
>
>
> ​Perhaps the issue was intermittent. You can see on buildbot ​logs multiple
> failures during make check.
>
> http://buildbot.octave.org:8010/waterfall
>
> The default gcc compile seems to finished OK, but llvm and lto both hanged
> (I noticed 2 octaves running on my machine.)
>
>

Since I really don't know at the moment, where to look for the erroneous
side effect, I have backed out the last changeset. The cli version now
exits normally again on my system.

​On my computer it still hangs. And I suspect also on JWE​
Try to compile with clang.
It looks to me as some kind of racing condition that gets exposed by either different compiler or
different level of optimization.



Torsten


​Dmitri.
--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Torsten-3
On 09.04.2017 23:31, Dmitri A. Sergatskov wrote:

> On Sun, Apr 9, 2017 at 3:29 PM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 09.04.2017 22:22, Dmitri A. Sergatskov wrote:
>     >
>     >
>     > On Sun, Apr 9, 2017 at 3:13 PM, Torsten <[hidden email] <mailto:[hidden email]>
>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>     >
>     >     On 09.04.2017 21:00, Dmitri A. Sergatskov wrote:
>     >     > I noticed that after
>     >     > http://buildbot.octave.org:8010/changes/2871
>     <http://buildbot.octave.org:8010/changes/2871>
>     >     <http://buildbot.octave.org:8010/changes/2871
>     <http://buildbot.octave.org:8010/changes/2871>>
>     >     >
>     >     > make check hangs at the end (after all checks has passed)
>     >     > with octave process running with 100% CPU utilization.
>     >     > E.g.:
>     >     >
>     >  
>      http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>     <http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio>
>     >  
>      <http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio
>     <http://buildbot.octave.org:8010/builders/clang-fedora/builds/381/steps/test/logs/stdio>>
>     >     >
>     >     > (I verified it also on other machines).
>     >     >
>     >     > I took buildbot client off-line until this gets resolved.
>     >     >
>     >     > Dmitri.
>     >     > --
>     >     >
>     >     >
>     >
>     >     After the mentioned changeset, the cli version still works on
>     my system.
>     >     It seems that my last changeset
>     >     http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
>     <http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f>
>     >     <http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f
>     <http://hg.savannah.gnu.org/hgweb/octave/rev/2cee3976d88f>>
>     >     broke the cli version.
>     >
>     >
>     >
>     > ​Perhaps the issue was intermittent. You can see on buildbot ​logs
>     multiple
>     > failures during make check.
>     >
>     > http://buildbot.octave.org:8010/waterfall
>     <http://buildbot.octave.org:8010/waterfall>
>     >
>     > The default gcc compile seems to finished OK, but llvm and lto
>     both hanged
>     > (I noticed 2 octaves running on my machine.)
>     >
>     >
>
>     Since I really don't know at the moment, where to look for the erroneous
>     side effect, I have backed out the last changeset. The cli version now
>     exits normally again on my system.
>
>
> ​On my computer it still hangs. And I suspect also on JWE​
> ​
> ​'s:
>
> ​
> http://buildbot.octave.org:8010/builders/gcc-6-lto-debian/builds/416/steps/test/logs/stdio
>
> Try to compile with clang.
> It looks to me as some kind of racing condition that gets exposed by
> either different compiler or
> different level of optimization.
>
>
>
>     Torsten
>
>
> ​Dmitri.
> --
> ​
>

I have also backed out the first changeset now.

Torsten

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email]> wrote:


>

I have also backed out the first changeset now.


​I confirm that this fixed it for me.​

 
Torsten

​Dmitri.
--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Torsten-3
On 10.04.2017 07:33, Dmitri A. Sergatskov wrote:

> On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     >
>
>     I have also backed out the first changeset now.
>
>
> ​I confirm that this fixed it for me.​
>
>  
>
>     Torsten
>
>
> ​Dmitri.
> --

Dmitri,

I have prepared a patch that does not freeze octave cli on my system and
uploaded it to the bug report. Would you mind to test it with your build
configuration before I push it?

Torsten



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
On Tue, Apr 11, 2017 at 12:35 PM, Torsten <[hidden email]> wrote:
On 10.04.2017 07:33, Dmitri A. Sergatskov wrote:
> On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     >
>
>     I have also backed out the first changeset now.
>
>
> ​I confirm that this fixed it for me.​
>
>
>
>     Torsten
>
>
> ​Dmitri.
> --

Dmitri,

I have prepared a patch that does not freeze octave cli on my system and
uploaded it to the bug report. Would you mind to test it with your build
configuration before I push it?

​Yes I would. How would I do that?
I have
hg id
62320e943696 tip @

​At the moment.​

 

Torsten



​Dmitri.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
On Tue, Apr 11, 2017 at 12:53 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
On Tue, Apr 11, 2017 at 12:35 PM, Torsten <[hidden email]> wrote:
On 10.04.2017 07:33, Dmitri A. Sergatskov wrote:
> On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     >
>
>     I have also backed out the first changeset now.
>
>
> ​I confirm that this fixed it for me.​
>
>
>
>     Torsten
>
>
> ​Dmitri.
> --

Dmitri,

I have prepared a patch that does not freeze octave cli on my system and
uploaded it to the bug report. Would you mind to test it with your build
configuration before I push it?

​Yes I would. How would I do that?
I have
hg id
62320e943696 tip @

​At the moment.​

 

Torsten



​Dmitri.


​Never mind -- just saw a patch on savannah, am compiling at the moment...

Dmitri.
 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Dmitri A. Sergatskov
On Tue, Apr 11, 2017 at 12:57 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
On Tue, Apr 11, 2017 at 12:53 PM, Dmitri A. Sergatskov <[hidden email]> wrote:
On Tue, Apr 11, 2017 at 12:35 PM, Torsten <[hidden email]> wrote:
On 10.04.2017 07:33, Dmitri A. Sergatskov wrote:
> On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     >
>
>     I have also backed out the first changeset now.
>
>
> ​I confirm that this fixed it for me.​
>
>
>
>     Torsten
>
>
> ​Dmitri.
> --

Dmitri,

I have prepared a patch that does not freeze octave cli on my system and
uploaded it to the bug report. Would you mind to test it with your build
configuration before I push it?

​Yes I would. How would I do that?
I have
hg id
62320e943696 tip @

​At the moment.​

 

Torsten



​Dmitri.


​Never mind -- just saw a patch on savannah, am compiling at the moment...

Dmitri.

​It is working fine on my machine.

Dmitri.
--
 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make check hangs in recent dev

Torsten-3
On 11.04.2017 20:19, Dmitri A. Sergatskov wrote:

> On Tue, Apr 11, 2017 at 12:57 PM, Dmitri A. Sergatskov
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     On Tue, Apr 11, 2017 at 12:53 PM, Dmitri A. Sergatskov
>     <[hidden email] <mailto:[hidden email]>> wrote:
>
>         On Tue, Apr 11, 2017 at 12:35 PM, Torsten <[hidden email]
>         <mailto:[hidden email]>> wrote:
>
>             On 10.04.2017 07:33, Dmitri A. Sergatskov wrote:
>             > On Mon, Apr 10, 2017 at 12:11 AM, Torsten <[hidden email] <mailto:[hidden email]>
>             > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>             >
>             >
>             >
>             >     >
>             >
>             >     I have also backed out the first changeset now.
>             >
>             >
>             > ​I confirm that this fixed it for me.​
>             >
>             >
>             >
>             >     Torsten
>             >
>             >
>             > ​Dmitri.
>             > --
>
>             Dmitri,
>
>             I have prepared a patch that does not freeze octave cli on
>             my system and
>             uploaded it to the bug report. Would you mind to test it
>             with your build
>             configuration before I push it?
>
>
>         ​Yes I would. How would I do that?
>         I have
>         ​
>         hg id
>         62320e943696 tip @
>
>         ​At the moment.​
>
>          
>
>
>             Torsten
>
>
>
>         ​Dmitri.
>         ​
>
>
>     ​Never mind -- just saw a patch on savannah, am compiling at the
>     moment...
>
>     Dmitri.
>     ​
>
>
> ​It is working fine on my machine.
>
> Dmitri.
> --
> ​

Great, thanks!

Torsten



Loading...