make error in GEN doc/interpreter/interpft.eps OSMesa >= 9.0? in stable

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

make error in GEN doc/interpreter/interpft.eps OSMesa >= 9.0? in stable

tmacchant
Platform Ubuntu 16.04, gcc 5.4.0
Stable source b940e457e11f

$ make
 :

GEN doc/interpreter/interpft.eps

error: __osmesa_print__: Depth and stencil doesn't match, are you sure you are using OSMesa >= 9.0?


osmesa on ubuntu is 17.2.8.

Is this bug or something wrong on my system?

Build on March 28, I did not see such error.
This error comes from new change recently.


Tatsuro

Reply | Threaded
Open this post in threaded view
|

Re: make error in GEN doc/interpreter/interpft.eps OSMesa >= 9.0? in stable

Colin Macdonald-2
On 2018-03-30 03:46 PM, Tatsuro MATSUOKA wrote:

> Platform Ubuntu 16.04, gcc 5.4.0
> Stable source b940e457e11f
>
> $ make
>   :
>
> GEN doc/interpreter/interpft.eps
>
> error: __osmesa_print__: Depth and stencil doesn't match, are you sure you are using OSMesa >= 9.0?
>
>
> osmesa on ubuntu is 17.2.8.
>
> Is this bug or something wrong on my system?
>
> Build on March 28, I did not see such error.
> This error comes from new change recently.

Same on Fedora 27, but I think---not sure---that I've been seeing this
for a long time.

Colin

Reply | Threaded
Open this post in threaded view
|

Re: make error in GEN doc/interpreter/interpft.eps OSMesa >= 9.0? in stable

tmacchant
----- Original Message -----

> From: Colin Macdonald
> To: octave-maintainers
> Cc:
> Date: 2018/3/31, Sat 13:09
> Subject: Re: make error in GEN doc/interpreter/interpft.eps OSMesa >= 9.0? in stable
>
> On 2018-03-30 03:46 PM, Tatsuro MATSUOKA wrote:
>>  Platform Ubuntu 16.04, gcc 5.4.0
>>  Stable source b940e457e11f
>>
>>  $ make
>>    :
>>
>>  GEN doc/interpreter/interpft.eps
>>
>>  error: __osmesa_print__: Depth and stencil doesn't match, are you sure
> you are using OSMesa >= 9.0?
>>
>>
>>  osmesa on ubuntu is 17.2.8.
>>
>>  Is this bug or something wrong on my system?
>>
>>  Build on March 28, I did not see such error.
>>  This error comes from new change recently.
>
> Same on Fedora 27, but I think---not sure---that I've been seeing this for a
> long time.
>
> Colin

My struggle on Ubuntu 16.04 is described here.
 
https://savannah.gnu.org/bugs/?53529

HTH

Tatsuro