missing:qcollectiongenerator qhelpgenerator

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

missing:qcollectiongenerator qhelpgenerator

Carlos Davila

Hello,

I am trying to install octave (v 4.4.0) from source on Cygwin. After installing most dependencies, ./config gives:

Build Octave Qt GUI:                  no (missing:qcollectiongenerator qhelpgenerator)

However these appear to have already been installed, from package qt4-debuginfo.  The following directories exist:

/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qcollectiongenerator/
/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qhelpconverter/

Would appreciate any suggestions.

Carlos


Reply | Threaded
Open this post in threaded view
|

Re: missing:qcollectiongenerator qhelpgenerator

Mike Miller-4
On Thu, Jul 19, 2018 at 15:31:18 -0500, Carlos Davila wrote:

> I am trying to install octave (v 4.4.0) from source on Cygwin. After
> installing most dependencies, ./config gives:
>
> Build Octave Qt GUI:                  no (missing:qcollectiongenerator qhelpgenerator)
>
> However these appear to have already been installed, from package
> qt4-debuginfo.  The following directories exist:
>
> /usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qcollectiongenerator/
> /usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qhelpconverter/
>
> Would appreciate any suggestions.
Those directories are either source code or debug symbols only, not the
actual executables. Octave needs the programs to be installed, typically
in /usr/bin or in /usr/lib/qt4/bin. The package name might be something
like qt4-dev-tools, but I don't use Cygwin so I don't know for sure.

If Cygwin offers Qt 5 as an option you might want to use that instead.

--
mike



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: missing:qcollectiongenerator qhelpgenerator

marco atzeri-2
In reply to this post by Carlos Davila
Am 19.07.2018 um 22:31 schrieb Carlos Davila:

> Hello,
>
> I am trying to install octave (v 4.4.0) from source on Cygwin. After
> installing most dependencies, ./config gives:
>
> Build Octave Qt GUI:                  no (missing:qcollectiongenerator
> qhelpgenerator)
>
> However these appear to have already been installed, from package
> qt4-debuginfo.  The following directories exist:
>
> /usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qcollectiongenerator/
>
> /usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qhelpconverter/
>
> Would appreciate any suggestions.
>
> Carlos
>

you need the develelopment packages.
/usr/src/debug is for *debuginfo packages content

You can identify the package using "cygcheck"
$ cygcheck -p qhelpconverter
Found 10 matches for qhelpconverter
qt4-debuginfo-4.8.7-3 - qt4-debuginfo: ..
qt4-debuginfo-4.8.7-4 - qt4-debuginfo: ..
qt4-devel-tools-4.8.7-3 - qt4-devel-tools: Qt4 Assistant, Designer, and
Linguist (installed binaries and support files)
qt4-devel-tools-4.8.7-4 - qt4-devel-tools: Qt4 Assistant, Designer, and
Linguist (installed binaries and support files)
qt5-doc-tools-5.9.2-1 - qt5-doc-tools: Qt C++ application framework
(development tools) (documentation generators)
qt5-doc-tools-5.9.3-1 - qt5-doc-tools: Qt C++ application framework
(development tools) (documentation generators)
qt5-doc-tools-5.9.4-1 - qt5-doc-tools: Qt C++ application framework
(development tools) (documentation generators)
qt5-tools-debuginfo-5.9.2-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.3-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.4-1 - qt5-tools-debuginfo: ..

So "qt4-devel-tools" and "qt5-doc-tools"

You should be able to build also with Qt5.
I just build 4.4.1-rc1 with QT5

Regards
Marco



---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus



Reply | Threaded
Open this post in threaded view
|

Re: missing:qcollectiongenerator qhelpgenerator

Carlos Davila
Thank you, qt5-doc-tools was the correct package. I ran "make" from within the "~/Downloads/octave-4.4.0" directory and got:

can't read ~/Downloads/octave-4.4.0/liboctave/liboctave.la: No such file or directory
error: '.../octave-4.4.0/liboctave/liboctave.la' is not a valid libtool archive

I checked that directory and liboctave.la is present. I am trying "./configure", and "make", (and planned to do "make install") from within the octave-4.4.0" directory. Could this be the problem?

On Sat, Jul 21, 2018 at 2:31 AM, Marco Atzeri <[hidden email]> wrote:
Am 19.07.2018 um 22:31 schrieb Carlos Davila:
Hello,

I am trying to install octave (v 4.4.0) from source on Cygwin. After installing most dependencies, ./config gives:

Build Octave Qt GUI:                  no (missing:qcollectiongenerator qhelpgenerator)

However these appear to have already been installed, from package qt4-debuginfo.  The following directories exist:

/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qcollectiongenerator/

/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qhelpconverter/

Would appreciate any suggestions.

Carlos


you need the develelopment packages.
/usr/src/debug is for *debuginfo packages content

You can identify the package using "cygcheck"
$ cygcheck -p qhelpconverter
Found 10 matches for qhelpconverter
qt4-debuginfo-4.8.7-3 - qt4-debuginfo: ..
qt4-debuginfo-4.8.7-4 - qt4-debuginfo: ..
qt4-devel-tools-4.8.7-3 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
qt4-devel-tools-4.8.7-4 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
qt5-doc-tools-5.9.2-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-doc-tools-5.9.3-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-doc-tools-5.9.4-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-tools-debuginfo-5.9.2-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.3-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.4-1 - qt5-tools-debuginfo: ..

So "qt4-devel-tools" and "qt5-doc-tools"

You should be able to build also with Qt5.
I just build 4.4.1-rc1 with QT5

Regards
Marco



---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus






Reply | Threaded
Open this post in threaded view
|

Re: missing:qcollectiongenerator qhelpgenerator

Carlos Davila
The GUI runs, however I cannot plot. I get:

Octave was configured for "x86_64-unknown-cygwin".

Additional information about Octave is available at https://www.octave.org.

Please contribute if you find this software useful.
For more information, visit https://www.octave.org/get-involved.html

Read https://www.octave.org/bugs.html to learn how to submitbug reports.
For information about changes from previous versions, type 'news'.

libGL error: Screen is not Windows-DRI capable
>> plot([1 2 3])
      0 [main] octave-gui 5720 child_info_fork::abort: C:\cygwin64\home\CarlosDavila\Downloads\octave-4.4.0\liboctave\.libs\cygoctave-5.dll: Loaded to different address: parent(0x43CDD0000) != child(0xE90000)
error: Resource temporarily unavailable
error: called from
    __gnuplot_open_stream__ at line 32 column 40
    __gnuplot_drawnow__ at line 72 column 19

On Sat, Jul 21, 2018 at 12:26 PM, Carlos Davila <[hidden email]> wrote:
Thank you, qt5-doc-tools was the correct package. I ran "make" from within the "~/Downloads/octave-4.4.0" directory and got:

can't read ~/Downloads/octave-4.4.0/liboctave/liboctave.la: No such file or directory
error: '.../octave-4.4.0/liboctave/liboctave.la' is not a valid libtool archive

I checked that directory and liboctave.la is present. I am trying "./configure", and "make", (and planned to do "make install") from within the octave-4.4.0" directory. Could this be the problem?

On Sat, Jul 21, 2018 at 2:31 AM, Marco Atzeri <[hidden email]> wrote:
Am 19.07.2018 um 22:31 schrieb Carlos Davila:
Hello,

I am trying to install octave (v 4.4.0) from source on Cygwin. After installing most dependencies, ./config gives:

Build Octave Qt GUI:                  no (missing:qcollectiongenerator qhelpgenerator)

However these appear to have already been installed, from package qt4-debuginfo.  The following directories exist:

/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qcollectiongenerator/

/usr/src/debug/qt4-4.8.7-3/tools/assistant/tools/qhelpconverter/

Would appreciate any suggestions.

Carlos


you need the develelopment packages.
/usr/src/debug is for *debuginfo packages content

You can identify the package using "cygcheck"
$ cygcheck -p qhelpconverter
Found 10 matches for qhelpconverter
qt4-debuginfo-4.8.7-3 - qt4-debuginfo: ..
qt4-debuginfo-4.8.7-4 - qt4-debuginfo: ..
qt4-devel-tools-4.8.7-3 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
qt4-devel-tools-4.8.7-4 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
qt5-doc-tools-5.9.2-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-doc-tools-5.9.3-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-doc-tools-5.9.4-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
qt5-tools-debuginfo-5.9.2-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.3-1 - qt5-tools-debuginfo: ..
qt5-tools-debuginfo-5.9.4-1 - qt5-tools-debuginfo: ..

So "qt4-devel-tools" and "qt5-doc-tools"

You should be able to build also with Qt5.
I just build 4.4.1-rc1 with QT5

Regards
Marco



---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus







Reply | Threaded
Open this post in threaded view
|

Re: missing:qcollectiongenerator qhelpgenerator

tmacchant
    0 [main] octave-gui 5720 child_info_fork::abort: C:\cygwin64\home\CarlosDavila\Downloads\octave-4.4.0\liboctave\.libs\cygoctave-5.dll: Loaded to different address: parent(0x43CDD0000) != child(0xE90000)
error: Resource temporarily unavailable


The issue seems to be a Cygwin error but not octave one.
Therefore here is not proper place to ask about.

Please move the topic to the Cygwin ML.

Tatsuro




----- Original Message -----

>From: Carlos Davila 
>To: help-octave
>Date: 2018/7/23, Mon 08:33
>Subject: Re: missing:qcollectiongenerator qhelpgenerator
>
>
>The GUI runs, however I cannot plot. I get:
>
>
>Octave was configured for "x86_64-unknown-cygwin".
>Additional information about Octave is available at https://www.octave.org.
>
>Please contribute if you find this software useful.
>For more information, visit https://www.octave.org/get-involved.html
>
>Read https://www.octave.org/bugs.html to learn how to submitbug reports.
>For information about changes from previous versions, type 'news'.
>
>libGL error: Screen is not Windows-DRI capable
>>> plot([1 2 3])
>      0 [main] octave-gui 5720 child_info_fork::abort: C:\cygwin64\home\CarlosDavila\Downloads\octave-4.4.0\liboctave\.libs\cygoctave-5.dll: Loaded to different address: parent(0x43CDD0000) != child(0xE90000)
>error: Resource temporarily unavailable
>error: called from
>    __gnuplot_open_stream__ at line 32 column 40
>    __gnuplot_drawnow__ at line 72 column 19
>
>
>
>On Sat, Jul 21, 2018 at 12:26 PM, Carlos Davila <[hidden email]> wrote:
>
>Thank you, qt5-doc-tools was the correct package. I ran "make" from within the "~/Downloads/octave-4.4.0" directory and got:
>>
>>
>>can't read ~/Downloads/octave-4.4.0/ liboctave/liboctave.la: No such file or directory
>>
>>error: '.../octave-4.4.0/liboctave/li boctave.la' is not a valid libtool archive
>>
>>
>>I checked that directory and liboctave.la is present. I am trying "./configure", and "make", (and planned to do "make install") from within the octave-4.4.0" directory. Could this be the problem?
>>
>>
>>
>>On Sat, Jul 21, 2018 at 2:31 AM, Marco Atzeri <[hidden email]> wrote:
>>
>>Am 19.07.2018 um 22:31 schrieb Carlos Davila:
>>>
>>>Hello,
>>>>
>>>>I am trying to install octave (v 4.4.0) from source on Cygwin. After installing most dependencies, ./config gives:
>>>>
>>>>Build Octave Qt GUI:                  no (missing:qcollectiongenerator qhelpgenerator)
>>>>
>>>>However these appear to have already been installed, from package qt4-debuginfo.  The following directories exist:
>>>>
>>>>/usr/src/debug/qt4-4.8.7-3/too ls/assistant/tools/qcollection generator/
>>>>
>>>>/usr/src/debug/qt4-4.8.7-3/too ls/assistant/tools/qhelpconver ter/
>>>>
>>>>Would appreciate any suggestions.
>>>>
>>>>Carlos
>>>>
>>>>
>>>
you need the develelopment packages.

>>>/usr/src/debug is for *debuginfo packages content
>>>
>>>You can identify the package using "cygcheck"
>>>$ cygcheck -p qhelpconverter
>>>Found 10 matches for qhelpconverter
>>>qt4-debuginfo-4.8.7-3 - qt4-debuginfo: ..
>>>qt4-debuginfo-4.8.7-4 - qt4-debuginfo: ..
>>>qt4-devel-tools-4.8.7-3 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
>>>qt4-devel-tools-4.8.7-4 - qt4-devel-tools: Qt4 Assistant, Designer, and Linguist (installed binaries and support files)
>>>qt5-doc-tools-5.9.2-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
>>>qt5-doc-tools-5.9.3-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
>>>qt5-doc-tools-5.9.4-1 - qt5-doc-tools: Qt C++ application framework (development tools) (documentation generators)
>>>qt5-tools-debuginfo-5.9.2-1 - qt5-tools-debuginfo: ..
>>>qt5-tools-debuginfo-5.9.3-1 - qt5-tools-debuginfo: ..
>>>qt5-tools-debuginfo-5.9.4-1 - qt5-tools-debuginfo: ..
>>>
>>>So "qt4-devel-tools" and "qt5-doc-tools"
>>>
>>>You should be able to build also with Qt5.
>>>I just build 4.4.1-rc1 with QT5
>>>
>>>Regards
>>>Marco
>>>
>>>
>>>
>>>---
>>>Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
>>>https://www.avast.com/antiviru s
>>>
>>>
>>>
>>>
>>
>
>
>
>
>