(no subject)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

(no subject)

Yetmen Wang
I am trying to upgrade ovtave to version 1.1.1. But this new version
needs gcc-2.6 for compilation. Since I only have gcc-2.5.8, I have to
upgrade gcc as well. Can anyone give me a suggestion how to upgrade
gcc? Or is it possible I can find the binary code for octave?
I am using linux 1.1.57 in IBM-PC Compatible. Please send to me at
[hidden email].
Thanks!!

yetmen wang
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Octave 1.1.1

Ted.Harding
> I am trying to upgrade ovtave to version 1.1.1. But this new version
> needs gcc-2.6 for compilation. Since I only have gcc-2.5.8, I have to
> upgrade gcc as well. Can anyone give me a suggestion how to upgrade
> gcc? Or is it possible I can find the binary code for octave?
> I am using linux 1.1.57 in IBM-PC Compatible. Please send to me at
> [hidden email].
> Thanks!!
>
> yetmen wang
> [hidden email]
>
----------------------------------------------------------------------------
Hi,
A pre-compiled octave-1.1.1 binary for Linux can be found at the
primary octave ftp site:

        ftp.che.utexas.edu:/pub/octave/BINARIES

There are sub-directories for different systems including one for Linux.
The file octave-1.1.1.tar.gz contains the executable binary, the m-files,
documentation, info, etc - the lot!.

Octave 1.1.1 complains if it finds a version of libf2c earlier than 0.10
(but it seemed to work anyway on the version 0.9 which I had at the time).
Probably, if you have linux 1.1.57 you may have libf2c.so.0.10 or later;
but if not you can get version 0.11 from a number of places
(I used
 src.doc.ic.ac.uk:
    /computing/operating-systems/Linux/sunsite.unc-mirror/devel/fortran
)
If you do install this, BEWARE that, despite what the libf2c README says,
after copying the three library files to the specified directories
you MUST run "ldconfig" to install the shared library in the shared-lib
database. Also you will probably find, as I did, that you have to compile the
libraries and not use the pre-compiled ones, because otherwise ldconfig
will complain about "not ZMAGIC", and fail to install it.

I hope this helps: have fun with the new octave - it seems to work
really well.

Ted.                                     ([hidden email])

Reply | Threaded
Open this post in threaded view
|

(no subject)

niles-5
In reply to this post by Yetmen Wang

:I am trying to upgrade ovtave to version 1.1.1. But this new version
:needs gcc-2.6 for compilation. Since I only have gcc-2.5.8, I have to
:upgrade gcc as well.

True.

:Can anyone give me a suggestion how to upgrade gcc?

The std. way is to grab the src from prep.ai.mit.edu:/pub/gnu
Read the INSTALL file and follow the instructions.
You will also need to get libg++ from the same source.

:Or is it possible I can find the binary code for octave?
:I am using linux 1.1.57 in IBM-PC Compatible.

Yes, at ftp.che.utexas.edu:/pub/octave/BINARIES you'll find binary
dist. of octave for most machines, including linux.  Try this first
as it will be much easier.  Also, this is not a std. linux, cd /,
then tar -xf installation.  You must simply unpack the archive and
type 'make install'  Again, read any INSTALL or READMEs first.

I'm running octave 1.1.1 on my Linux 486/66 right now so if you
have any problems let me know.  The main thing I'm worried about
is that you MAY have to also upgrade you runtime c-libs, but
let me know how it goes.

        Good Luck,
        Rick Niles.
        [hidden email]