octave 4.4.0- Debian 8 stable

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

octave 4.4.0- Debian 8 stable

mathkida
HI,
After installing octave 4.4.0 on Debian 8 stable, I found it working but
without help and documentation in gui-mode. These errors were shown in
gui-msg boxes:

1. Couldnot copy help collection to temporary file. Search capabilites may
be affected. Cannot load sqlite database driver !

2. Couldnot setup the data required for the documentation viewer. Only help
texts in the console widget will be available.

Please help to fix the problem.
Thanks.
--mathkida





--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.4.0- Debian 8 stable

Andreas Weber-6
Am 23.06.2018 um 14:52 schrieb mathkida:
> After installing octave 4.4.0 on Debian 8 stable, I found it working but
> without help and documentation in gui-mode. These errors were shown in
> gui-msg boxes:

How have you installed Octave 4.4.0? I guess from source tarball?
Are you sure you've installed all dependencies and not missed the
messages at the end of ./configure? How have you run ./configure?

-- Andy


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.4.0- Debian 8 stable

mathkida
>How have you installed Octave 4.4.0? I guess from source tarball?

Yes. I used "tar -xvzf octave-4.4.0.tar.gz" to expand the sources to a
directory.

>Are you sure you've installed all dependencies and not missed the
>messages at the end of ./configure?

I used the command given on the wiki page:

For Debian 8 stable,
sudo apt-get install gcc g++ gfortran make libblas-dev liblapack-dev
libpcre3-dev libarpack2-dev libcurl4-gnutls-dev epstool libfftw3-dev
transfig libfltk1.3-dev libfontconfig1-dev libfreetype6-dev libgl2ps-dev
libglpk-dev libreadline-dev gnuplot libgraphicsmagick++1-dev
libhdf5-serial-dev openjdk-7-jdk libsndfile1-dev llvm-dev lpr texinfo
libgl1-mesa-dev libosmesa6-dev pstoedit portaudio19-dev libqhull-dev
libqrupdate-dev libqscintilla2-dev libqt4-dev libqtcore4 libqtwebkit4
libqt4-network libqtgui4 libqt4-opengl-dev libsuitesparse-dev texlive
libxft-dev zlib1g-dev autoconf automake bison flex gperf gzip icoutils
librsvg2-bin libtool perl rsync tar


>How have you run ./configure?

After expanding sources to a directory "octave-4.4.0 ", I entered the
directory and typed: ./configure (I did the same thing when I installed (
successfully) this octave version on Ubuntu 16.04.)

After the configuration was over, there were no error messages. So I typed
"make". When there were no error messages, in the same directory, i used the
command- "./run-octave" successfully. After this, I used the command "make
install" with PREFIX=/usr/local

Please let me know If I have given the full information.

Thanks.
--Mathkida





--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.4.0- Debian 8 stable

Andreas Weber-6
Am 24.06.2018 um 09:50 schrieb mathkida:
> Please let me know If I have given the full information.

Yes, very detailed, thank you.

Have you installed one of these debian packages?

libqt4-sql-sqlite
libqt4-sql-sqlite2
libqt5sql5-sqlite

You may post the output of

$ dpkg --get-selections | grep sqlite

-- Andy


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.4.0- Debian 8 stable

mathkida
>>Have you installed one of these debian packages?
>>libqt4-sql-sqlite
>>libqt4-sql-sqlite2
>>libqt5sql5-sqlite

After installing the first choice (libqt4-sql-sqlite), my problem was
solved.

Thanks a lot. You made my day.
--mathkida



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html