octave forge pkg states

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

octave forge pkg states

John Donoghue-3
Just for info,

I just ran through most of the packages on octave forge, trying to install
them on my fedora box with octave 4.4

The result of just trying to install them (after installing their
dependencies) is below. Where a package wouldn't install from octave forge,
I also tried the latest code of the repo, and where that also failed, tried
to identify (or create) a bug report.

In general packages were installed as pkg install -verbose -forge -nodeps

                                                       
Name |    Rel Version | released |    -forge
|    repo inst |  bug report | notes

============================================================================
==============
bim | 1.1.5 | 10/17/2014 | y |
| |

bsltl | 1.1.1 | 9/7/2016 | y |
| |

cgi | 0.1.2 | 9/7/2016 | y |
| |

communications | 1.2.1 | 4/4/2015 | n |
n | 46521, 45856 | cant find config.h, dep warnings

control | 3.1.0 | 3/11/2018 | y |
| | depreciated warnings

data-smoothing | 1.3.0 | 3/1/2012 | y |
| |

database | 2.4.2 | 9/18/2016 | n |
n | 53812 | cant convert octave_value_list to octave_value

dataframe | 1.2.0 | 8/14/2017 | y |
| |

dicom | 0.2.1 | 4/2/2018 | y |
| |

divand | 1.1.2 | 6/18/2014 | y |
| |

doctest | 0.6.1 | 1/4/2018 | y |
| |

econometrics | 1.1.1 | 2/17/2013 | y |
| | some dep warnings

fem-fenics | 0.0.5 | 10/31/2016 | ? |
| | untested as needs dolfin which has lots of dependencies
financial | 0.5.1 | 12/14/2017 | y |
| |
fits | 1.0.7 | 6/10/2015 | y |
| | depreciated warnings
fpl | 1.3.5 | 8/17/2015 | y |
| |
fuz log toolkit | 0.4.5 | 7/1/2014 | n |
y | | anonymous bodies parse error
ga | 0.10.0 | 4/6/2012 | y |
| | warning on depreciated continuation markers
general | 2.0.0 | 5/27/2015 | n |
n | 53813 | error no symbol_table
generate_html | 0.3.1 | 6/17/2017 | y |
| |
geometry | 3.0.0 | 3/27/2017 | y |
| | warning, invalid line in description file, unusable help
text in clipper
gsl | 2.1.0 | 8/18/2017 | y |
| | depreciated warnings
image | 2.6.2 | 11/9/2017 | y |
| | depreciated warnings, shadows rgb2gray
image-acquisition | 0.2.2 | 4/19/2015 | y |
| | warning on expected arg of type int
instrument-control | 0.3.0 | 8/8/2017 | y |
| | depreciated warnings
interval | 2.1.0 | 12/21/2017 | y
| | | depreciated warnings
io | 2.4.11 | 4/18/2018 | y |
| |
level-set | 0.3.0 | 12/17/2015 | y |
| | depreciated warnings, warning in creating cached docs
linear-algebra | 2.2.2 | 3/6/2015 | n |
y | | forge: cant find config.h, dep warnings in repo

lssa | 0.1.2 | 8/17/2012 | n |
y | | forge: lvalue required as left operand of
assignment
ltfat | 2.2.0 | 12/21/2016 | y |
| | 2.3.0 in release tracker
mapping | 1.2.1 | 2/6/2016 | y |
| |
miscellaneous | 1.2.1 | 6/5/2014 | y |
| | depreciated warnings
mpi | 1.2.0 | 1/7/2014 | ? |
| | untested no dep mpic++ installed
msh | 1.0.10 | 2/21/2014 | y |
| |
mvn | 1.1.0 | 12/30/2013 | y |
| |
nan | 3.1.4 | 8/23/2017 | y |
| | warning on unusable help text found
ncarray | 1.0.4 | 11/29/2016 | y |
| |
netcdf | 1.0.12 | 4/12/2018 | y |
| |
nurbs | 1.3.13 | 3/28/2017 | y |
| | depreciated warnings
ocs | 0.1.5 | 8/7/2015 | n |
n | 51510 | depreciated warnings, break must appear in loop
tclip | 1.0.8 | 6/16/2015 | y |
| | depreciated warnings
octproj | 1.1.5 | 6/16/2015 | y |
| |
odepkg | 0.8.5 | | |
y | | no longer available in forge?, warnings in repo

optics | 0.1.3 | 5/6/2015 | y |
| |
optim | 1.5.2 | 9/18/2016 | y |
| |
optiminterp | 0.3.5 | 4/15/2018 | y |
| | depreciated warnings
parallel | 3.1.1 | 9/24/2016 | n
| y | | forge: error unknown the_interpreter

quaternion | 2.4.0 | 3/21/2015 | y |
| | depreciated warnings
queueing | 1.2.5 | 12/6/2016 | y |
| | warning in help text: misplaced '}'
secs1d | 0.0.9 | 3/30/2012 | y |
| | all 3 secs*d merged to 1 repo
secs2d | 0.0.8 | 5/6/2009 | n |
n | 44803 | Octave_map not declared
secs3d | 0.0.1 | 9/8/2011 | y |
| |
signal | 1.3.2 | 5/25/2015 | n |
y | | 1.4.0 in release tracker
sockets | 1.2.0 | 12/3/2014 | y |
| | depreciated warnings top_level.h
sparsersb | 1.0.5 | 3/29/2017 | n |
n | 50764 | depreciated warnings, error in compile
specfun | 1.1.0 | | y |
| | dep warnings, shadow functions unmaintained 1.2.0
splines | 1.3.2 | 11/23/2016 | y |
| |
statistics | 1.3.0 | 10/9/2016 | y |
| | shadow function
stk | 2.5.0 | 9/13/2017 | y |
| |
strings | 1.2.0 | 6/6/2015 | y |
| | depreciated warnings
struct | 1.0.14 | 9/18/2016 | y |
| |
symbolic | 2.6.0 | 7/27/2017 | y |
| |
tisean | 0.2.3 | 8/14/2015 | y |
| |
tsa | 4.4.5 | 1/3/2017 | y |
| |
vibes | 0.2.0 | 6/22/2016 | y |
| | depreciated warnings
video | 1.2.4 | 5/19/2017 | y |
| | needed setenv CPPFLAGS='-I/usr/include/ffmpeg'
vrml | 1.0.13 | 6/18/2012 | y |
| |warning on using continuation marker
windows | 1.3.0 | 3/30/2018 | y |
| |
zeromq | 1.3.0 | 4/2/2018 | y |
| |

       



Reply | Threaded
Open this post in threaded view
|

RE: octave forge pkg states

John Donoghue-3
If no one is actively working on the general package at the moment, any
issues if I make modifications/prepare for release

> -----Original Message-----
> From: JohnD [mailto:[hidden email]]
> Sent: Wednesday, May 02, 2018 5:24 PM
> To: [hidden email]
> Subject: octave forge pkg states
>
> Just for info,
>
> I just ran through most of the packages on octave forge, trying to install
> them on my fedora box with octave 4.4
>
> The result of just trying to install them (after installing their
> dependencies) is below. Where a package wouldn't install from octave
forge,
> I also tried the latest code of the repo, and where that also failed,
tried

> to identify (or create) a bug report.
>
> In general packages were installed as pkg install -verbose -forge -nodeps
>
>
> Name |    Rel Version | released |    -forge
> |    repo inst |  bug report | notes
>
> ================================================================
> ============
> ==============
> bim | 1.1.5 | 10/17/2014 | y |
> | |
>
> bsltl | 1.1.1 | 9/7/2016 | y |
> | |
>
> cgi | 0.1.2 | 9/7/2016 | y |
> | |
>
> communications | 1.2.1 | 4/4/2015 | n |
> n | 46521, 45856 | cant find config.h, dep warnings
>
> control | 3.1.0 | 3/11/2018 | y
|
> | | depreciated warnings
>
> data-smoothing | 1.3.0 | 3/1/2012 | y
|

> | |
>
> database | 2.4.2 | 9/18/2016 | n |
> n | 53812 | cant convert octave_value_list to octave_value
>
> dataframe | 1.2.0 | 8/14/2017 | y |
> | |
>
> dicom | 0.2.1 | 4/2/2018 | y |
> | |
>
> divand | 1.1.2 | 6/18/2014 | y
|
> | |
>
> doctest | 0.6.1 | 1/4/2018 | y
|

> | |
>
> econometrics | 1.1.1 | 2/17/2013 | y |
> | | some dep warnings
>
> fem-fenics | 0.0.5 | 10/31/2016 | ? |
> | | untested as needs dolfin which has lots of dependencies
> financial | 0.5.1 | 12/14/2017 | y |
> | |
> fits | 1.0.7 | 6/10/2015 | y |
> | | depreciated warnings
> fpl | 1.3.5 | 8/17/2015 | y |
> | |
> fuz log toolkit | 0.4.5 | 7/1/2014 | n
|
> y | | anonymous bodies parse error
> ga | 0.10.0 | 4/6/2012 | y |
> | | warning on depreciated continuation markers
> general | 2.0.0 | 5/27/2015 | n
|

> n | 53813 | error no symbol_table
> generate_html | 0.3.1 | 6/17/2017 | y |
> | |
> geometry | 3.0.0 | 3/27/2017 | y |
> | | warning, invalid line in description file, unusable help
> text in clipper
> gsl | 2.1.0 | 8/18/2017 | y |
> | | depreciated warnings
> image | 2.6.2 | 11/9/2017 | y |
> | | depreciated warnings, shadows rgb2gray
> image-acquisition | 0.2.2 | 4/19/2015 | y |
> | | warning on expected arg of type int
> instrument-control | 0.3.0 | 8/8/2017 | y |
> | | depreciated warnings
> interval | 2.1.0 | 12/21/2017 | y
> | | | depreciated warnings
> io | 2.4.11 | 4/18/2018 | y |
> | |
> level-set | 0.3.0 | 12/17/2015 | y |
> | | depreciated warnings, warning in creating cached docs
> linear-algebra | 2.2.2 | 3/6/2015 | n
|

> y | | forge: cant find config.h, dep warnings in repo
>
> lssa | 0.1.2 | 8/17/2012 | n |
> y | | forge: lvalue required as left operand of
> assignment
> ltfat | 2.2.0 | 12/21/2016 | y |
> | | 2.3.0 in release tracker
> mapping | 1.2.1 | 2/6/2016 | y |
> | |
> miscellaneous | 1.2.1 | 6/5/2014 | y |
> | | depreciated warnings
> mpi | 1.2.0 | 1/7/2014 | ? |
> | | untested no dep mpic++ installed
> msh | 1.0.10 | 2/21/2014 | y |
> | |
> mvn | 1.1.0 | 12/30/2013 | y |
> | |
> nan | 3.1.4 | 8/23/2017 | y |
> | | warning on unusable help text found
> ncarray | 1.0.4 | 11/29/2016 | y
|
> | |
> netcdf | 1.0.12 | 4/12/2018 | y
|
> | |
> nurbs | 1.3.13 | 3/28/2017 | y |
> | | depreciated warnings
> ocs | 0.1.5 | 8/7/2015 | n |
> n | 51510 | depreciated warnings, break must appear in loop
> tclip | 1.0.8 | 6/16/2015 | y |
> | | depreciated warnings
> octproj | 1.1.5 | 6/16/2015 | y
|
> | |
> odepkg | 0.8.5 | |
|
> y | | no longer available in forge?, warnings in repo
>
> optics | 0.1.3 | 5/6/2015 | y
|

> | |
> optim | 1.5.2 | 9/18/2016 | y |
> | |
> optiminterp | 0.3.5 | 4/15/2018 | y |
> | | depreciated warnings
> parallel | 3.1.1 | 9/24/2016 | n
> | y | | forge: error unknown the_interpreter
>
> quaternion | 2.4.0 | 3/21/2015 | y |
> | | depreciated warnings
> queueing | 1.2.5 | 12/6/2016 | y |
> | | warning in help text: misplaced '}'
> secs1d | 0.0.9 | 3/30/2012 | y
|
> | | all 3 secs*d merged to 1 repo
> secs2d | 0.0.8 | 5/6/2009 | n
|
> n | 44803 | Octave_map not declared
> secs3d | 0.0.1 | 9/8/2011 | y
|
> | |
> signal | 1.3.2 | 5/25/2015 | n
|
> y | | 1.4.0 in release tracker
> sockets | 1.2.0 | 12/3/2014 | y
|
> | | depreciated warnings top_level.h
> sparsersb | 1.0.5 | 3/29/2017 | n |
> n | 50764 | depreciated warnings, error in compile
> specfun | 1.1.0 | | y
|
> | | dep warnings, shadow functions unmaintained 1.2.0
> splines | 1.3.2 | 11/23/2016 | y
|
> | |
> statistics | 1.3.0 | 10/9/2016 | y |
> | | shadow function
> stk | 2.5.0 | 9/13/2017 | y |
> | |
> strings | 1.2.0 | 6/6/2015 | y
|
> | | depreciated warnings
> struct | 1.0.14 | 9/18/2016 | y
|
> | |
> symbolic | 2.6.0 | 7/27/2017 | y |
> | |
> tisean | 0.2.3 | 8/14/2015 | y
|

> | |
> tsa | 4.4.5 | 1/3/2017 | y |
> | |
> vibes | 0.2.0 | 6/22/2016 | y |
> | | depreciated warnings
> video | 1.2.4 | 5/19/2017 | y |
> | | needed setenv CPPFLAGS='-I/usr/include/ffmpeg'
> vrml | 1.0.13 | 6/18/2012 | y |
> | |warning on using continuation marker
> windows | 1.3.0 | 3/30/2018 | y |
> | |
> zeromq | 1.3.0 | 4/2/2018 | y
|
> | |
>
>
>



Reply | Threaded
Open this post in threaded view
|

Re: octave forge pkg states

marco atzeri-2
In reply to this post by John Donoghue-3
On 5/2/2018 11:24 PM, JohnD wrote:

> Just for info,
>
> I just ran through most of the packages on octave forge, trying to install
> them on my fedora box with octave 4.4
>
> The result of just trying to install them (after installing their
> dependencies) is below. Where a package wouldn't install from octave forge,
> I also tried the latest code of the repo, and where that also failed, tried
> to identify (or create) a bug report.
>
> In general packages were installed as pkg install -verbose -forge -nodeps
>

Thanks for the report John,
very useful as guidance for my check

Unfortunately mail have screw up a bit the formatting so
please find attached the updated version with some additional
test results on cygwin 64bit where a new version was released
or my test results are in some way different.
I added a second line immediately after yours

Still works in progress, I need to test other 17 packages
between the one that have another, or more, octave package dependencies

for odepkg, I used https://bitbucket.org/odepkg/odepkg/branch/octave43
that is more advanced than SF.



octave_forge_pkg_states.txt (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: octave forge pkg states

John Donoghue-3
In reply to this post by John Donoghue-3

> -----Original Message-----
> From: JohnD [mailto:[hidden email]]
> Sent: Wednesday, May 02, 2018 5:24 PM
> To: [hidden email]
> Subject: octave forge pkg states
>
> Just for info,
>
> I just ran through most of the packages on octave forge, trying to install
> them on my fedora box with octave 4.4
>
> The result of just trying to install them (after installing their
> dependencies) is below. Where a package wouldn't install from octave
forge,
> I also tried the latest code of the repo, and where that also failed,
tried
> to identify (or create) a bug report.
>
> In general packages were installed as pkg install -verbose -forge -nodeps
>
(cut) --
>


As an update for any interested, and in a perhaps easier way to read and
injest, attempting to install the current forge packages in linux (octave
4.4.0) and ignoring warnings, I get the following package failures:

* communications 1.2.1 - the repo code also fails

* fuzzy logic toolkit 0.4.5 - the repo code did allow installing ok

* linear-algebra 2.2.2 - the repo code did allow installed OK

* lssa 0.1.2 -  the repo code did allow installed OK

* ocs  0.1.5 - sourceforge repo code also failed, but dev repo elsewhere is
OK

* parallel 3.1.1 - repo code did allow installed OK

secs2d 0.0.8 - secsXXX is one repo now, but not working


Packages not tested:

* fem-fenics 0.0.5 - had a number of dependencies that I couldn't get all
installed

* mpi 1.2.0 - I did not have mpic++ installed



If not listed above, then it installed ok.