octave-sundials for ubuntu 16.04

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

octave-sundials for ubuntu 16.04

tmacchant
I tried to install octave-sundials on 16.04


LC_ALL=C sudo apt install octave-sundials
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 octave-sundials : Depends: octave but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Perhaps my setting was wrong.

Please give me a clue to kick out the error.

Tatsuro



Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

Mike Miller-4
On Mon, Mar 19, 2018 at 15:19:36 +0900, Tatsuro MATSUOKA wrote:
> I tried to install octave-sundials on 16.04
[…]
> The following packages have unmet dependencies:
>  octave-sundials : Depends: octave but it is not going to be installed
[…]
> Please give me a clue to kick out the error.

Do you have any PPAs added to your system? In particular if you are
using ppa:octave/stable, you won't be able to install octave-sundials.

Also note that octave-sundials no longer exists in SUNDIALS 2.7.0.

--
mike



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

tmacchant
In reply to this post by tmacchant
----- Original Message -----

> From: Tatsuro MATSUOKA
> To: "[hidden email]"
> Cc:
> Date: 2018/3/19, Mon 15:19
> Subject: octave-sundials for ubuntu 16.04
>
> I tried to install octave-sundials on 16.04
>
>
> LC_ALL=C sudo apt install octave-sundials
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  octave-sundials : Depends: octave but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
> Perhaps my setting was wrong.
>
> Please give me a clue to kick out the error.
>
> Tatsuro
>

Solved the above using aptitude.
However,
configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
ode15i and ode15s will not support the sparse Jacobian feature

still appear.

Have to I build SUNDIALS by myself?

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

Mike Miller-4
On Mon, Mar 19, 2018 at 16:00:13 +0900, Tatsuro MATSUOKA wrote:
> configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
> ode15i and ode15s will not support the sparse Jacobian feature
>
> still appear.
>
> Have to I build SUNDIALS by myself?

If I'm remembering right, you need SUNDIALS 2.7.0 or higher for this
particular feature. So on Ubuntu, either build SUNDIALS yourself or
upgrade to Ubuntu 18.04 (not quite out yet).

--
mike



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

tmacchant


----- Original Message -----

> From: Mike Miller 
> To: Tatsuro MATSUOKA 
> Cc: [hidden email]
> Date: 2018/3/19, Mon 16:14
> Subject: Re: octave-sundials for ubuntu 16.04
>
> On Mon, Mar 19, 2018 at 16:00:13 +0900, Tatsuro MATSUOKA wrote:
>>  configure: WARNING: SUNDIALS IDA library not configured with IDAKLU,
>>  ode15i and ode15s will not support the sparse Jacobian feature
>>
>>  still appear.
>>
>>  Have to I build SUNDIALS by myself?
>
> If I'm remembering right, you need SUNDIALS 2.7.0 or higher for this
> particular feature. So on Ubuntu, either build SUNDIALS yourself or
> upgrade to Ubuntu 18.04 (not quite out yet).
>
> --
> mike


Thanks for information.
mxe-octave seems to build sundials-2.7.0.
I try to use the information from mxe-octave and build it.


Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

Sebastian Schöps
In reply to this post by Mike Miller-4
Mike Miller-4 wrote
> If I'm remembering right, you need SUNDIALS 2.7.0 or higher for this
> particular feature.

One needs exactly version 2.7.
(https://savannah.gnu.org/bugs/?func=detailitem&item_id=52475)

Seb.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

Sergei Steshenko
In reply to this post by tmacchant





________________________________
From: Tatsuro MATSUOKA <[hidden email]>
To: "[hidden email]" <[hidden email]>
Sent: Monday, March 19, 2018 8:20 AM
Subject: octave-sundials for ubuntu 16.04



I tried to install octave-sundials on 16.04



LC_ALL=C sudo apt install octave-sundials

Reading package lists... Done

Building dependency tree      

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

 octave-sundials : Depends: octave but it is not going to be installed

E: Unable to correct problems, you have held broken packages.


Perhaps my setting was wrong.


Please give me a clue to kick out the error.



Tatsuro


------------------------------------------------

"Perhaps my setting was wrong" - yet again, Octave packaging system is broken. It is broken because it wasn't properly spec'ed in the first place.


And this can clearly be seen from the copy-pasted by you messages:

"Building dependency tree" <-> "Some packages could not be installed" - where is the EXACT list of packages that could not be installed in the light of "Building dependency tree" ?

You and others can provide whatever particular solutions to concrete package problems, but Octave packaging system is broken. And no squandering of resources on Octave (qt) GUI can hide this fact.

The

"
The following packages have unmet dependencies:

octave-sundials : Depends: octave but it is not going to be installed

"

is a ridiculous error message - obviously any package for Octave depends on it.


--Sergei.


Reply | Threaded
Open this post in threaded view
|

Re: octave-sundials for ubuntu 16.04

avlas-2
El dilluns, 19 de març de 2018, a les 9:31:04 EDT, Sergei Steshenko va escriure:
 
  ________________________________
  From: Tatsuro MATSUOKA <[hidden email]>
  To: "[hidden email]" <[hidden email]>
  Sent: Monday, March 19, 2018 8:20 AM
  Subject: octave-sundials for ubuntu 16.04
 
  I tried to install octave-sundials on 16.04
   
  LC_ALL=C sudo apt install octave-sundials
 
  Reading package lists... Done
 
  Building dependency tree      
 
  Reading state information... Done
 
  Some packages could not be installed. This may mean that you have
 
  requested an impossible situation or if you are using the unstable
 
  distribution that some required packages have not yet been created
 
  or been moved out of Incoming.
 
  The following information may help to resolve the situation:
 
 
  The following packages have unmet dependencies:
 
   octave-sundials : Depends: octave but it is not going to be installed
 
  E: Unable to correct problems, you have held broken packages.
 
 
  Perhaps my setting was wrong.
 
 
  Please give me a clue to kick out the error.
 
 
 
  Tatsuro
 
 
  ------------------------------------------------
 
  "Perhaps my setting was wrong" - yet again, Octave packaging system is broken. It is broken because it wasn't properly spec'ed in the first place.
 
 
  And this can clearly be seen from the copy-pasted by you messages:
 
  "Building dependency tree" <-> "Some packages could not be installed" - where is the EXACT list of packages that could not be installed in the light of "Building dependency tree" ?
 
  You and others can provide whatever particular solutions to concrete package problems, but Octave packaging system is broken. And no squandering of resources on Octave (qt) GUI can hide this fact.
 
  The
 
  "
  The following packages have unmet dependencies:
 
  octave-sundials : Depends: octave but it is not going to be installed
 
  "
 
  is a ridiculous error message - obviously any package for Octave depends on it.
 
  --Sergei.

Sergei,

I don't know about the internals of Octave packaging, but I'm 100% sure that this doesn't have to do anything with it. This is an error from Debian (Ubuntu) packaging, purely and only.

Best,

....
a.