[ode45] and so

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[ode45] and so

Ákos Horváth
hey!

I got a bunch of Matlab codes which i intend to use with Octave (I only have a Macbook now, and no license for Matlab anymore).
A lot of codes use ode45 and ode23, and Octave says:
"warning: Octave provides lsode for solving differential equations.  For more
information try 'help lsode'.  Matlab-compatible ODE functions are
provided by the odepkg package.  See

Now the thing is, that link is broken, and I can't find that odepkg anywhere after hours of searching. I have Octave 4.0.3 installed, that's the newest I could find.
I really need that odepkg, or at least ode23 or ode45, can someone please help me?

Thanks,
Akos Horvath

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: [ode45] and so

Przemek Klosowski-7
On 11/16/2017 11:08 AM, Ákos Horváth wrote:
> Now the thing is, that link is broken, and I can't find that odepkg
> anywhere after hours of searching. I have Octave 4.0.3 installed,
> that's the newest I could find.
> I really need that odepkg, or at least ode23 or ode45, can someone
> please help me?
ode23 and ode45 are packaged with main octave now; on my system it's
part of octave-4.2.1-4.fc27.2.x86_64


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: [ode45] and so

Nir Krakauer-3
In reply to this post by Ákos Horváth
The newest release of Octave, 4.2, has ode45 and ode23 as built-in functions. The first recommendation would therefore be to update your Octave version. If that is impossible, you can download an old version of odepkg that has ode45, for instance from https://octave.sourceforge.io/download.php?package=odepkg-0.8.5.tar.gz

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: [ode45] and so

Sebastian Schöps
In reply to this post by Ákos Horváth
Ákos Horváth wrote
> I got a bunch of Matlab codes which i intend to use with Octave (I only
> have a Macbook now, and no license for Matlab anymore).
> ...
> I really need that odepkg, or at least ode23 or ode45, can someone please
> help me?

You can install the latest development version of octave. Then you will get
ode15i,ode15s,ode23 and ode45 without any additional a package. This is
quite easy on macOS using homebrew [1] on the command line:

"brew install octave --HEAD".

If you want to use the GUI then please follow the steps described at my blog
[2].

Bye
Sebastian

[1] https://brew.sh
[2] http://www.schoeps.org/home/2017/10/octave-on-macos-with-gui/



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave