odepkg on octave4 from PPA on Ubuntu14.04

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

odepkg on octave4 from PPA on Ubuntu14.04

Jan Groenewald
Hi

I am trying to run ode45 on octave4 from the octave/stable PPA on Ubuntu 14.04.

0 jan@muizenberg-old:~$lsb_release -d
Description:    Ubuntu 14.04.5 LTS
0 jan@muizenberg-old:~$apt-cache policy octave
octave:
  Installed: 4.0.2-1ubuntu5~octave~trusty1
  Candidate: 4.0.2-1ubuntu5~octave~trusty1
  Version table:
 *** 4.0.2-1ubuntu5~octave~trusty1 0
        500 http://ppa.launchpad.net/octave/stable/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.1-1ubuntu1 0
        500 http://za.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
0 jan@muizenberg-old:~$dpkg -l |grep octave
ii  liboctave-dev                                               4.0.2-1ubuntu5~octave~trusty1                                amd64        Development files for the GNU Octave language
rc  liboctave2:amd64                                            3.8.1-1ubuntu1                                               amd64        Shared libraries of the GNU Octave language
ii  liboctave3:amd64                                            4.0.2-1ubuntu5~octave~trusty1                                amd64        Shared libraries of the GNU Octave language
ii  octave                                                      4.0.2-1ubuntu5~octave~trusty1                                amd64        GNU Octave language for numerical computations
ii  octave-common                                               4.0.2-1ubuntu5~octave~trusty1                                all          architecture-independent files for octave
ii  octave-control                                              3.0.0-1~octave~trusty1                                       amd64        computer-aided control system design (CACSD) for Octave
ii  octave-gui                                                  0.1ubuntu4                                                   amd64        GNU Octave language for numerical computations with GUI desktop file
ii  octave-info                                                 4.0.2-1ubuntu5~octave~trusty1                                all          GNU Info documentation on the GNU Octave language
ii  octave-signal                                               1.3.2-1~octave~trusty1                                       amd64        signal processing functions for Octave
ii  octave-specfun                                              1.1.0-2~ubuntu14.04.1                                        all          special mathematical functions for Octave
0 jan@muizenberg-old:~$sudo apt-get install octave-odepkg
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 octave-odepkg : Depends: octave (>= 3.8.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
# wget odepkg....

0 jan@muizenberg-old:~$octave -q
octave:1> pkg install odepkg-0.8.5.tar.gz
warning: doc_cache_create: unusable help text found in file 'dldsolver'
For information about changes from previous versions of the odepkg package, run 'news odepkg'.
octave:2> ode45
warning: Octave provides lsode for solving differential equations.  For more
information try 'help lsode'.  Matlab-compatible ODE functions are
provided by the odepkg package.  See
<http://octave.sourceforge.net/odepkg/>.

Please read <http://www.octave.org/missing.html> to learn how you can
contribute missing functionality.
warning: called from
    __unimplemented__ at line 524 column 5
error: 'ode45' undefined near line 1 column 1
octave:2>

$sudo apt-get purge octave octave-common octave-info liboctave3 liboctave-dev
$sudo apt-get install liboctave2 octave=3.8.1-1ubuntu1 octave-common=3.8.1-1ubuntu1 liboctave-dev=3.8.1-1ubuntu1 octave-odepkg
0 jan@capetown:~$octave -q
octave:1> version
ans = 3.8.1
octave:2> ode45
ode45   ode45d 
octave:2> ode45 # ode45 is there...



Regards,
Jan


--
  .~.
  /V\     Jan Groenewald
 /( )\    www.aims.ac.za
 ^^-^^ 

Reply | Threaded
Open this post in threaded view
|

Re: odepkg on octave4 from PPA on Ubuntu14.04

Jan Groenewald
Hi

On 12 May 2017 at 12:08, Jan Groenewald <[hidden email]> wrote:
Hi

I am trying to run ode45 on octave4 from the octave/stable PPA on Ubuntu 14.04.




Stupid mistake, I installed but did not load the package in octave4. I now did install with -auto.

Is there any plan to update octave-odepkg in the PPA?

Regards,
Jan



--
  .~.
  /V\     Jan Groenewald
 /( )\    www.aims.ac.za
 ^^-^^ 

Reply | Threaded
Open this post in threaded view
|

Re: odepkg on octave4 from PPA on Ubuntu14.04

Mike Miller-4
On Fri, May 12, 2017 at 16:43:46 +0200, Jan Groenewald wrote:
> Stupid mistake, I installed but did not load the package in octave4. I now
> did install with -auto.

FYI, the -auto option has been removed in Octave 4.2. If you want to
load some list of packages at startup, it should be done in ~/.octaverc.

> Is there any plan to update octave-odepkg in the PPA?

The plan is to only add packages that people request and find useful,
and that can be backported with no effort. You're the first one to
request adding odepkg to the PPA. I'll add it to my list.

--
mike

Reply | Threaded
Open this post in threaded view
|

Re: odepkg on octave4 from PPA on Ubuntu14.04

Carlo de Falco-2
In reply to this post by Jan Groenewald

> On 12 May 2017, at 12:08, Jan Groenewald <[hidden email]> wrote:
>
> I am trying to run ode45 on octave4 from the octave/stable PPA on Ubuntu 14.04.

FYI ode45 has been moved from odepkg to core in octve 4.2

c.