odepkg

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

odepkg

Martin Johnson
Dear All,
I am new to octave and I am trying to use ode45 to solve some ODE. I tried to install package odepkg-0.8.0.tar.gz
I got the error message that
./configure: line 2693: /usr/local/bin/mkoctfile-3.4.0: No such file or directory
configure: error: Could not run /usr/local/bin/mkoctfile-3.4.0

Please give me some direction to solve this issue
I use GNU Octave, version 3.4.0
OS: Ubuntu 10.04 64 bit

Regards,
Martin

octave:8> pkg install odepkg-0.8.0.tar.gz
./configure: line 2693: /usr/local/bin/mkoctfile-3.4.0: No such file or directory
configure: error: Could not run /usr/local/bin/mkoctfile-3.4.0
the configure script returned the following error: checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for mkoctfile... /usr/local/bin/mkoctfile-3.4.0
error: called from `pkg>configure_make' in file /usr/local/share/octave/3.4.0/m/pkg/pkg.m near line 1320, column 9
error: called from:
error:   /usr/local/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /usr/local/share/octave/3.4.0/m/pkg/pkg.m at line 354, column 9


_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: odepkg

kartiman
Hi!

I've encountered a similar problem when installing odepkg-0.8.0.
I've checked and I have the octave-devel package so it is not absence of mkoctfile.

Could anyone help me?

--
/usr/bin/mkoctfile-3.4.3: line 505: g++: command not found
configure: error: Could not run /usr/bin/mkoctfile-3.4.3
the configure script returned the following error: configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for mkoctfile... /usr/bin/mkoctfile-3.4.3
error: called from `pkg>configure_make' in file /usr/share/octave/3.4.3/m/pkg/pkg.m near line 1327, column 9
error: called from:
error:   /usr/share/octave/3.4.3/m/pkg/pkg.m at line 790, column 5
error:   /usr/share/octave/3.4.3/m/pkg/pkg.m at line 361, column 9