pkg install

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg install

Tarmo Tapio
Hi

I was downloading a new package to Octave, but it announced:

 >> pkg install -forge geometry
sh: 1: make: not found
skipping line
skipping line
skipping line
skipping line

pkg: error running `make' for the geometry package.
error: called from
     configure_make at line 95 column 9
     install at line 194 column 7
     pkg at line 394 column 9

what is problem?

Tarmo



Reply | Threaded
Open this post in threaded view
|

Re: pkg install

Tarmo Tapio
My Octave verion is 4.2.2. Linux Xubuntu 18.04.

Tarmo

Tarmo Tapio kirjoitti 29.1.2019 klo 9.30:

> Hi
>
> I was downloading a new package to Octave, but it announced:
>
> >> pkg install -forge geometry
> sh: 1: make: not found
> skipping line
> skipping line
> skipping line
> skipping line
>
> pkg: error running `make' for the geometry package.
> error: called from
>     configure_make at line 95 column 9
>     install at line 194 column 7
>     pkg at line 394 column 9
>
> what is problem?
>
> Tarmo
>


Reply | Threaded
Open this post in threaded view
|

Re: pkg install

siko1056
On Tue, Jan 29, 2019 at 8:41 AM Tarmo Tapio <[hidden email]> wrote:
My Octave verion is 4.2.2. Linux Xubuntu 18.04.

Tarmo

Tarmo Tapio kirjoitti 29.1.2019 klo 9.30:
> Hi
>
> I was downloading a new package to Octave, but it announced:
>
> >> pkg install -forge geometry
> sh: 1: make: not found
> skipping line
> skipping line
> skipping line
> skipping line
>
> pkg: error running `make' for the geometry package.
> error: called from
>     configure_make at line 95 column 9
>     install at line 194 column 7
>     pkg at line 394 column 9
>
> what is problem?
>
> Tarmo
>


Do you have GNU "make" and "gcc" installed on your system?

   sudo apt-get install make

Best,
Kai 


Reply | Threaded
Open this post in threaded view
|

Re: pkg install

tmacchant
In reply to this post by Tarmo Tapio
--- k.ohlhus@

> On Tue, Jan 29, 2019 at 8:41 AM Tarmo Tapio <> wrote:
> My Octave verion is 4.2.2. Linux Xubuntu 18.04.
>
> Tarmo
>
> Tarmo Tapio kirjoitti 29.1.2019 klo 9.30:
> > Hi
> >
> > I was downloading a new package to Octave, but it announced:
> >
> > >> pkg install -forge geometry
> > sh: 1: make: not found
> > skipping line
> > skipping line
> > skipping line
> > skipping line
> >
> > pkg: error running `make' for the geometry package.
> > error: called from
> >     configure_make at line 95 column 9
> >     install at line 194 column 7
> >     pkg at line 394 column 9
> >
> > what is problem?
> >
> > Tarmo
> >
>
>
> Do you have GNU "make" and "gcc" installed on your system?
>
>    sudo apt-get install make
>
> Best,
> Kai 
I recommend you to install build-essential package.

sudo apt install build-essential

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: pkg install

Tarmo Tapio
Thank you. It works now. I have allso update my packages.

Tarmo

Tatsuro MATSUOKA kirjoitti 29.1.2019 klo 13.00:

> --- k.ohlhus@
>> On Tue, Jan 29, 2019 at 8:41 AM Tarmo Tapio <> wrote:
>> My Octave verion is 4.2.2. Linux Xubuntu 18.04.
>>
>> Tarmo
>>
>> Tarmo Tapio kirjoitti 29.1.2019 klo 9.30:
>>> Hi
>>>
>>> I was downloading a new package to Octave, but it announced:
>>>
>>>>> pkg install -forge geometry
>>> sh: 1: make: not found
>>> skipping line
>>> skipping line
>>> skipping line
>>> skipping line
>>>
>>> pkg: error running `make' for the geometry package.
>>> error: called from
>>>      configure_make at line 95 column 9
>>>      install at line 194 column 7
>>>      pkg at line 394 column 9
>>>
>>> what is problem?
>>>
>>> Tarmo
>>>
>>
>> Do you have GNU "make" and "gcc" installed on your system?
>>
>>     sudo apt-get install make
>>
>> Best,
>> Kai
> I recommend you to install build-essential package.
>
> sudo apt install build-essential
>
> Tatsuro