some notes to problems with Octave Forge website

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

some notes to problems with Octave Forge website

Olaf Till-2
Hi,

after changes within the infrastructure of Sourceforge, the Octave
Forge website experiences some problems. There are still issues to be
fixed.

Among other things, they seem to have updated our references to their
logo within many files in the html pages generated for the
packages. This affects only pages generated with elder versions of
generate_html, since the last version doesn't hardcode the logo
address. This makes it difficult to compare the package pages with my
backup... think I'll just update my backup of the package pages.

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: some notes to problems with Octave Forge website

Oliver Heimlich
Am 18. Februar 2018 12:02:07 MEZ schrieb Olaf Till <[hidden email]>:

>Hi,
>
>after changes within the infrastructure of Sourceforge, the Octave
>Forge website experiences some problems. There are still issues to be
>fixed.
>
>Among other things, they seem to have updated our references to their
>logo within many files in the html pages generated for the
>packages. This affects only pages generated with elder versions of
>generate_html, since the last version doesn't hardcode the logo
>address. This makes it difficult to compare the package pages with my
>backup... think I'll just update my backup of the package pages.
>
>Olaf
Hi Olaf,

I have updated the references to the SF.net logo in all our html pages in January. After their redesign the new logo had different dimensions and looked bad being rescaled to the old logo's size.

Apparently, the logo URL isn't working yet. I get a 404 error from the new data center. I hope this will be fixed by SF.net within the next days.

Oliver

-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------

signature.asc (515 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: some notes to problems with Octave Forge website

Olaf Till-2
On Sun, Feb 18, 2018 at 01:09:03PM +0100, Oliver Heimlich wrote:

> Am 18. Februar 2018 12:02:07 MEZ schrieb Olaf Till <[hidden email]>:
> >Hi,
> >
> >after changes within the infrastructure of Sourceforge, the Octave
> >Forge website experiences some problems. There are still issues to be
> >fixed.
> >
> >Among other things, they seem to have updated our references to their
> >logo within many files in the html pages generated for the
> >packages. This affects only pages generated with elder versions of
> >generate_html, since the last version doesn't hardcode the logo
> >address. This makes it difficult to compare the package pages with my
> >backup... think I'll just update my backup of the package pages.
> >
> >Olaf
>
> Hi Olaf,
>
> I have updated the references to the SF.net logo in all our html
> pages in January.
Ok, so it wasn't Sourceforge. I thought you had only touched the core
website files...

Anyway I've checked the consistency of my backups now.

> After their redesign the new logo had different
> dimensions and looked bad being rescaled to the old logo's size.
>
> Apparently, the logo URL isn't working yet.

Yes, I've seen that... I'd say that's their affair, not ours...

I've scanned the website now and everything seems to be fixed again,
except that it's (currently?) very slow.

If somebody still sees a bug, please speak up.

Olaf

--
public key id EAFE0591, e.g. on x-hkp://pool.sks-keyservers.net


-----------------------------------------
Join us March 12-15 at CERN near Geneva
Switzerland for OctConf 2018.  More info:
https://wiki.octave.org/OctConf_2018
-----------------------------------------

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: some notes to problems with Octave Forge website

marco atzeri-2
On 2/18/2018 2:47 PM, Olaf Till wrote:
> On Sun, Feb 18, 2018 at 01:09:03PM +0100, Oliver Heimlich wrote:
>
> If somebody still sees a bug, please speak up.
>
> Olaf
>

Not sure if is a new issue, but I am currently seeing a
bad rendering with Firefox and Chrome;
Internet Explorer looks fine but the logo
https://octave.sourceforge.io/oct.png
does not show up.



Reply | Threaded
Open this post in threaded view
|

Re: some notes to problems with Octave Forge website

Oliver Heimlich
On 30.05.2018 15:30, Marco Atzeri wrote:

> On 2/18/2018 2:47 PM, Olaf Till wrote:
>> On Sun, Feb 18, 2018 at 01:09:03PM +0100, Oliver Heimlich wrote:
>>
>> If somebody still sees a bug, please speak up.
>>
>> Olaf
>>
>
> Not sure if is a new issue, but I am currently seeing a
> bad rendering with Firefox and Chrome;
> Internet Explorer looks fine but the logo
> https://octave.sourceforge.io/oct.png
> does not show up.
The CSS couldn't be loaded (404 error although the file exists). I have
removed some cache control and the site works again. I guess that SF.net
have updated their webserver.

https://sourceforge.net/p/octave/project-web/ci/c96679425645a4e90987962a190bfbc42e3bddc8/

Oliver


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: some notes to problems with Octave Forge website

marco atzeri-2
On 5/31/2018 3:02 AM, Oliver Heimlich wrote:
> On 30.05.2018 15:30, Marco Atzeri wrote:

>>
>> Not sure if is a new issue, but I am currently seeing a
>> bad rendering with Firefox and Chrome;
>> Internet Explorer looks fine but the logo
>> https://octave.sourceforge.io/oct.png
>> does not show up.
>
> The CSS couldn't be loaded (404 error although the file exists). I have
> removed some cache control and the site works again. I guess that SF.net
> have updated their webserver.
>
> https://sourceforge.net/p/octave/project-web/ci/c96679425645a4e90987962a190bfbc42e3bddc8/
>
> Oliver
>

Thanks very much for the prompt action

Marco