Quantcast

syntax highlighting error on wiki since upgrade

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

syntax highlighting error on wiki since upgrade

Mike Miller-4
The wiki.octave.org software was updated to MediaWiki 1.28.2 this week.
Since then, I can't load any page that contains code blocks with syntax
highlighting (e.g. http://wiki.octave.org/FAQ).

It looks like someone tried to install a new version of pygments to work
with the updated MediaWiki, but it doesn't seem to be working yet. Is
someone working on this, is some help needed?

Thanks,

--
mike

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: syntax highlighting error on wiki since upgrade

John W. Eaton
Administrator
On 05/05/2017 01:55 PM, Mike Miller wrote:
> The wiki.octave.org software was updated to MediaWiki 1.28.2 this week.
> Since then, I can't load any page that contains code blocks with syntax
> highlighting (e.g. http://wiki.octave.org/FAQ).
>
> It looks like someone tried to install a new version of pygments to work
> with the updated MediaWiki, but it doesn't seem to be working yet. Is
> someone working on this, is some help needed?

I upgraded the wiki.  When I noticed that some pages weren't working, I
figured out that the likely problem was syntax highlighting.  So I tried
to fix it but I think I broke things more.  I'm not sure how to install
a new python package on the system that's running the wiki.  Jordi said
he would look at it, but I'm guessing he didn't yet?  Help fixing it
would definitely be appreciated.

jwe



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: syntax highlighting error on wiki since upgrade

Juan Pablo Carbajal-2
On Fri, May 5, 2017 at 8:27 PM, John W. Eaton <[hidden email]> wrote:

> On 05/05/2017 01:55 PM, Mike Miller wrote:
>>
>> The wiki.octave.org software was updated to MediaWiki 1.28.2 this week.
>> Since then, I can't load any page that contains code blocks with syntax
>> highlighting (e.g. http://wiki.octave.org/FAQ).
>>
>> It looks like someone tried to install a new version of pygments to work
>> with the updated MediaWiki, but it doesn't seem to be working yet. Is
>> someone working on this, is some help needed?
>
>
> I upgraded the wiki.  When I noticed that some pages weren't working, I
> figured out that the likely problem was syntax highlighting.  So I tried to
> fix it but I think I broke things more.  I'm not sure how to install a new
> python package on the system that's running the wiki.  Jordi said he would
> look at it, but I'm guessing he didn't yet?  Help fixing it would definitely
> be appreciated.
>
> jwe
>
>
>
Hi jwe,

Does this work?

pip install pygments

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: syntax highlighting error on wiki since upgrade

Carnë Draug
In reply to this post by Mike Miller-4
On 5 May 2017 at 18:55, Mike Miller <[hidden email]> wrote:

> The wiki.octave.org software was updated to MediaWiki 1.28.2 this week.
> Since then, I can't load any page that contains code blocks with syntax
> highlighting (e.g. http://wiki.octave.org/FAQ).
>
> It looks like someone tried to install a new version of pygments to work
> with the updated MediaWiki, but it doesn't seem to be working yet. Is
> someone working on this, is some help needed?
>
> Thanks,
>
> --
> mike
>

Should be all fixed now.  If anyone notes an issue, let us know.

Thank you
Carnë

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: syntax highlighting error on wiki since upgrade

Mike Miller-4
On Sat, May 06, 2017 at 15:02:04 +0100, Carnë Draug wrote:

> On 5 May 2017 at 18:55, Mike Miller <[hidden email]> wrote:
> > The wiki.octave.org software was updated to MediaWiki 1.28.2 this week.
> > Since then, I can't load any page that contains code blocks with syntax
> > highlighting (e.g. http://wiki.octave.org/FAQ).
> >
> > It looks like someone tried to install a new version of pygments to work
> > with the updated MediaWiki, but it doesn't seem to be working yet. Is
> > someone working on this, is some help needed?
> >
> > Thanks,
> >
> > --
> > mike
> >
>
> Should be all fixed now.  If anyone notes an issue, let us know.

Thanks for taking care of it.

Before I sent this mail, I had seen the same thing with pip not working,
and pygmentize showing a different version. Thanks for untangling all of
that and figuring out the MediaWiki setting.

--
mike

Loading...