texi2dvi cannot find my installed LaTeX distribution

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

texi2dvi cannot find my installed LaTeX distribution

Joseph Malkoun
when I run 
+verbatim+
brew install octave --HEAD --with-qt
-verbatim

I now face the same issue as here
Homebrew/homebrew-science#3669
texi2dvi complains that there is no TeX/LaTeX distribution, while there is, and it is in the path. I tried the workaround suggested in the link above, by editing the octave formula, but it did not work for me (same error message). I also tried --without-docs and --without-test, but these were unrecognized options for me (using MacOS High Sierra). Is this expected behavior?

I tried a brew cleanup, and I also deleted the relevant cache folders in my home folder, but it did not seem to help.

brew install octave --with-qt gets built and installed successfully by the way, which makes me think maybe it is upstream (I am not sure though).

If someone has a suggestion for a workaround, please let me know. It is strange that texi2dvi thinks there is no LaTeX installed, while it is in my PATH environment variable. My LaTeX is at

/Library/TeX/texbin/tex