Alpha GCC for compiling Octave

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Alpha GCC for compiling Octave

Eyal Doron
Hi guys!

   What GCC do I need to compile Octave on a DEC Alpha? We gave 2.6.3,
but I recall something about a higher version needed. Unfortunately,
our sys admin claims that 2.7.0 is a beta version and so refuses to
install it. Whats the truth?

Thanks,
    Eyal Doron

Reply | Threaded
Open this post in threaded view
|

Re: Alpha GCC for compiling Octave

niles-3

>   What GCC do I need to compile Octave on a DEC Alpha? We gave 2.6.3,
>but I recall something about a higher version needed. Unfortunately,
>our sys admin claims that 2.7.0 is a beta version and so refuses to
>install it. Whats the truth?
 
Octave 1.1.1 should be compiled with GCC 2.6.3. John Eaton issued
a statement saying that GCC 2.7.0 will not work with the current
Octave and people shouldn't use it to compile Octave.

However, GCC 2.7.0 is NOT a beta version in any way!  I've been using
it since it's release.  I've only found one bug which was in the
optimizer and was probably in 2.6.3 as well.  You can have mult.
versions of gcc running if your not sure about the new version.  One
controls which version is used with the "-V" directive.

e.g. "gcc -V 2.6.3 foo.c" will compile with version 2.6.3 of gcc even
if your running version 2.7.x, provided you don't delete the 2.6.3
stuff.

        Rick Niles.

Reply | Threaded
Open this post in threaded view
|

Re: Alpha GCC for compiling Octave

John W. Eaton-6
[hidden email] <[hidden email]> wrote:

: Octave 1.1.1 should be compiled with GCC 2.6.3.

Yes, you will have trouble if you try to compile 1.1.1 with 2.7.x.
However, there is a patch available via ftp from bevo.che.wisc.edu in
the file /pub/octave/README-GCC-2.7.0 that may help, but it has not
been extensively tested, and it doesn't fix any bugs other than those
directly related to compilation problems with gcc 2.7.0.

: However, GCC 2.7.0 is NOT a beta version in any way!  I've been using
: it since it's release.  I've only found one bug which was in the
: optimizer and was probably in 2.6.3 as well.

I am using 2.7.0 on an Alpha for the current development sources of
Octave.  I haven't noticed too many problems, but some things have had
to change because of changes in C++ as it evolves toward some sort of
standard.  The next Octave release will probably require 2.7.0 or
later.

: You can have mult. versions of gcc running if your not sure about
: the new version.  One controls which version is used with the "-V"
: directive.

If you do this, you have to be careful to get the right version of
libg++.  Instead of relying on the -V option, I have been configuring
gcc and libg++ using a command like

  ./configure --prefix=/usr/local/gnu/gcc/VERSION

(where VERSION is 2.6.3, or 2.7.0, etc.) so that all of the things
related to a given version of gcc are grouped together.  A default
version can be installed by making the necessary symbolic links, and a
specific version can be selected by changing PATH appropriately.

jwe